Welcome to discussions

Quick Suggestions

  • Fernatius
    32 posts

    @nicotaco87 nope they have not done much about the big game breaking bugs it seems

  • Ubi-Borealis
    Ubisoft Support Staff 2906 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • Petteflet88
    346 posts

    @nicotaco87 you mean 1.04? Did not fix anything.

  • BlitzBStone
    7 posts

    So I downloaded the patch, I’ve cleared my cache on my console, I’ve closed and reloaded the game and yet Ubba does not progress the quest. My objective still says to talk to him. I did that. I watched the cutscene with the kings dumb kid. I’ve still got a longboat parked on the road and a NECESSARY QUEST that can’t be completed. I do not have a previous save file that I can go back to because like many others I worked other quests and collected wealth and artifacts to pass the time until a patch was released. Now I’m outside of the realm of a refund, I’ve got just under 90 hours into a play through, and the only potentially viable solution is to start over and hope it doesn’t glitch out again. What did you actually fix? I want to see legit patch notes to see what missions were given higher priority than the main missions.

  • Fernatius
    32 posts

    @petteflet88 this is why people who want the game asap should not be allowed to play any games and just let the devs have their extra time to work on the game and delay the release date 😉

  • Petteflet88
    346 posts

    @fernatius agree. I rather have waited for 2 more weeks then this garbage

  • Chriswvu99
    2 posts

    @ubi-woofer let me echo another's thougths.....GO [censored] YOURSELF

  • Petteflet88
    346 posts

    @chriswvu99 yes. Exactly.

  • DanteKingM.O.W
    4 posts

    So last night i decided to restart the game. I flew through to get to the Sons of Ragnar mission and was able to complete it. After raiding with ivar before completing the quest, i tried to load my first manual save which i was level 138 and had about 60 hours of game play. Well needless to say i didnt exit ths animus fully and when i loaded my first manual save, it copied the game i was currently on and now i lost my first save. I was able to complete sons of ragnar but now i have to basically start from scratch!!!! One mad dude right now!

  • Ner0Infern0
    14 posts

    Just release an hotfix that will reset the mission for everybody and then work for a proper fix! We don’t want to wait anymore.

  • BlitzBStone
    7 posts

    @ner0infern0

    this is a way better solution than they could come up with on their own

  • Petteflet88
    346 posts

    @blitzbstone best solution ever

  • guest-VQnBB6Mo
    3 posts

    I must say it's astonishing how unprofessional Ubisoft is. Next to none communication with the community. Updates that fix nothing. And we even can't contact support?! Yesterday it was suggesting contact via chat that that didn't work and now the site is crashed.

    So maybe you should create a thread about getting our money back? We've paid for full game, not some short demo.

    This is the last Ubisoft game I've ever purchased. It's not because of the failing game, [censored] happens, bugs can occur in best games (but you should definitely fire all testing team). It's because how you're treating people, that paid for the game.

  • Agony567
    16 posts

    Okay i make it Work this worked for me a Solution and i finish the quest,i use PC.

    Uninstall the game and delete everything from folder,and i download all 51 GB again,all my save's was there cuz they are on Cloud.
    I just continue infront of the Tamensworth fort,watched cinematic and no freeze and no crash,i Finished thank to God.

    I hope this will help to others same as me,becouse this Ubisoft will do nothing

  • Nicotaco87
    24 posts

    Thé positieve thing is. There is no more boat on the road


    But now all the horses are dead

  • BlitzBStone
    7 posts

    @ubi-woofer

    legit question in regards to an offered suggestion. How can we play mission offline on Xbox One? Anytime I load into the game while offline, the moment I can move around, the game closes and informs me I need to be online to play the game

  • STREETY14
    6 posts

    It still doesn’t work why have I paid so much for a game that doesn’t even work I’ve done the update and still nothing. I want a refund

  • MooseNuugle
    22 posts

    Does anyone know what constitutes something being able to qualify for a CLASS ACTION LAWSUIT? I mean we were told if we wanted a fix send saves (Console players can’t), told to talk to customer support chat (can’t), sold a partial game and they stalled us past the 2 weeks for a refund with bull [censored] patches. Ubisoft most of us are going to need that money to buy an actual game like Cyberpunk not a demo. I figure if not we just flood Twitter and all other social media making sure no one else buys this game and get treated like this!

  • armydoc7yrs
    2 posts

    Please fix this bug asap. I've looked at the thread and there are quite a few of us whom can not continue the Main story line just because you couldn't be bothered to fix bugs before shipping. Honestly, this is ridiculous. I could understand if the issues lay with side quests and add on content but the main story line? Uuba is just standing at the dock can't talk to him and his ship is on the shores with all of his men.

  • Lo5er02
    1 posts

    @armydoc7yrs same. Thought today's patch would fix it but no luck

  • armydoc7yrs
    2 posts

    @lo5er02 As did I.

Suggested Topics

Community Details

88
Online
142.8k
Users
25.2k
Topics
131.0k
Posts