Welcome to discussions

Quick Suggestions

  • guest-7OXsteWH
    17 posts

    @ner0infern0
    Hmmm let's find out if it's related.
    Any more people that can't find Cola?
    Or maybe another Zealot (the last you need).

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • buzzin2208
    2 posts

    Been playing for over 70h and I can speak to ubba in the the sons of Ragnar quest please fix this don’t really want to start new game

  • janisabl
    1 posts

    Bought the game, i liked very much, but now, when played some time, i canot start main mision... sons of ragnar.. in the mision info is writhen speek whit ubbe, but i cant... i am standing near him, runing into him, nothing, there is no sighn talk..
    what i need to do??

  • Fernatius
    32 posts

    @guest-7oxstewh this might be far fetched but if you are stuck at sons of ragnar maybe one of the zealots is locked behind the quest/a quest which may be the reason why he wont show up.

    spoiler

    If you're not stuck at this quest then I have no idea.

  • guest-RAyzwr6F
    1 posts

    Hi I cannot progress with this after the update I want my money back

  • guest-7OXsteWH
    17 posts

    @fernatius

    I am indeed stuck on this quest, so I want to see if this certain zealot (or maybe another) is locked behind this quest. So if all people who are stuck on Sons of Ragnar can't find Cola (or another zealot), we can kind of conclude the last Zealot you need is locked behind the main quest? (No spoilers please)

  • Rathma86
    17 posts

    Still unable to progress, I can't talk to ubba. No dead horses for me, but boat is now on its side, on the path ( i slid under the mast) and all the vikings are seated like they're in a gravitron.


    What exactly did this patch "fix"?

    Can we please just get an option to drop a quest and pick it up again as a reset

  • Fernatius
    32 posts

    @guest-7oxstewh haven't found him either and yeah thats kinda why I putted in spoilers so its automatically hidden incase you want to avoid that spoiler part 😉

  • crazy_hook112
    3 posts

    I cant play ubba mission even after 1.04 patch, i have 48h in game, im stuck. Ubbisoft!!!!!!!

  • Dunstan888
    1 posts

    UBISOFT, GET THIS SORTED. I have played 30 hours and I am NOT starting a new campaign.

  • Maggotmel
    8 posts

    This has been talkes about on different forums.
    When you're at the docks and had an interaction with Ubba (had the cutscene to talk about the sons ready for battle) nothing happens.

    First there were boats on land, thats fixed(?)
    Suggestions are:
    Turn off andTravel to Norway and back (do this with and without quest marked)
    Exit/enter animus
    Change gender(and repeat the above)
    Finish different quest
    Reinstal the whole game
    start a different game(i'm 80 hours in +10are from trying to fix the bug, im not going to start again)

    Nothing works for me, i was waiting on the 1.04 patch update, but that only solved the boats.

    Ubisoft what now?

  • Fernatius
    32 posts

    @crazy_hook112 welcome to the fray xD This bug has not been fixed yet, can tell you one thing when the fix comes out I might as well set the game on highest difficulty since everything will be oneshotted pretty much. Eivor on steroids on a low level quest 😂

  • Fernatius
    32 posts

    @dunstan888 I'm at 90+ hours now since I just let the quest be for now and did some other stuff while waiting for a fix patch

  • Rathma86
    17 posts

    @fernatius i feel this comment, 94hrs in and unable to do the first questline hahahaha.

    My settlement is at lvl 5, I am power 230 😕

  • Thelise
    6 posts

    My husband can't get past talking to Ubba, the ship is still on the road. He's done a -ton- of other side quests, and has tried every suggestion I've found in here trying to fix it. On my account, I managed to play through the quest just fine. My bugs are more related to the world events acting up. I'm so disappointed that they didn't fix this quest in the patch. ☹️ And looking at their list of 'updated bugs', Sons of Ragnar is no longer listed.

  • AVA0723
    5 posts

    @maggotmelvin right there with you. This is unreal.

  • Rathma86
    17 posts

    @ava0723 so much for the fix.

    Most of us have reignited older threads because this is still an issue.

  • crazy_hook112
    3 posts
    This post is deleted!
  • crazy_hook112
    3 posts

    @fernatius i have allready power 120, so ya, hope they fix it with de future update, i want to finish all game

  • Speedbum99
    1 posts

    OK, just to echo everyone else...the patch DIDNT FIX THIS ISSUE!!! Sons of Ragnar - Speak to Ubba is STILL BROKEN - hey UBISOFT...you even listening or care??? Not sure I've ever encountered an issue like this on any of your games...so pretty shocked by it, so after dropping $120 on it...I kinda expected a complete game! When will this be resolved???

Suggested Topics

Community Details

32
Online
192.3k
Users
32.4k
Topics
162.1k
Posts