Welcome to discussions

Quick Suggestions

  • Spier1991
    15 posts

    @ilikepaninis did the boat flip for you like it did for me?

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • Lokin1980
    2 posts

    Same here. Still can't speak to Ubba. Definitely won't be buying the next one upon release. They can't even get off their asses and fix this bug.

  • Lokin1980
    2 posts

    Still can't talk to Ubba after update. Definitely won't buy the next game. Ubisoft really screwed this up. Can't even get off their asses to fix this bug that's halted the main story but can fix stupid [censored] like petting animals and gear balancing. Idiots.

  • revforlife
    12 posts

    @guest-r874m0ck Like putting a shiny new coat of paint on a broken-down car....JUST FIX THE CAR!

  • BlitzBStone
    7 posts

    @ubi-woofer

    i started a new save to try to see if I could play the mission through. In the new play through, I made it to England and began setting up camp. Ran into a hiccup that was remedied with an early auto save, reading the letter about the berserker mission made it impossible to speak to randvi. I was able to accept the mission to go to repton and was able to successfully play through the mission. No glitch after speaking to ubba. The difference between my glitched play through and the successful was not raiding tamsworth prior to the mission. Tamsworth already being raided may be a culprit for other people but only one person replied early to my question about having raided it prior to beginning the sons of Ragnar quest line. Hopefully this information is able to help the process along for patching the mission. This was accomplished on the Xbox One version of the game.

  • T4wksicka
    2 posts

    Been stuck on this for like a week now. Trying to kill time by doing other things, world events and such. When I try to talk to ubba, there's a long boat on the path. Though the speak option isn't available anyway. There's also a few horses scattered about, on ship debris and on the bale of hay by ubba. I'm over 60 hours in and have unlocked many legendary animals and killed quite a few zealots. If this isn't fixed soon I'll be quite frustrated. I'm also able to see Sigurd but I can't talk to him either. The friendly teal dot doesn't show up above him when I use odin's vision as well. Where Sigurd is standing it's all dark and rainy. But when I cross the border when reptons name shows up, where ubba is standing, it's all sunny. I've tried exiting the animus, travelling to Norway, coming back and reselecting the mission all to no avail. Sometimes the questmarker shows up, sometimes not.
    😧

  • bramjagh
    1 posts

    I am also unable to speak to Ubba. I tried travelling back to Norway and then England all that did was remove the boat from the road... When is this being addressed??

  • Nickydubb1015
    1 posts

    After speaking with ubba in sons of ragnar quest, nothing happens. Cannot progress through the story and I know many other people are having the same issue. You just released a patch but this was not fixed?? When is this going to be fixed? Beginning to think I wasted my money..

  • JenovaQProject
    8 posts

    I'm stuck at the end of this quest, once you take the fortress with Ubba and Ivar.

    I can't leave the fortress afterwards, after the new quest "Bartering" comes up. No fast travel of any kind, and the Animus won't let me out, neither by unplugging Layla from it nor trying to walk or ride away.

  • buzzin2208
    2 posts

    @buzzin2208
    anyone at Ubisoft help

  • Rathma86
    17 posts

    @spier1991 mine was on its side, on the path

  • zwesley11
    3 posts

    I may have a fix. I let my character be killed. When the game reloaded the cutscene played again and it fixed the issue. For me, at least.

  • Petteflet88
    346 posts

    Poehhh... still waiting and it seems like even more People get stuck on this.

  • Petteflet88
    346 posts

    @zwesley11 how did you let him die? Were you at this bug for a long time? I honoustly think that nothing works at this moment when you have this bug for quite some time.

  • Petteflet88
    346 posts

    @guest-7oxstewh where did you find this?

  • Spittovski321
    1 posts

    I have the same issue on PS4 boats in the middle of the land can't speak to Ugga and it seems like the only way that may work is to restart from an earlier save at the beginning of the episode so people are saying but I'll lose close to 20 hours of gameplay and majority of my loot and upgrades, their should be an easier way to abandon quest and restart instead of losing so much progress

  • zwesley11
    3 posts

    @petteflet88 When I reached the fort, the cutscene started, but the game kicked me out. I started the game again, and I was standing in front of the fort with no cutscene and no marker to tell me where to go. I was stuck for a good 10 minutes, only to look up a fix. Then I just climbed the fort wall and let myself get killed. When the game reloaded, the cutscene started up again.

  • Petteflet88
    346 posts

    @zwesley11 yeah you reached the fort. Most of us are still waiting for Ubba to even want to go to the fort... ubba is not speaking.

  • zwesley11
    3 posts

    @petteflet88 Ah. Sorry about the misunderstanding. I promise I'm not joking when I say, "Try letting yourself get killed."

  • Petteflet88
    346 posts

    @zwesley11 its oke... at this point, since Ubi does not react, all information is welcome

Suggested Topics

Community Details

47
Online
192.8k
Users
32.5k
Topics
162.6k
Posts