Welcome to discussions

Quick Suggestions

  • guest-7OXsteWH
    17 posts


    Yes, I raided it too, and there are a lot of Vikings cheering in front of the fort, as if the quest is completed, even though I can't talk to Udda.

    I'll reask my question from a few posts above this one.

    Is there anybody else who can't complete this quest and CAN'T find Cola the Zealot? So far there is one other person with the same problem.

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • Manorm3
    1 posts


    I was looking for Cola for about 2 years the other day. I even waited on the crossroads on his path for an hour to see if he showed up. He is the only Zealot I havent find and yes I can not speak to Ubba. I guess they are linked

  • guest-7OXsteWH
    17 posts


    I guess they are tied then. 3 of us, unless someone can tell us they did find Cola and are stuck on this quest. (unless it's always the last zealot you need that you're stuck on...)

  • Rinadon93
    14 posts

    They have made their money and dont give a F about our problems with this mission. Im done.

  • skullr4fael
    3 posts

    Level 320, 100h+ and still cant attack the castle, Ivarr still stuck in nothing and without interact 🙂 Tks Ubisoft for this awesome game. 😉

    94 posts

    @spittovski321 I feel you, try 80 hours 😂20 is bad enough

    94 posts

    @zwesley11 I tried drowning myself in Repton like someone suggested, it didn't restart the mission unfortunately

    94 posts

    @petteflet88 it is, there's a bigger section of pre patch issues and it's in three, they do know about it, it's just the patch didn't work unfortunately

    94 posts

    @petteflet88 I vaguely remember him, feels like a century ago 😂

  • omer2k
    1 posts

    same here

  • Ner0Infern0
    14 posts

    We have to insist for a fix! The bug isn’t even addressed in the known issue post!

  • Petteflet88
    346 posts

    @ilikepaninis haha, i forgot everything about him...

  • Petteflet88
    346 posts

    @ner0infern0 tell me what we can do more then this?

  • Maggotmel
    8 posts

    If we make a new post every other day
    Some will get deleted then we know ubisoft sees them.
    No escape at that point....

  • Ewwa18
    5 posts

    Yep. 50 hours in and I've been stuck at ”Talk to Ubba” for 30 of them. It's pretty bad when the MAIN QUEST is bugged.

  • Petteflet88
    346 posts

    @maggotmel some People got banned actually.

  • guest-7OXsteWH
    17 posts

    From the known issues post:



    • The Ingot looted off the Destroyer in Hamptun Blockade is not counted towards wealth territory completion 
    • Items lost due to dual-wield issue
    • Splash Screen freeze
    • Cannot interact with Reda
      • In the meantime, completing the Cent story arc should trigger an event at the settlement that should allow players to interact with Reda.
    • Cannot proceed with several quests:
      • The Big Finish
      • A Rivalry for the Ages
      • Smashing The Compass
      • Bleeding The Leech

    This quest is not planned in a future update it seems. Guess it's not important to progress through a main quest. But the Norwegian sea life seems to be high on the agenda. What is this, Greenpeace?

  • Fernatius
    32 posts

    @blitzbstone @Ubi-Woofer @guest-7OXsteWH I wouldn't say having raided Tamsworth before the quest would be the culprit, since I have not done raided it before the quest. However I have done a second playthrough kinda speedran through the story to get to the quest but instead of exploring repton before goin to Ubba I went straight to Ubba and didn't do anything else besides following the story which made me able to continue. My first playthrough I came to repton went to talk to Ivarr *random crash happened* tried again continued following Ivarr and when I had to talk to Ubba I kinda went exploring repton grabbed some lootchests and did the flyting and then I went to Ubba which after the cutscene became bugged.
    It might be because I deviated from the direct story quest that it got bugged or it seems like that would be the case.
    Back then the ship just went on without Ubba, I even saw where the ship went. I reloaded and ship suddenly was on the road. Went back and forth from Norway to England which did not help it either. Before I knew it I had no autosave before this happening and I sadly saved at the bugged moment cuz I wanted to see if turning it off and on would help which did not work either. I've done literally everything there is to try to fix it but Ubba stay bugged. If the boat is not on the road the marker on Ubba is also gone, is the marker there then the boat is also on the road.
    Hoping this info might give devs a lead on how it got stuck.

  • Fernatius
    32 posts

    I still need the quest to be fixed tho, since I just continued doing other stuff in wait for a patch to fix it and have a lot of hours spend into it.

  • Maggotmel
    8 posts

    Anybody else with an idea?
    This is the first time in my life that im folowing a solution on a game bug

Suggested Topics

Community Details