Welcome to discussions

Quick Suggestions

  • guest-7OXsteWH
    17 posts

    From the known issues post:

    ISSUES ADDRESSED IN FUTURE UPDATE 

    ALL PLATFORMS 

    • The Ingot looted off the Destroyer in Hamptun Blockade is not counted towards wealth territory completion 
    • Items lost due to dual-wield issue
    • Splash Screen freeze
    • Cannot interact with Reda
      • In the meantime, completing the Cent story arc should trigger an event at the settlement that should allow players to interact with Reda.
    • Cannot proceed with several quests:
      • The Big Finish
      • A Rivalry for the Ages
      • Smashing The Compass
      • Bleeding The Leech




    This quest is not planned in a future update it seems. Guess it's not important to progress through a main quest. But the Norwegian sea life seems to be high on the agenda. What is this, Greenpeace?

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • Fernatius
    32 posts

    @blitzbstone @Ubi-Woofer @guest-7OXsteWH I wouldn't say having raided Tamsworth before the quest would be the culprit, since I have not done raided it before the quest. However I have done a second playthrough kinda speedran through the story to get to the quest but instead of exploring repton before goin to Ubba I went straight to Ubba and didn't do anything else besides following the story which made me able to continue. My first playthrough I came to repton went to talk to Ivarr *random crash happened* tried again continued following Ivarr and when I had to talk to Ubba I kinda went exploring repton grabbed some lootchests and did the flyting and then I went to Ubba which after the cutscene became bugged.
    It might be because I deviated from the direct story quest that it got bugged or it seems like that would be the case.
    Back then the ship just went on without Ubba, I even saw where the ship went. I reloaded and ship suddenly was on the road. Went back and forth from Norway to England which did not help it either. Before I knew it I had no autosave before this happening and I sadly saved at the bugged moment cuz I wanted to see if turning it off and on would help which did not work either. I've done literally everything there is to try to fix it but Ubba stay bugged. If the boat is not on the road the marker on Ubba is also gone, is the marker there then the boat is also on the road.
    Hoping this info might give devs a lead on how it got stuck.

  • Fernatius
    32 posts

    I still need the quest to be fixed tho, since I just continued doing other stuff in wait for a patch to fix it and have a lot of hours spend into it.

  • Maggotmel
    8 posts

    @petteflet88
    Well...action-reaction
    Anybody else with an idea?
    This is the first time in my life that im folowing a solution on a game bug

  • Petteflet88
    346 posts

    Yeah I have never been stuck on a game for so long either... it is really painful and not seeing it on the known issues makes it more painful 😞

  • SLXW75
    13 posts

    Ubisoft please, REACTION??????

  • Petteflet88
    346 posts

    Have a nice weekend all 😞

  • LeoneMcGee
    2 posts

    Please help fix this. I’ve tried everything under the sun on trying to fix this and nothing is working. I’ve been a week now. It says to talk to ubba on the beach and when I walk up to him it doesn’t allow me to talk to him. I was trying to upload a picture but it’s too big to upload. Please help. Cause I can progress that story anymore

  • LeoneMcGee
    2 posts

    After encountering this issue I decided to continue with everything thinking that pledging to another quest and coming back to it would fix its. So going to a different save won’t work for me.... for I’m now.... 20 hrs plus from that save point @ubiexcellent

  • Petteflet88
    346 posts

    @leonemcgee i am 90 hours in

  • Isaacjohnson243
    1 posts

    I have a playstation 4 and iam having problems with the mission speak to ubba by the docks

  • SteampunkZapper
    12 posts

    The 1.04 patch did NOT fix this on PS4. When I was in the area, I did finally get a prompt about a nearby mission, which had not happened before. I had hopes. I went to the spot, and the fully manned longboat was in the road, gently rocking back and forth with the waves. Of the road. Again. Still. Ubba had the quest icon over his head. I could not interact with him. At. All. I can't even kill him. After this many hours, I'd gladly watch him burn since I can't do anything else with him. I guess I'll spend my time looking for map holes to glitch into the few treasure rooms i have left to access.

    Also, why don't the legendary animal heads appear mounted in the longhouse? What's the point if I can't even look at it?

  • Petteflet88
    346 posts

    @steampunkzapper it is not even on their acknowledged issues (known issues topic), so we are basically left alone

  • Graybeered
    4 posts

    105 hrs in, doing the side quests, and almost done with the order hit list. Cant believe that this wasn't addressed! It's a main quest ffs...

  • SteampunkZapper
    12 posts

    @petteflet88 Yeah, I saw that too. With so many people having that issue, you'd think it might matter. I think Fernatus has a point though - if the ship is in the road, then Ubba has the quest marker. If it's not there, he doesn't. Rather, if I deselect the quest, it removes the ship from the road.

    Funny, they fixed the non-game breaker bug. Sort of. I still have dead, curled on their side zombie fish swimming around, but it no longer plays the creepy "juggling invisible boobs or a big fish" animation when Eivor catches one. It just doesn't play an animation anymore. https://www.reddit.com/r/AssassinsCreedValhala/comments/k1lsa5/it_was_this_big_fishing_animation_bug_aside_from/?utm_source=share&utm_medium=web2x&context=3

  • SteampunkZapper
    12 posts

    @maggotmel So far, I've tried:

    • uploading my profile and last save, deleting all saves from my console, and downloading those two saves. It fixed the corrupt data save bug, so I figured it wouldn't hurt to try for this.
    • Deleting the game completely and redownloading it.
    • coming to Repton with no quest selected, and then selecting 'see nearby quest', not selecting the quest at all, and having it selected before I come to the area.
    • Dying near Ubba.
    • Kiting enemies to the area
    • Completing the Asgard quests.
    • Doing other stuff in other areas and returning on foot, and by fast travel
    • turning it off and on again
    • cursing at Eivor, the devs, Ubisoft, the internet, Sony, and anything else I could think of
    • clearing Repton of all wealth, mysteries and whatever the third thing was.
    • leaving the ship in different places
    • going to where the next step in the quest would be if it progressed - by foot, by horse, and by boat (as far as possible)
    • using different armor sets, and different equipped weapons

    None of that worked. I have the exact same setup, system and game version as my husband, but he doesn't have this bug and I do. He focused more on story line over exploration, and I focused more of exploration - getting those fast travel points. I particularly hate that this seems to be tied to not immediately following the next step in the questline because Sigurd and Ubba's Sleezeball Brother specifically tell you to go explore the town a little and meet Ubba when you're ready.

  • guest-7OXsteWH
    17 posts

    @graybeered
    Did you find Cola, the Zealot?

  • SteampunkZapper
    12 posts

    @petteflet88 When the boat is in the road, he's standing looking out over the river. You can't interact with him either.

  • DGM1992
    8 posts

    Day 17 since this game broke for me.... Ubisoft fix your broken game!! Not even bothering playing this till it’s fixed no point anymore !

Suggested Topics

Community Details

45
Online
192.8k
Users
32.5k
Topics
162.6k
Posts