Welcome to discussions

Quick Suggestions

  • ILIKEPANINIS
    94 posts

    @fernatius dude, I'm in work for a while yet but when I get on later I'm gonna see if he's under the ground for me too out of curiosity

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • ILIKEPANINIS
    94 posts

    @blackbird08 exactly the same dude, I have three missions bugging 🤣

  • Fernatius
    32 posts

    @ilikepaninis what you might expect (this is the big rock on the left of Ubba close to the water) I used Odin's sight to see this npc markerundefined

  • DeathlyPoetic
    13 posts

    I have the NPC in the rock as well

  • Rinadon93
    14 posts

    I didnt even know that ivarr was meant to be there 🤣🤣 as if hes been stuck in a rock this whole time. Didnt know he was an xmen

  • Fernatius
    32 posts

    Well I'm only guessing its Ivarr since I can't find him anywhere and on a walkthrough I do see him on a horse riding with Eivor to Tamsworth. And it would make sence for the quest to be stuck if there was a crucial character wasn't able to move to where he was suppose to. Well guess Ivarr the boneless got scared of the battle for Tamsworth and crawled under his rock

  • DHangelfan16
    24 posts

    Guys, the next patch won't fix this either.

    We're still at least 2 weeks out from another fix.

    RIP Ubisoft.

  • MolodoyRoze
    2 posts

    Let's crash the ranking of this game across all sorts of platforms. It will be fair, not those paid reviews.

  • ShopsLA
    11 posts

    Come to think of it.. Ivarr wasn’t present in my game after the Ubba freeze either. Might be an important piece to this bug puzzle. Only saw Sigmund/Ubba. No sign of kings son either.

  • Fernatius
    32 posts

    @shopsla found the king's son hitting a log with a knife in the town or walking to the tradestore or goin to the ships at the docks in the north. No sign of Ivarr anywhere nor at Tamsworth checked if he went ahead but couldn't find him.

  • Ner0Infern0
    14 posts

    @ubi-woofer

    Please just force restart the quest for anyone who didnt complete it and then work for a real fix, so we can play the game we paid for.

  • Kyshakysha
    4 posts

    I recieved my game on launch day and ran into this Ubba problem 4 days later. I have been patiently waiting for Ubisoft to solve this issue, but my patience has it's limit. Luckily, for me, I did not buy a digital copy of this game and my $110 hard copy is returnable until mid January. If this GAME-BREAKING GLITCH isn't fixed soon I will be returning my copy for a full refund.

    I am probably one of the very few people who had never encountered glitches with ANY game before Assassin's Creed Valhalla. This has been greatly disappointing. The only positive I can take from this experience is that I've learned from others' complaints to NEVER BUY A DIGITAL COPY , as Ubisoft doesn't seem to want to extend the refund window.

  • EmoKid199387
    19 posts

    @fernatius ya know I got on my game today did Odin sight right there and have that blue dot there to. It might be the last piece of this grueling puzzle ubisoft needs

  • Thelise
    6 posts

    @guest-7oxstewh @BlitzBStone

    My husband raided Tamworth before the quest and also can't find Cola. He sat there for 30 minutes last night, trying to find the zealot because it's the last one he needs. Never showed up. And Ubba is still super fudged for him.

  • Maggotmel
    8 posts

    This is going great.
    Spend 2 hours looting and lost it all.
    Manual and auto save did not work due no connection to ubisoft server?!
    What is going on?!!!??

  • mdrdom
    7 posts

    How do we go about getting refund. Can’t talk to Ubba, can’t bring paint in Asgard, Cola is missing. Can’t even play now.

  • rajansbox
    1 posts

    Cannot speak to Ubba in SOR mission.

    Tried all the suggestions- no manual save within 10 hours. Figured it would be fixed with the patch. It wasn’t.

    44 hours in and now I cannot start Walls and Shadows. Load screen starts as if a cut scene were going to take place then after 2-3 minutes of black screen with background audio the game freezes and my only option is to exit to title screen. So now what?!

    I cannot progress the story any further since both story lines are dead.

    Requested refund on download copy last week and no response.

    I know the poor guy reading this with UbiSoft can’t help it but corporate really screwed this one up.

    This may be the last Ubisoft I buy and I absolutely will never pre-order again,

  • Atheros763
    2 posts

    Tried all the fixes said by other users but still doesn't work for me. Ubisoft, please take note of this bug. Alot of players are forced to start over. The 1.0.4 patch doesn't seem to take care of it. We've had smoother playthroughs with Origins and Odyssey. What's going on???

  • Spier1991
    15 posts

    Some people were asking about a zealot named cola. I have that one on my order page but can no mark him or locate him anymore. Im mot sure what happened there.

  • Seanoborn
    2 posts

    I’m having the same issue. Playing with PS4

Suggested Topics

Community Details

60
Online
141.1k
Users
24.9k
Topics
129.2k
Posts