Welcome to discussions

Quick Suggestions

  • Spier1991
    15 posts

    Some people were asking about a zealot named cola. I have that one on my order page but can no mark him or locate him anymore. Im mot sure what happened there.

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts
    Best Answer

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • Seanoborn
    2 posts

    I’m having the same issue. Playing with PS4

  • VoidzLV
    1 posts

    I haven’t been able to proceed with the main story. I know the next thing that was supposed to happen was I was supposed to meet sigur up north who was with the Ragnar brothers. I did side missions for a while not knowing I couldn’t proceed with the main story so I’m stuck. I gave up on the game until a fix can come out and I can finish the story.

  • FallingCobra
    3 posts

    @ava0723 Same here, very frustrating

  • FallingCobra
    3 posts

    @ewwa18 Still broke for me to, Ubisoft please fix this asap!

  • FallingCobra
    3 posts

    I have the same issue to. Hope to hear from Ubisoft soon, it's killing the fun of the game for me!

  • MGAZZA89
    1 posts

    Same issue as everyone else, I have completed the other main quests in hope it would restart the sons of Ragnar one but I’m still left at the docks unable to speak to Ubba, are we going to get an update to fix this????

  • Dark-Coco
    17 posts

    Any news on this quest? I haven't played Valhalla since being on these forums... like, 2 weeks ago. I literally can't play the game and Ubisoft haven't responded about a refund yet. I knew they'd get a lot of emails about this, so I gave it time, but it's been over a week now, probably closer to 2?

  • ILIKEPANINIS
    94 posts

    @dark-coco 19 days dude I think it is

  • Fernatius
    32 posts

    Tbf I dont think you should expect any news at moment since its weekend.
    The only close thing I found to why the quest is stuck might be Ivarr missing/stuck in the ground which may be interfering with the quest being able to continue.
    I have made a case ticket about this late on friday and would only expect them to have checked it starting by monday.
    Gonna put this screenshot in again and yes multiple people have said they found an npc marker in the ground when they used odin's sight like this close to Ubba.
    undefined

    As for the missing zealot, might have to do that one or some of em are locked behind the story of the sons of ragnar. I can tell you why I think that, I can't say with 100% certainty this is the reason why it's just a speculation. For the sake of people not wanting to be spoiled I'll put it in spoilers. I'll even try not to name npc's or anything to not spoil too much.
    spoiler
    That said I hope the info I found about Ivarr missing and the npc marker I found under the ground might be the reason this quest is stuck and helps the devs to fix it and hopefully someone of the support team sees this.

  • Kyshakysha
    4 posts

    I uninstalled then reinstalled the game only to find a different, smaller boat toppled over, halfway onto the road with people rowing inside, while Sigurd stands on a rock behind them looking out towards the river. Is Sigurd even supposed to be there? I'm pretty sure he's not supposed to be there.

  • Petteflet88
    346 posts

    Guys, they are not going to fix this.

  • ILIKEPANINIS
    94 posts

    @fernatius he wasn't out of the map for me but still nowhere to be seen

  • Fernatius
    32 posts

    @kyshakysha from what Ive seen it's you riding together with Ubba, Ivarr (who's missing presumably under a rock somehwere) , Coelbert (who seems to be still in town trainin with a knoif) and Sigurd. Then a whole bunch of dialogue back and fort while goin to Tamsworth.

  • Fernatius
    32 posts

    @ilikepaninis heh, Ivarr the boneless they say more like bore ragnaro... sorry bad joke from a youtuber but more like Ivarr the appearless

  • CrystalSinger88
    2 posts

    I've been hoping for a fix for around 10 days now. I thought it would happen quickly given that it is a main quest and so kept playing. I'm now 40 hours in and there still is no fix. I've raised a case with Ubisoft as this is now getting to the point the game is unplayable. I'm not prepared to start from scratch when there is a chance the bug will still be present.

    Originally, it let me speak to Ubba and the cut scene played but after there was no further information/action. The game hadn't registered that I had spoken to Ubba and so the quest is still active. Sometimes when I check the longboat will be on land (usually if I fast travel to the port) but some times it is not (usually if I fast travel to the sync point). However, I am never able to speak with Ubba. It's really disappointing to spend so much money on something to not even have the bug acknowledged from ubisoft on this thread.

    Fixes I've tried that don't work:

    • Travel to Norway, travel back (with quest on and off)
    • Exit the Animus (with quest on and off)
    • Fast travel to different locations
    • Go by boat
    • Pledge to other areas and then re pledge
    • Tried at different times of day
    • Tried turning on and off again


    Not prepared to try and uninstall and reinstall when I have put so much time into the game thinking that this would be acknowledged and fixed early without a guarantee it will be fixed and some sort of compensation for the trouble or a refund.




  • BuckStalion8294
    3 posts

    @fernatius I hope Ubisoft reads this, because this is ridiculous and you are the people’s champion at this point lol

  • Petteflet88
    346 posts

    Guys, they are NOT going to fix this

  • mrdeadhead
    10 posts

    I met ubba (had to track him down since there's no mission icon on him) he said something about attacking somewhere and now the mission just says talk to him again. his longships even rolled out, and I tried following them to see if they will just trigger the next stage, but no they just kind of meander down the river aimlessly. on ps4

  • GORE-rilla
    1 posts

    For anyone asking where Ivarr is during this part of the glitch. You can find him [censored] on the church near the tent when you first spoke to him. Where the king is currently located.

    Nothing has worked for me to fix this quest. The travels to Norway etc. I've bumped Ubba into the river and he just walks back to the same spot. I've bumped Sigurd and Ivarr nothing helps. I'm very annoyed because I have put nearly 70 hours in the game literally doing everything else since release. They just need to get a hot fix out already.

Suggested Topics

Community Details

77
Online
140.5k
Users
24.8k
Topics
128.3k
Posts