Welcome to discussions

Quick Suggestions

  • harvydanger81
    1 posts

    Upon settling in Britain I opted to go to Grantebridgescire from Randvi. Once I completed that quest chain Sons of Ragnar does not show up, the cut scene does not trigger nor do the NPCs show up in Repton. I sent a ticket in that was closed stating this was fixed last month and I am writing to share that it is not and I am unable to proceed. It was not made clear in the master thread for the next update that this scenario has been addressed.

    Thank you.

  • maloydis785
    1 posts

    @ubi-woofer I’m still not able to talk to ubba

  • Ubi-Borealis
    Ubisoft Support Staff 3847 posts

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • Kerryl72
    2 posts

    This is still very broken. Did the fix ever go out? I can't meet Ivar or talk to Ubba. I should up via the boat location, get out and can't find them anywhere. Totally blocked. Based on what I have found on Reddit it sounds like this has been going on for months now.

  • Kerryl72
    2 posts

    @ubi-borealis How do I record a video to do this? You want us to just use our phone?

  • thysdk
    5 posts

    @rajansbox thank you for your post, I have the exact same issue at the moment with the Quest "Walls and Shadows". (Playing on PS4)

    Tried running to the wall from different angles and keeps on happening. Loading screen starts as if a video must play but nothing, just a dark screen and when its done the game freezes.

  • Ubi-Borealis
    Ubisoft Support Staff 3847 posts

    Hello there!

    @Kerryl72 - Apologies for the delayed response. You can record a video using a camera or mobile phone. You may also find you can use other programmes, depending on the platform you use. For instance, on PS4 you can record and share footage using the "Share" button on your PS4 controller. You can then share a link to the video within this thread.

    @thysdk - I'd recommend checking out our megathread list to see if you can find a more suitable thread for the issue you're encountering in "Walls and Shadows."

    Thanks all! 😊

    Official Response
  • Bella0290
    1 posts
    Sons of Ragnar is bugged, when I meet them at the docks, nothing happend, the should say mount up, is i long trip to tamworth! Can't get any longer on the history 😕
  • Ubi-Mark.
    Ubisoft Support Staff 1541 posts

    Hello @Bella0290,

    Thank you for bringing this to our attention!

    Can you please provide us with a short video of this occurring along with the platform that you're currently playing on, so we can have a look? Many thanks and if you have any other questions, please let us know.

    Official Response
  • bryantlee97
    2 posts

    @ubi-borealis So I can talk to them and then when I head into templebourgh nothing happens. I walk to the basement room with the iron door and nothing happens

  • Ubi-Borealis
    Ubisoft Support Staff 3847 posts

    Hello there,

    As we have received no further reports of this issue happening in-game following the release of TU 1.1.1, we will now be locking this thread. If you continue to encounter trouble with "The Sons of Ragnar," please don't hesitate to open up a new thread. A member of the player support team will take a closer look as soon as they are able to.

    Thank you 😊

    Official Response

Suggested Topics

Community Details

89
Online
220.2k
Users
37.2k
Topics
184.5k
Posts