Welcome to discussions

Quick Suggestions

  • darkrexje
    1 posts

    Still no fix it seems for players that already talked to him.... Boat still in the middle. Guy still has quest mark on his head but he wont move..

  • nuth1nmuch
    1 posts

    Can you actually fix the sons of Ragnar quest or can you just refund me for selling me trash?

  • DGM1992
    8 posts

    Hot fix my [censored]! It’s still not working! I’m done with this piece of crap game! I won’t even bother putting it back on my Xbox just not worth it!

  • NilsKita
    2 posts

    We demand a refund for this [censored] game! Take CD Projekt Studio as an example.. They have the balls to admit they brought out an unfinished product!

  • williiham
    1 posts

    Still not working for me, even after all the steps provided.

  • longjohn119
    538 posts
    We demand a refund for this [censored] game! Take CD Projekt Studio as an example.. They have the balls to admit they brought out an unfinished product!


    That's [censored] They were dragged kicking and screaming by 3.1 million players that bought the game for consoles and Sony completely took them off their store ...... They won't give me a refund since I bought a digital version for PC, only for PC users that bought the actual DVD disks can get a refund .... maybe

    The [censored] AI in my modded version of Skyrim works better than the AI in Cyberpunk which is ridiculously broken on all versions .... Fire my gun, turn away quick for a fraction of a second and all the civilians NPCs disappear or when you least expect you T=pose through the roof of your car with no pants on ..... Trees constantly melting like wax in the sun ....

    Valhalla is buggy but it sure isn't on the same level as Cyberpunk buggy ...... The Devs are now revolting against management and I don't blame them one bit

    Basically I have 2 games that likely won't be playable for a couple more months ...... So I'm playing a bunch of new quests written by essentially amateurs in Skyrim and came across one bug in 20+ hours and that was likely something I did wrong with my load order or a patch ( My main lighting mode shut down and it was pitch black outside town even with a torch lit I couldn't see more than 5 feet in front of my face but I still managed to complete the mission and save the wench from the evil bandits) .....

  • Dark-Coco
    17 posts

    Is this bug still not fixed? I checked the other day to check and it didn't work. I contacted Sony a while back, since I bought a digital version from the store, it's not through Ubisoft, it's through them. I explained the situation. Do you know what they did? Gave me a list of things to try. "Restart your console", "check you have the updated version of the game". I know they have to say these things, so I can't say "don't you think I've tried that?" (not that I would, in those words), but... I explained that there's literally a thread on the Ubisoft forums about this. It's a game breaking but that can't be fixed by merely restarting the console...

    Even if the bug was fixed, I wasn't interested in having the game for now. Ubisoft, I love the AC franchise, I do, but again, why release a game where a bug like this exists? Surely you must have checked for these things? It's like with Cyberpunk 2077 and how their game runs on PS4, i.e absolutely terrible, like I'm back in 1998, and they said people could get refunds. At least... if you bought physical versions. They even took the game off the shelves, and yet... Sony can't refund me because it's not in their policy? The game doesn't work!

    I hate sounding so complain-like, because I know people worked hard on this, like any game, but it wasn't ready, and I'm still £60 out of pocket for something that doesn't function properly. What am I to do? I replied back to Sony on trying to get my refund, but what if they don't? I've basically been scammed? I go "oh well, that's that"?

  • NilsKita
    2 posts

    Finally, finished this quest after 40 days or so waiting on it to be fixed. The only positive thing is that this game teaches me to be patient, very patient. Now get your act together Ubisoft and fix the other trillion bugs. Ow yeah, parkour in this game is [censored] too, what the hell is going on with these letters you have to chase. Sometimes they outfly you even if you are chasing it at maximum speed, certainly at tamworth fortress

  • longjohn119
    538 posts

    @dark-coco

    The problem isn't the game itself, it's the Connect App breaking the saves when it does an auto save to the Cloud ..... It's not marking an event/milestone as completed in the save file where all that data is stored ..... If the event isn't registered as completed in the Save then the game has no clue that it has been completed ....

  • mrdeadhead
    10 posts

    still had trouble activating it until I untracked the quest, tracked a different one, and stood like 10 feet away from him, finally ubba would let me speak to him (which repeated the introduction to ceowulf dialog scene) then he finally got on his horse and we rode out

    could it have something to do with ubba standing like directly on the border of riften? I ran around and pushed him a few times and noticed I kept getting that welcome to riften pop-up

  • Croolness
    1 posts

    So I still cannot talk to ubba, I thought this was supposed to fixed with the latest update, I’m at power level 205 and can’t get past a quest at power level 20, also since the update whenever my game loads the screen acts as though the character is drunk. Seriously how do you get past this? I have tried every suggestion below and nothing




  • nanalie7
    1 posts

    Still can't progress. I can talk to Ubba, but it crashes during the cutscene - everytime on the exact same spot (tried all advices on save games, traveling, other quests, etc.). Happens to me also on the cutscene after building the Seer's house 😕

  • AwAfrican
    1 posts

    still happening, on pc, finished first cutscene guy disappeared during the tour of the town cannot progress watched video found out where to go the the red tent. nothing just bodies

  • Hilkdogg
    1 posts

    I believe I have encountered a game breaking bug.

    After the sons of Ragnar quest, I noticed I could not proceed on the map, an invisible wall stopped me and said area not available. Well then I noticed I could not go the other way either. I was almost boxed in.

    So I tried to fast travel, and after spawning it immediately deaynched. Now, I am unable to fast travel in England. Every time I do, it desynchs immediately. I have tried everything to fix it to no avail.

    My problem is I was not saving manually at all, so the furthest I can go back without restarting the game completely is the middle of the Sons of Ragnar quest. The bug still exists in the middle of that quest tho.

    Please help, I love this game but refuse to restart and waste my time

  • JPat570
    1 posts

    So the exact same bug is happening. Can't talk to ubba so then I fast travel out then back to ubba, able to talk to him but after cut scene no one moves. Also tried what ubisoft said to do about the manual save. Nothing happened. Not really a AAA game if you ask me.

  • harvydanger81
    1 posts

    Upon settling in Britain I opted to go to Grantebridgescire from Randvi. Once I completed that quest chain Sons of Ragnar does not show up, the cut scene does not trigger nor do the NPCs show up in Repton. I sent a ticket in that was closed stating this was fixed last month and I am writing to share that it is not and I am unable to proceed. It was not made clear in the master thread for the next update that this scenario has been addressed.

    Thank you.

  • maloydis785
    1 posts

    @ubi-woofer I’m still not able to talk to ubba

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts

    Hey everyone!

    I apologise for the delayed update. I'm sorry to see that some of you still encountered issues following the hotfix my colleague Ubi-Woofer mentioned earlier within this thread. Thank you for continuing to update this thread and for sharing your experiences with the issue.

    This issue was marked as resolved by the development team following the deployment of TU 1.1.1. If you are still unable to talk to Ubba following this update, please can you provide a video within the thread so we can pass this to the development team for further investigation. Thank you! 😊

    Tsarchasm5 - It looks like this thread addresses the missing treasure hoard in Eurvicscire. This issue should also now be resolved with the update of TU 1.1.1. I recently collected the treasure hoard in Eurvicscire myself! If you're still unable to find it, please can you update a more relevant thread (such as the one linked), or open up a new one. Thanks!

    Official Response
  • Kerryl72
    2 posts

    This is still very broken. Did the fix ever go out? I can't meet Ivar or talk to Ubba. I should up via the boat location, get out and can't find them anywhere. Totally blocked. Based on what I have found on Reddit it sounds like this has been going on for months now.

  • Kerryl72
    2 posts

    @ubi-borealis How do I record a video to do this? You want us to just use our phone?

Suggested Topics

Community Details

30
Online
138.5k
Users
24.2k
Topics
125.6k
Posts