Welcome to discussions

Quick Suggestions

  • lynatra2323
    1 posts

    I feel like writing this message is useless but I got nothing else to do....
    I have a problem with AC Valhalla where Erke is not at the docks. I just cannot start the rest of my main quests. I am quite frustrated cause I know nothing in video game solution like this (BTW I play on ps4) and I don't see any solution online...
    Hopefully someone at ubisoft actually read this message and will help.
    Thank you

  • SeeKerNBJ
    2 posts

    @lynatra2323 the only way it is solved by my knowing is starting the game all over..

  • PikaMewPix
    5 posts

    I'm getting bored of trying to progress further in this game. Over 40 hours invested and because of the bug in this quest line I'm stuck. I killed her, game crashed right at the tail end of the cut scene. When I loaded back in the quest marker was gone so I went to do the arrows quest line, finished his and it's still trying to make me go after the leech. Even though she is marked as defeated in the order menu. At this rate the ones we all paid $60 to $120 to be beta testers for an unfinished game.

  • Medved_Nbg
    18 posts

    @pikamewpix it's been almost two weeks since this thread was created, and all we got from Ubisoft is a suggestion to create a case or use the live chat and submit a save file on their support page, where both creating a case and live chat are disabled, and also an information that the dev team could not recreate the bug. Brilliant.

  • GothNeko96
    2 posts

    I killed the leech and I get the quest update to find erke to report back but there is no marker on the map and he is in the cathedral unable to interact

  • GothNeko96
    2 posts

    @mallatekiller1 restarting doesn't help its what I did and now I'm stuck at the same point on erkes quest as I was on my first playthrough

  • sunset_pig
    4 posts

    this is what happened to me! I tried to load a previous save to a few hours before and it just loaded to like 5 mins before

  • Epeli744
    5 posts

    @sunset_pig Exactly the same for me.. really weird

  • Cypherpunx
    3 posts

    @ubi-woofer What to do when this happens on Xbox (Series X) ?

  • King_Kai_2002
    2 posts

    I can't continue in the quest fiery ambush. I kill the enemy's that come from the main road but I can't continue the quest any further. Please help me ASAP.

  • Frater_Andras
    5 posts

    Same problem here.

  • WaxMandible
    3 posts

    I’ve been dealing with the same issues with this quest. I love this game but I really don’t want to lose 50 plus hours of play time.

  • BJK19852020
    3 posts

    I am having the exact same issue, I've reloaded the game to an earlier mission, turned the PS4 on and off but still Erke does not appear at the docks.
    Has anyone found a fix for this problem?

  • FireWhenReady47
    1 posts

    SOLVED...I had the same problem, the solution i found is that you gotta kill arrow first and then go to stowe to complete the quest when that quest completes then go and kill leech.

  • kdawgx1
    1 posts

    Same here on PS5.

    Mission: Bleeding the Leech
    Objective: Report back to Erke

    🐜 Bug: No quest marker to find Erke.

  • Arussiansnail
    1 posts

    I'm having the same problem on Xbox One. Killed the blacksmith, quest objective updated to find and assassinate the leech, but didn't give me a quest marker. I found the leech by looking up her location and killed her. I had no cutscene when I killed her and the quest objective didn't update. Erke isn't showing up at the bench by the dock either. I also got that Ubisoft email showing my game progress and strangely, it showed an accurate play time and power level, but it said my most recent alliance made was with ledectrescire, but my most recent alliance is actually East Essex. I can't load back to a point before killing the black smith.

  • Poizen2yourbloo
    3 posts
    This post is deleted!
  • Nfirm12
    2 posts

    I had to completely make a new save then i was able to complete bleeding the leech

  • Nfirm12
    2 posts

    @kdawgx1 same problem on ps4

  • racemaster1
    2 posts

    can't progress any further been playing Assassin's Creed 50 hours I'm stuck on the where you go trick or treating you have to knock on the doors it won't let me do it need some help

Suggested Topics

Community Details