Welcome to discussions

Quick Suggestions

  • Gawdamahty
    2 posts

    @ubi-baron I am having the same issue. I killed the leech, but she was a regular character. Did not get a cutscene. The order list shows her as deceased, but the quest ya not updated so I cannot proceed in Lunden. I’m on an Xbox One.

  • SDbomber619
    1 posts

    I am having the same issue. I killed the Leech and nothing happens. I reloaded to previous saves, and it does the same thing. She’s marked on the Order list as being dead. But the mission says find and assassinate the leech. I’m on PS4.

  • jj030891
    3 posts

    Just killed the arrow and bleeding the leech mission isnt available. I've seen alot of people with this issue in the comments but haven't seen any official response. I cant warrant another 30 hours to start a new game. I hope this gets addressed

  • guest-dQNaZIKH
    2 posts

    I've already killed the leech, but the game quit during the cut scene, so it's not recognizing that I killed her. I already killed the arrow after I killed the leech, but I can't progress any further in the game because the only quest it's giving me is to kill the leech even though I've done it, she's even marked dead in my list of the order. And to make matters worse, I tried to go back to a previous save and the only save from before I killed the leech is from 9 days ago...at the beginning of the game!! Anyone else having this issue? I did a chat and the person I spoke with said they were releasing a patch sometime, but doesn't know if it will help me....I'm so upset, 92 hours, wasted and I wanna know what happens with the story...

  • guest-dQNaZIKH
    2 posts

    @toothxclaw I'm having this same issue...my game glitched while I was in the cutscene after assassinating the leech, and because of that it doesn't register that I killed her, so I can't progress any further without killing the leech even though I've already done it. I tried to go back to my previous saves, but my previous save was from November 14th which has only 16 hours of gameplay compared to today's save that has 92 hours of gameplay...

  • Mallatekiller1
    4 posts

    @guest-dqnazikh we all just have to hope that the next patch fixes the issue. If it doesn’t we might have to just start all over again and hope we don’t run into the same problem again...

  • Jozone10
    6 posts

    @mallatekiller1 I understand what you are saying about I hope that they fix it. I would like to rephrase that to, "they need to fix it" on the next patch. This is unacceptable. A quest that is a core component of the story line and thus hindering all of our gameplay experiences. You would think they learned from AC unity, but clearly Ubisoft did not.

  • DinoShrav
    1 posts

    Hi @Ubi-Baron ,

    I'm having the same issue with the 'Bleeding the Leech' quest and I can't progress in the main story because of it - the target is marked as defeated on the Order list, but there's no cutscene and the quest is still in my quest list and does not let me progress. I've tried going back to old saves and redoing it a few different ways but its still the same outcome. I've also read through this thread and seen that it worked if you kill The Arrow first, but that didn't work for me (in my case, I killed the arrow when 'bleeding the leech' was already in my quest list). I'd go back and replay the whole East Anglia arc but I'm a good 60+ hours into the game 😅

    Do you still need my savefile, and if so, which one? (I have a few saves - one before she's dead, and one after, and a few others in between). Where do I upload my zipped save file?

    Thanks!

  • Medved_Nbg
    18 posts

    I think they have planned an update for the game, that fixes a lot of bugs, for a specific date and are not going to change that date and release an early fix just for one quest. Because, you know, schedules are probably more important than players' experience.

  • jj030891
    3 posts

    @jozone10 So true. Its unacceptable paying £60 for a game you cant finish.

  • rasberii
    2 posts

    I cant get unwelcome quest. I did swan road home but then no quests

  • Gezz97
    3 posts

    Mine has bugged too on PS4 I can’t progress passed assassinating the leech, it just tells me to still do it

  • Dankness_666
    6 posts

    @oreinak don’t restart the game ask for a refund, you can’t play all the content in the game because of them.

  • Hagenfels
    5 posts

    @kdawgx1 Same here on PC

  • Xander43245
    1 posts

    Hi, Im getting an issue whereby I try to finish the quest quests and riddles and I finish the druid with his quest but it does not seem to finish the quest at all.

    Please help, really frustrating.

  • william_ps3
    2 posts

    I’ve been stuck on the bleeding the leach mission for over a week, killed the leach then killed the arrow and it still wants me to kill the leach, I got a cutscene when I killed her but won’t let me progress

  • guest-q9zmgZeN
    2 posts

    I am having problems with the Bleeding the Leech mission, I’ve killed the target but i never got a cutscene and I couldn’t confirm the kill. I can’t reload a save because i’d lose almost 10 plus hours of playtime. I’ve also seen that reloading a save doesn’t work.

  • guest-q9zmgZeN
    2 posts
    This post is deleted!
  • Xiantayne
    1 posts

    As a note to Ubisoft, if this will help, I have the same issue with having to report to Erke but he's nowhere to be found. I killed The Arrow first, then The Leech. My friend killed The Leech first and then The Arrow and didn't have a problem. It may be an issue of killing the Arrow first that bugs the questline?

  • guest-bU98WC2H
    2 posts

    @xiantayne on my load I killed the leech first and didn't have a marker just assumed maybe I don't get a marker until I kill the arrow killed the arrow still nothing 😕

    Got the same issues with the saves as other people aswell said I could reload 30 mins before start of the mission thought that's okay I'll just restart it but for some reason would just load me back in 2 mins before.. Seems a bug with the saves as well.

Suggested Topics

Community Details

49
Online
194.5k
Users
32.9k
Topics
164.4k
Posts