Welcome to discussions

Quick Suggestions

  • WaxMandible
    3 posts

    The patch comes out tomorrow. Patch notes look super promising.

  • Weav2593
    5 posts

    The cut scene is not loading when I press Y to hide behind the crate. And yea it’s night time in game when I try to hide. There is also no quest icon that appears when I track the quest. I’m over 30 hours in and do not want to restart the game... anyone else have this issue or ideas what to do

  • Vanyar1
    10 posts

    @ubi-ginge Sorry for the late reply. I'm playing on PS4, so I think I can't send you the save. Sorry for saying in the beginning ^^"

  • TheWeeedMaster
    4 posts

    I am a pc player for AC-V! Fantastic game if i may say so myself , however i am trying to complete alot of end game content such as all main story lines completed so i can get Gungnir and other things that require all story lines in England completed. My problem is Lunden. I have progressed the story line to where i need to kill the leech and the arrow. However, i have killed the arrow and killed the leech but got no cutscene for the leech and killing the leech show an unfinished quest like many people have been reporting. I also have the quest active still active even thoughy i have defeated herr? i have MANY hours on this save and am not willing to start over !!! Please help 🙂

  • Ubi-Woofer
    Ubisoft Support Staff 1152 posts

    Hello everyone, please accept my apologies for the delay in updating this thread.

    The developers have been investigating this issue since it was first reported and I am pleased to say that they believe they have found the cause, and a fix is planned to be implemented in a future update.

    I'm afraid that I do not have any additional details about the fix to share at this time (this includes when it will be released) but will update this thread again as soon as more information becomes available.

    Please be sure to update your game to version 1.0.4 when it drops later today, and let us know if you require any additional assistance in the meantime.

    Official Response
  • callumreuben
    2 posts

    That was a well detailed response! Luckily the patch coming in today should sort out a few of the main mission quests not completing, however I will take your advice and complete main missions before going astray and looking at mysteries.

    Unfortunately for me the odor of Tithe mission worked without a hitch (maybe try destroying the vases anyway?).

    For the fishing mission I am almost certain that you have to fish for it and not kill a fish with an arrow. However if they are not biting, then I think the new patch should help (as they are fixing some other fishing issues in Norway).

    Again apologies for not being able to help, but I hope your mysteries get solved!

  • MankoFafDM
    4 posts

    Thank you for the update!

  • Cypherpunx
    3 posts

    Doesn't seem like the patch today fixed the issue 😞 Still no sign of Erke.

  • MankoFafDM
    4 posts

    Well they already said the fix for the problem will come in the future, they were only able to reproduce the problem recently so don't expect a fix this week; we will probably receive another patch before New Year that will fix these quests that cannot be completed.

  • Balda1237
    3 posts

    Hi, i cant start Bleeding the Leech quest line. I did finish quest with Arrow to kill. And i have found that you have to start over the whole game to do this quest. Is that rue? Becasue i spent a lot of time in this game and i I dont wan tto grind it all over again.

  • Itonano1986
    2 posts

    After have killed the arrow, Erke is not a available so i can’t start the quest!!! Even with the patch 1.04, is not fixed!!! Ubisoft, do something!
    i’m playing in my PS4

  • Itonano1986
    2 posts

    @ubi-woofer do we have any ETA?

  • Frater_Andras
    5 posts

    The patch today not fixed the issue. The Leech is dead and Erke is in the Church, not in the pier. Unable to talk to him, and continue in this main quest.

  • Alojin
    10 posts

    I havew the exact opposite problem. "Bleeding the leech" worked fine for me but "Firing the Arrow" is broken for me. The quest should show "aquire a coin" but instead it shows nothing and the NPC that is supposed to spawn does not appear. Patch 1.0.4 changed nothing

  • Ras_Algethi
    2 posts

    Documenting the exact same thing, as of a week ago. Sadly, Patch 1.0.4 did NOT fix this.
    @staff: It'd be nice to get confirmation whether this will be (eventually) fixed, or if players would be better off restarting the whole game.

  • Mallatekiller1
    4 posts

    Guys I personally had decided to restart a couple of days ago and I didn’t get the bug this time around. My gut was telling me this patch wasn’t going to fix it and I didn’t want to wait a month. I lost like 45 hours but oh well.

  • MankoFafDM
    4 posts

    @alojin The entire Lunden arc is bugged, not only one or two quests. The problem can occur anytime during the Lunden story part

  • MankoFafDM
    4 posts

    @mallatekiller1 Good to know, seems like some people restarted as well but encountered the same exact bug; personally I wouldn't restart until I know for sure it works, actually I may not restart at all since I've got 100 hours played...

  • Stonejenson
    2 posts

    I went to Lunden, did the starting quests, Firing the Arrow fine, Bleeding the Leech I killed her but could not confirm kill, so reloaded and managed to kill her again and confirm, so they are in my dead list. The guys said meet us at St Pauls - then I left Lunden and went exploring. Re-pledged and did a couple of other counties, boucing back and forth between them OK. Tried a couple of times now to get back to Lunden, but quest line is still saying I have to do the Bleed the Leech quest. Her dead body is still where i left it, she's still showing as being dead, and the guys are waiting in St Pauls, but nothing will let me continue. and this is after installing today's patch on PS4.

  • Hopper03
    1 posts

    I am on PC and currently having the same bug. Updated to patch 1.04 today and it did not to fix this bug. I can't finish kill the leech quest because there is no option for cut scene on the body. I do show that I killed her in the contracts info.

Suggested Topics

Community Details

133
Online
218.7k
Users
36.9k
Topics
183.1k
Posts