Welcome to discussions

Quick Suggestions

  • Balda1237
    3 posts

    @kultowy97 Hi, do you think that they will somehow manage to fix that? Im lvl 255 and i cant progress. because Due to this quest bug i cant pedge to Jorvik or Wessex. I dont twant to start all over again and do the same grind. Ty for your answear.

  • Hagenfels
    5 posts
    This post is deleted!
  • CathalNeill2020
    1 posts

    Doesn't show Erke on the map. I found him at the church but can't interact with him.

  • Hagenfels
    5 posts

    Hey Ubisoft, your patch did nothing to remedy this bug.

    The Leech is dead, lying around, in the Order menu she is listed a defeated but nothing cant be continued from this point.

    Well Ubisoft, this bug is now known for 2 full weeks, you rolled out a patch that did not fix it.
    And apparently from what i read, its even impossible to complete the game without finishing this mission.

    Sorry but this is realy not acceptable on many levels.

  • ErickLeftazs117
    6 posts

    The Pilgrimage to St. Albanes quest is still not working after the patch. Any information?

  • babbabbbbbbbbb
    1 posts

    Hi, for me too same issue, killed the leech, then had a cutscreen and a bug.
    now it shows that she is dead in the order list but the quest bleeding the leech is still open, when selecting this quest there is no pin appearing on the map..
    even if reload to last autosave it’s still the same issue. It’s really annoying.
    hope ubisoft can fix this bug on assassin creed valhalla or else will just leave the game away and claim reimbursement.

  • ClintonWarner
    1 posts

    This is still not fixed after the patch. First experienced the problem on my One X, it still persists after patch on my Series X. Very annoying.

  • Hugs_
    1 posts

    Bug still remains after 1.04 patch it seems. I got the bug before the patch dropped yesterday on the previous patch.

    Killed the leech
    Got the cutscene
    Game crashed as I was fighting the guards afterwards (nice)
    Loaded back in. Quest is still active, no marker on the map. Kill the leech and I don't get the cutscene anymore. Quest doesn't preogress.

    I tried loading multiple saves but it doesn't work. All the saves I have are from after the Arrow and Leech quests are active.

    Updated to 1.04 today and the bug remains the same.

    Playing on PS4

  • TheBirdManHQ
    Original poster 20 posts

    The patch from today does not include fixing the Bleeding the Leech or anything else in Lunden.

    Lunden quest lines are full of bugs for people. They have recently replicated the issue so hopefully a fix will be posted soon and we won't have to restart our whole game.

    They asks us to restart I will be asking for a refund.

  • DeadRev
    1 posts

    The exact same thing happened to me, I reinstalled but didn't reload a old save, I continued and completed all other Regions and the Asgard arc aswell, and now I cant continue the story. it just says Report to Erke, I looked YouTube vids on where he is and he is not by the docks so I've lost full. Hopefully they get this fixed. I hoped the 1.04 patch would have fixed it but now Im slowly getting bored because I really want to know what happens next.

  • IrenalovesArya
    1 posts

    I have exactly the same problem. I have just downloaded the patch, assassinated the leech , saw the cinematics ,and that order member was killed etc and the quest does not proceed. It still says assassinate the leech.. help plz

  • Frater_Andras
    5 posts

    @thebirdmanhq Me too!

  • kkealakai
    2 posts

    I have the same bug. My quest says to Report to Erke, shows the Leech dead in my Order tab, but I am unable to find Erke at the docks or talk to him or Stowe in the cathedral.

    I've also noticed that any guards I have killed in the Leech's vicinity remain dead. So, I've actually now killed every guard in that area and their bodies are still in the streets days (in-game) later. The only guards that seem to reappear are by the side alcove entrances (while the other guards remain dead in the garden, chapel, streets, and atop the roof).

    I've also gone back to the Leech's "office/workshop" several times and have set traps in her body, and carried it and thrown it at Erke in Saint Paul's Cathedral (it surprised him, but did nothing). However, her body always respawns in the chapel where I killed her, after fast traveling or leaving the area.

    When I killed her, I assassinated her, and got the cutscene, but did not get a "confirm kill" option nor do I have the book (quest item) you're supposed to get in my inventory. I had actually started the Bleeding the Leech quest first but, upon encountering the bug, was unable to finish, so I did the Arrow quest line, assuming that, when I restarted the game the Leech quest's bug might fix itself (which is how another bug resolved itself). When that wasn't the case, since I didn't have an earlier save, I then tried re-pledging after completing an alliance, but still encountered the bug.

    I don't know if it helps, but I also have the bug for the jars mystery quest in Lunden (The Demon Odour at the Tithe). The jars are moved so the guy can exit, but he doesn't talk nor can I talk to him, and one of the moveable crates have respawned atop the jars I had moved.

    (I am playing on PC)

  • trapped_bird
    1 posts

    i'm currently on the mission ''bleeding the leech'' in assassin's creed valhalla on the playstation 4. the issue i'm having is that i killed the leech, but i got to see no cutscene, so the mission hasn't been completed and now i'm stuck. i can't continue, but on the order page it says i've eliminated the leech. my latest save game is 5 hours earlier and i don't wanna lose these 5 hours. please help me with this problem.

    i submitted this as a case last week on friday and i uploaded my save file to ubisoft support, but they still haven't fixed it. just downloaded patch 1.04 and it didn't fix it either.

    so now what?

  • Hagenfels
    5 posts

    @trapped_bird That bug is known for 14 days now roughly and its a game breaker that makes progress impossible later.
    I have the same problem.

  • AmirAli2132
    1 posts

    My friend can't speak english so im writing for him and here's what he says about this problem:" i killed the arrow and talked to stowe but the mission doesn't show up and stowe told me to find erke but erke isn't at the place im supposed to go and the bleeeding the leech mission doesn't show up" so i looked at it and not only it can't find erke and the mission is glitched but also the place where erke should be to start the mission is also glitched( i attached the photo of the glitch ).apparently the problem isn't just for me and others have this problem as well
    Ubisoft please look this through because not only he is disappointed at buying this but also i've lost a lot of intrest in buying this game as well because of the millions of bugs and glitches this game has.
    With regards

  • Rachlily1971
    26 posts

    I’ve finished the quest, killed the leech, had cut scene. But no quest marker showing up. I am meant to report to Erke.

    Anyone else?

    Is Ubisoft aware of this, as it the main story which obviously I cannot continue on with?

    I wondered if I can find erke and still report to him with no quest marker (although I have the quest highlighted in my menu)? Can this work? Where is he?

    thanks !

  • Rachlily1971
    26 posts
    This post is deleted!
  • tnulton
    2 posts
    This post is deleted!
  • tnulton
    2 posts

    i am also having the same issue. I got a cutscene the first time, but Erke never showed up. After I reset and tried again I never recieved the cutscene and the quest does not update. I am playing on PC.

Suggested Topics