ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to progress with "Bleeding the Leech" after completing "Firing the Arrow" | POST HERE

    10 likes/552 replies/13533 views
    ubisoft:x-posts, 1

    @ubi-baron I am also having the same glitch. I can't complete the mission even though it says I killed the leach.

  • TheWeeedMaster
    ubisoft:x-posts, 4

    I too am having this problem with the leech . I'm playing on PC. I killed the leech but no cutscene and cant progress the quest please help !!

  • Guave
    ubisoft:x-posts, 5

    I never had freezes and loading issues before 1.0.4 and now its basically unplayable. It sometimes just freezes and I have to kill the process in the task manager. Did not happen before 1.0.4 and I played over 55 hours.

    I also have quest in which I am not able to progress. War Weary, where Ceolbert always bugs out and dies after the fight in the church. That happens even if he is alive after the fight. When the cutscene ends, he just falls dead on his face. Its almost comical to watch..

    The" Viking for hire is also bugged". I cant speak to the quest giver in my village after I did my 10 quests.

    I sent them a Ticket, but I guess that I will try next year again.... if they did not fix it by then, I will ask for a refund. They should have tested the Main Questline more. The Leech thing worked for me fortunately, but some sidequests where also bugged but worked after a reload.
    Seems that they tested the first 35 Hours of progression and stopped then.... lol

  • Chloeromain1793
    ubisoft:x-posts, 2


    Erik doesn't even appear on my map at the docks I have no main quest at all

  • guest-yahaeiFe
    ubisoft:x-posts, 3

    @ubi-baron I am playing on xbox one s? I wasnt able to load a save before the glitch. Went back to lunden after every other territory i completed and no change, and still nothing after the 1.0.4 update. Im now at a point where lunden is the only thing im able to do main story wise

  • Wonkyphil
    ubisoft:x-posts, 1

    Both the Lunden Arc and Grantebridgescire arc quests are not working properly. I have managed to complete Lunden after the game crashed I was then given the cutscene for Stowe on entering but now I am on grantebridgescire and soma won't give me the option to accuse one of the three as a traitor, just keeps giving me the bit about getting to know her better. I also have no quest markers for this arc. Is there a quick fix?

  • D1NZY09
    ubisoft:x-posts, 1

    I am unable to continue the sons of ranger quest as I can't speak to ubba at the docks and the longship is levitating

  • guest-LmzWZ5qG
    ubisoft:x-posts, 1

    Hey there I'm playing on a ps4 and I'm unable to complete the Old Cellar side quest/ mystery. I have run out of barrels to destroy and I can still can not pick up the floating item. I have left and come back but there seems to be nothing I can do. Any help would be a blessing!

  • MiserlyEarth30
    ubisoft:x-posts, 1

    Just make it possible to reset the pledge missions i would rather redo an hour or two then my current 70 hrs. Thanks

  • Hlysettes16
    ubisoft:x-posts, 1

    I am currently trying to complete the “war weary” quest but after I kill the guys on the beach, it gave me no further instruction. It only shows the quest name on the top left corner. I’ve tried exiting the application/game and even turned off my PS4 multiple times. I also tried rebuilding the database and restored the licenses on my PS4. When I try to do the quest, the same thing happens and and now it won’t even let into the quest area(Quatford). I haven’t had any issues with the game until the recent update. Please help me.

  • Dan4842010
    ubisoft:x-posts, 2

    I want to report the same issue, completed the previous quest, Firing the Arrow, the Lunden quest arc then disappeared from my quest log and I cannot progress further. Please can this be looked into?

  • Ubi-Baron
    Ubisoft Support Staff ubisoft:x-posts, 798

    Hey guys,

    The issue with Bleeding the Leech has been identified, and this should be resolved in an Upcoming update.

    For the other issues in the thread, please make sure to create new posts or find other users with the same issues.

  • Giddz2020
    ubisoft:x-posts, 4

    I have this problem literally at a stand still there’s nothing more I can do until this is sorted what a waste of money for a glitchy game

  • hybrid_wolf666
    ubisoft:x-posts, 14
  • hybrid_wolf666
    ubisoft:x-posts, 14

    Ive killed the arrow, but its not giving me "bleeding the leech" guest....ive waited for days now and ive even reloaded my last save to see if they would fix it some how, obviously that didnt work. I dont want to respart my 21 hours and only to run into the same problem

  • LimitlessN
    ubisoft:x-posts, 1

    IM LIKE: WAITING LIKE TWO WEEKS,"COME ON UBISOFT COME ON VERSION 1.0.4." and the leech still cant come back to my side.

  • Hagenfels
    ubisoft:x-posts, 5

    ETA for a patch please?

  • LonghornEric
    ubisoft:x-posts, 1
    As you see in these pictures, I have done exactly what the game tells me to do, and yet i cannot progress any furtherundefinedundefinedundefined

    I have EXACTLY the same issue. I never got a cutscene for killing her. I tried to move the body to a site with less enemies to see if I could “confirm kill.” This didn’t work either. I then thought that maybe I had to go and finish the Arrow mission, so I went and killed him, got the cutscene for him, and got his medallion. I then went back to the Leech’s body but could do nothing with it. Now I show her as dead on the Order page, but the mission is still active. I have ZERO manually saved games, so I would have to start all over from the beginning!

  • amchan88
    ubisoft:x-posts, 5

    @ubi-baron Thank you

  • TheRealBDogg
    ubisoft:x-posts, 4

    its been two weeks and still no patch or help from ubisoft I would like a refund please if you guys don't fix it soon I'm really [censored] I paid 100$ for a broken game. How did it even get passed beta. PLEASE RESPOND SOON! THIS IS RIDICULOUS!

Suggested Topics