Welcome to discussions

Quick Suggestions

  • leoraygamer
    3 posts
    This post is deleted!
  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "Bleeding the Leech" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with "Bleeding the Leech" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • leoraygamer
    3 posts

    hi im on ps4 and when i was speaking to the blacksmith my game crashed so i loaded it back up again and now im unable to interact with the blacksmith and my quest marker disappeared even tho i have it tracked
    i also created a case about this but im also posting about it here just to be sure
    case number:
    13303786
    i also have a video of the bug:



  • Kamerica27
    4 posts

    When is the new patch coming out? My game is broken, I can't proceed with Bleeding the Leech, and Cyberpunk isn't out yet

  • Scangeo
    3 posts

    @ubi-swaggins

    Any update on this issue?? I have pledged allegiance with every interactive territory on Randvi's map but none of the zealots I had to kill to complete these story arcs show up in the ancient order tree as "defeated" and, therefore, I cannot progress the story any further... What is going on? After almost 100 hours of gameplay, I really don't want to have to start again. I think I'll just give up on the game and take it back to the store for a refund.

  • BABBLE610
    2 posts

    @babble610

    Now 83 hours in. Completed every main story quest available. Have been randomly free roaming doing mysteries, legendary animals, all view points, etc. I am bored as hell. Please just release a patch to reset a region. I would rather redo all the other quests in London then not be able to play the [censored] game. There is zero chance of restarting the game. How do you sell a game for soo much that has major game breaking bugs? Getting stuck in the terrain, faces not loading, etc are all annoying but at least we can continue the game. Guess I am going back to boycotting UBI.

  • PrudentMarmot88
    2 posts

    Xbox1, no cut scene. Says she is dead in order tab. Never confirmed kill. Kept playing other regions and checking back. Now I'm all caught up. Tried reading other threads, no help. Any suggestions?

  • ketlers
    1 posts

    I have that same problem right now. Did you figure out how to fix it?@oreinak

  • william_ps3
    2 posts

    I don’t think I’ve ever played such a buggy and glitchy game, it’s fantastic when it works but they really should’ve given it another month or two to make it right, been stuck on bleeding the leech for over a week now and constant crashes, really needs to get patched

  • Itswolverine1
    1 posts

    Bleeding Leech bug!!
    I tried to kill the leech and she died like a normal guard. There wasn't any cutseen or anything. I have raised a complaint but there isn't any response.. it's been nearly 10 days.. please help!!

  • FireIce38
    27 posts

    @itswolverine1 Was it not just posted earlier that the issue has been identified and will be fixed soon? Be patient.

  • PrudentMarmot88
    2 posts

    I am also having same issue. All caught up in story otherwise. Anyone have a resolution yet?

  • Stonejenson
    2 posts

    Yup, got to that point where I can't pledge to anything else but Lunden now, so need a reset for that area before any progress will be made. I popped back a few times, but always the same Bleed the leech is stuck after killing her. I got to confirm, and she's in the dead list, but never had the part where you meet and decide about the book, and move on to the next quest.

  • Fallzss
    1 posts

    Hello, I am unable to move forward in my quests. I received the Bleeding the Leech quest, so I went to where she was found. I found her, and immediately killed her.
    This happened to me originally two weeks ago, and I googled it and saw others were having issues as well so I tried reloading saved files (as it stated when I first searched up about the issue) and that still hasn't worked. I'm not quite sure where to go from here. I'm at a point in my game where I'm too low of a level to do anything else OTHER than my Bleeding the Leech quest.

  • guest-yahaeiFe
    3 posts

    @fallzss theyre dropping a fix in the next update for mid December. Depending on your play style, if you just explore around and do the cultusts or do the mythical stuff, itll get your power up. Im almost at 300 and was able to do everything storywise up to the 250 regions. Im also stuck due to bleeding the leech

  • gurganus429
    3 posts

    Is there a fix for bleeding a leech bug

  • wasilewskimaste
    6 posts

    @stonejenson same here I hope its in the next patch

  • AVPham94
    1 posts

    Captain's Log: December 8th 2020, no sign of Ubisoft fixing the issue. Can I get a refund on this $60 game?

  • Scangeo
    3 posts

    @avpham94 This really sucks and the worst customer service I've experienced in a long time.

  • BJK19852020
    3 posts

    I can't even make it this far in Lunden. Every time I try to meet Erke at the docks he never appears. No marker on the map or anything. I tired going back a few saves and playing up to that spot again but he still would not appear and there were no quests in the mission log for Lunden. I continued on in the game and have completed ever part of England I can accept for Lunden and Jorvick and of course Wessex but I can go no further now until Lunden is fixed. Has anyone else had this experience or can help?

  • BJK19852020
    3 posts

    @bjk19852020 I've had no answer back from Ubisoft or anyone else on this issue, I was able to continue the game and get as far as taking over most of England but it always come back to Erke not showing up on the docks and so I can not continue the story or finish the game. After over 70hrs worth of gaming I really don't want to start again. He may not turn up if i re start it either.

Suggested Topics

Community Details

48
Online
138.4k
Users
24.2k
Topics
125.6k
Posts