Welcome to discussions

Quick Suggestions

  • sunset_pig
    4 posts

    Killed the arrow and the bleeding the leech objective has completely disappeared - erke is in the cathedral and you cannot interact with him. I've done everything else in the game and cannot complete it because of this bug.

  • Ubi-Borealis
    Ubisoft Support Staff 2929 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "Bleeding the Leech" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with "Bleeding the Leech" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • iviaq
    3 posts

    New update do not solve bug with Eric not showing for rapport on saved game.
    😞

  • golding666
    2 posts

    I downloaded and installed today’s patch, the notes for which state it addressed the issue in the quest where Erke is not where he is supposed to be. This hasn’t been fixed. I’m on PS4 and have repledged to Lunden after the patch and the quest is still missing!

  • Doodlebob804
    2 posts

    Did the bug fix for anyone in the new update?

  • gurganus429
    3 posts

    @doodlebob804 no I have the same problem

  • AHMET861C4N
    9 posts
    This post is deleted!
  • AHMET861C4N
    9 posts

    And it didn't change with the new patch. I am stuck on the main quest and can't progress or do anything because all other main missions are finished. So, what should I do? Should I delete the game and start from the beginning because I prefer to buy a new game rather than throw away my 75-80 hours again. If this will be the advice or solution, it is boring to say but please refund my money, because I started to believe that there will not be a solution in the near future!!!
    @Ubi-Woofer
    @UbiExcellent

  • UnafraidBigfoot
    11 posts

    @unafraidbigfoot this problem still exists how long before you have a solution to this i spent a great deal of money on this game and I am not amused by these bugs. Out of the 3 that my wife and I have come across only 1 has been solved

  • Bmweta
    3 posts

    When will this be fixed, have waited since November to proceed in the game 🤬

  • raggednail79
    5 posts

    So as with a lot of people on this thread I am having the same problem with completing the Lunden story arc both of the sheriffs are just sitting in St Paul's Cathedral and its just not allowing me to progress plus its not even showing up in the quest section and as I'm at around level 345 and put in 149 hours into this game , and yes I do still have other quest to do but that is beside the point it still doesn't change the fact that the game will not progress the frustration as a gamer who only has certain time to play this game when I could of spent my hard earned cash on a game that would at least allow me to continue with the story , now I have generally been a fan of the assassin's games and especially this one as I love the subject matter but it is now getting to the point I actually don't think I want to play it anymore because so many issues with story progress Mystery progress(which I as of yet have not had a problem with, touch wood, but have friends that have) Glitches the list goes on, I have spent money on a game and a season pass for that matter and really not seeing a return on my investment, my time or my faith in Ubisoft to put out a fun gaming experience and that has diminished because the only reply to posts is send us this info, send us save files and make a ticket well some people might be thinking how you actually do something about it as you know there is a massive issue with the game you have put out .

  • Joskinmert
    5 posts

    Installed newest update and still no erke at the docks I'm very unhappy with the game this is not acceptable to be waiting from November for a fix

  • Jaks637488
    1 posts

    i am having the same issue. No quest or marker for bleeding the leech after killing arrow. Erke is in the cathedral with Stowe and not on the docks. Started game over twice and same issues. Deleted and reinstalled game. Same issue. Loaded many previous saves and still no luck. Put in a ticket and was told it is being worked on.

  • RafaelLacayo
    1 posts

    bruh.....I have 80+ hours in the game and my quest marker for "bleeding the leech" isn't showing up... I completed the arrow just fine but my quest marker for the leech isn't showing now...went to the docks and everything...I really really don't want to start over with 80+hrs played


  • folkert87
    3 posts

    I recommend everyone to refund the game since the problem has not yet been solved. Ubisoft did not help me fix it, so I am unable to finish the game. I was able to get a refund from my retailer. Good luck everyone.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hello and thank you all for adding to this thread. I've checked in on this issue, but I'm afraid that no further updates have been made available to us at this time. For those of you that are still unable to proceed due to the quest marker/objectives for 'Bleeding the Leech' not being available after completing 'Firing the Arrow', please still provide your affected saves to us via a support ticket.

    @Bmweta I appreciate you posting your case number here! Would you be able to also upload your saves to this ticket please?

    Official Response
  • AHMET861C4N
    9 posts

    Hi @UbiExcellent ,

    Thank you for your reply, but most of us cant continue the game and main story because of this bug, and I have stopped playing Valhalla almost 2-3 weeks ago, and the magic of the game has gone.

    I understand that there will be no solution for this issue in the near future, and it makes me much more distant from the game day by day.

    This is the first time I give up on a game and can't finish the main story because of the bugs, which makes it impossible.


  • Ubi-Borealis
    Ubisoft Support Staff 2929 posts

    Hey there folks!

    Apologies for the delayed update. The issue regarding being unable to get the letter from the Blacksmith, or being unable to locate the Leech following the attainment of the letter, has been marked as resolved by the development team following TU 1.1.1. Additionally, Erke should now be showing at the correct location.

    If you are still unable to get the letter from the Blacksmith or locate the Leech within the quest, please don't hesitate to update this thread so we can take a closer look. If possible, please include which platform you use (PC/PS/Xbox) and a video that shows that you're unable to proceed with the quest. We can then pass this information to the development team for further investigation.

    If you're unable to start "Bleeding the Leech" after completing "Firing the Arrow," please check out this megathread instead. Thanks! 😊

    @iviaq & @Joskinmert - Are you still unable to find Erke in "Bleeding the Leech"? If so, can you please send us an image that shows him as missing from the location he should be in? Thanks!

    Official Response
  • guest-1vW8rmmF
    4 posts

    @guest-1vw8rmmf

    Im getting help from livechat now so you dont have to check on this 🙂 thanks

  • jimmyward93
    2 posts

    @jameswarrenpark I have the same issue and been that way for a couple of months :(.

  • Knudsnik
    1 posts

    On PS4

    After completing firing the arrow in AC Valhalla the next Quest bleeding the leech does not appear at All

    What to do? Ive tried loading an earlier save and completing the Quest again but still have the problem.

Suggested Topics

Community Details

37
Online
144.0k
Users
25.5k
Topics
132.5k
Posts