ubisoft discussions

Quick Suggestions

  • UnafraidBigfoot
    11 posts

    @unafraidbigfoot this problem still exists how long before you have a solution to this i spent a great deal of money on this game and I am not amused by these bugs. Out of the 3 that my wife and I have come across only 1 has been solved

  • Bmweta
    3 posts

    When will this be fixed, have waited since November to proceed in the game 🤬

  • raggednail79
    5 posts

    So as with a lot of people on this thread I am having the same problem with completing the Lunden story arc both of the sheriffs are just sitting in St Paul's Cathedral and its just not allowing me to progress plus its not even showing up in the quest section and as I'm at around level 345 and put in 149 hours into this game , and yes I do still have other quest to do but that is beside the point it still doesn't change the fact that the game will not progress the frustration as a gamer who only has certain time to play this game when I could of spent my hard earned cash on a game that would at least allow me to continue with the story , now I have generally been a fan of the assassin's games and especially this one as I love the subject matter but it is now getting to the point I actually don't think I want to play it anymore because so many issues with story progress Mystery progress(which I as of yet have not had a problem with, touch wood, but have friends that have) Glitches the list goes on, I have spent money on a game and a season pass for that matter and really not seeing a return on my investment, my time or my faith in Ubisoft to put out a fun gaming experience and that has diminished because the only reply to posts is send us this info, send us save files and make a ticket well some people might be thinking how you actually do something about it as you know there is a massive issue with the game you have put out .

  • Joskinmert
    5 posts

    Installed newest update and still no erke at the docks I'm very unhappy with the game this is not acceptable to be waiting from November for a fix

  • Jaks637488
    1 posts

    i am having the same issue. No quest or marker for bleeding the leech after killing arrow. Erke is in the cathedral with Stowe and not on the docks. Started game over twice and same issues. Deleted and reinstalled game. Same issue. Loaded many previous saves and still no luck. Put in a ticket and was told it is being worked on.

  • RafaelLacayo
    1 posts

    bruh.....I have 80+ hours in the game and my quest marker for "bleeding the leech" isn't showing up... I completed the arrow just fine but my quest marker for the leech isn't showing now...went to the docks and everything...I really really don't want to start over with 80+hrs played

  • folkert87
    3 posts

    I recommend everyone to refund the game since the problem has not yet been solved. Ubisoft did not help me fix it, so I am unable to finish the game. I was able to get a refund from my retailer. Good luck everyone.

  • UbiExcellent
    756 posts

    Hello and thank you all for adding to this thread. I've checked in on this issue, but I'm afraid that no further updates have been made available to us at this time. For those of you that are still unable to proceed due to the quest marker/objectives for 'Bleeding the Leech' not being available after completing 'Firing the Arrow', please still provide your affected saves to us via a support ticket.

    @Bmweta I appreciate you posting your case number here! Would you be able to also upload your saves to this ticket please?

  • AHMET861C4N
    9 posts

    Hi @UbiExcellent ,

    Thank you for your reply, but most of us cant continue the game and main story because of this bug, and I have stopped playing Valhalla almost 2-3 weeks ago, and the magic of the game has gone.

    I understand that there will be no solution for this issue in the near future, and it makes me much more distant from the game day by day.

    This is the first time I give up on a game and can't finish the main story because of the bugs, which makes it impossible.

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hey there folks!

    Apologies for the delayed update. The issue regarding being unable to get the letter from the Blacksmith, or being unable to locate the Leech following the attainment of the letter, has been marked as resolved by the development team following TU 1.1.1. Additionally, Erke should now be showing at the correct location.

    If you are still unable to get the letter from the Blacksmith or locate the Leech within the quest, please don't hesitate to update this thread so we can take a closer look. If possible, please include which platform you use (PC/PS/Xbox) and a video that shows that you're unable to proceed with the quest. We can then pass this information to the development team for further investigation.

    If you're unable to start "Bleeding the Leech" after completing "Firing the Arrow," please check out this megathread instead. Thanks! 😊

    @iviaq & @Joskinmert - Are you still unable to find Erke in "Bleeding the Leech"? If so, can you please send us an image that shows him as missing from the location he should be in? Thanks!

    Official Response
  • guest-1vW8rmmF
    4 posts


    Im getting help from livechat now so you dont have to check on this 🙂 thanks

  • jimmyward93
    2 posts

    @jameswarrenpark I have the same issue and been that way for a couple of months :(.

  • Knudsnik
    1 posts

    On PS4

    After completing firing the arrow in AC Valhalla the next Quest bleeding the leech does not appear at All

    What to do? Ive tried loading an earlier save and completing the Quest again but still have the problem.

  • jameswarrenpark
    3 posts


    Excuse my sternness but this is getting ridiculous now.
    I've put 115 hours into Valhalla since acquiring it on PS4 in December. Collected all of the wealth/artifacts in Norway & England, completed all mysteries and fully upgraded all skills/mastery levels. I've completed the story arcs for Grantebridgescire, East Anglia, Sciropescire, Oxenefordscire, Ledecestrescire , Snotinghamscire, Cent and have the latest update (2.00) installed.. and STILL, the main questline (Lunden Leech) is broken for myself and many other players!

    I appreciate that you guys are working on 'Wrath Of The Druids' and 'The Siege Of Paris' DLC's along with other titles, but I don't understand how a game-breaking bug like this one isn't a top priority, or better yet, already resolved. I saw that some players have suggested returning the game for a full refund, but what about those of us who had more faith in Ubisoft and didn't keep their receipt?
    I've provided my save files, along with a support ticket (13798427) and still, months later, the main story is stuck at Lunden..
    The story arcs/side quests completed thus far, have been phenomenal, but the fact this hasn't been ironed out yet is beyond disappointing.

  • keh-tone
    2 posts


    I've lost all the Lunden quests in my game. Haven't been abel to continue with either firing the arrow or bleeding the leech.

    What is also odd is that my Quest menu has the star showing unread items, but I don't have any unread items in my current or completed quests... it must be the quests for Lunden, which are just not appearing at all.

  • jameswarrenpark
    3 posts


    That's exactly what has happened to me. I was completing each story arc as they showed up, but then after completing the 'Firing The Arrow' quest, the Lunden quest tab has vanished, along with any markers or active objectives. Just decided to mess around with collectibles/side quests thinking it'd be resolved by now.
    Ah, I hadn't noticed that myself till you pointed it out. Same on my end. No active or unread quests, but the symbol is there..

    Fingers crossed this is dealt with soon as the game is now collecting dust.

  • mrluke-4232
    1 posts

    The contact we're supposed to tail in the Bleeding the Leech mission (after meeting Erke) is broken. He saw me, I killed him, now he is just hunched over. I cannot interact at all, and I tried to go to the next goal, but that doesn't work either. The issue was raised in https://discussions.ubisoft.com/topic/90097/for-ubisoft-bleeding-the-leech-mission-tail-the-contact?lang=en-US , but no responses. I am playing on PS5. I cannot progress any further in the story at this point. All missions are complete but this one and the missions that follow it. HELP.

  • doodpwnd
    3 posts

    @ubi-borealis The quest still isn't working for me. When I switch territories back to Linden to pick up where I left off, finding the guy at the docks, I don't get a quest. On the screen it'll say "Bleeding the Leech", but underneath it, it won't say what to do. When I go into the menu and go to quests, it doesn't come up at all, as if I already completed the quest, but I didn't. I tried waiting until night to see if anything changed and going to the docks, and nothing. I have a ps4.

  • UbiExcellent
    756 posts

    @doodpwnd Thank you for the update. Are you able to provide a short video clip showing that you do not get a new quest/ are not prompted to continue 'Bleeding the Leech' please?

  • wx11._
    4 posts

    It has been over two months since the first case of this bug was reported, with many people experiencing this problem there is still no solution. Are we entitled to a refund? @UbiExcellent @Ubi-Woofer @UbiKobold

Suggested Topics