Welcome to discussions

Quick Suggestions

  • Vanyar1
    10 posts

    Did you try entering the stone circle again to make the house appear a second time? That worked for me as the house always disappears (I think it's a normal thing).
    If it's not working the normal way, try entering the circle from the west or while crouching. But that shouldn't be necessary.

  • Ubi-Borealis
    Ubisoft Support Staff 2906 posts
    Best Answer

    Hello there,

    Following the release of TU 1.2.2, the development team have marked this issue with "Mistress of the Iron Wood" as resolved.

    If you are still encountering trouble with this quest, please don't hesitate to update this thread so we can take a closer look. Please include a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the right-hand corner of the main game menu.
    • The issue you're encountering in "Mistress of the Iron Wood."

    We can then forward these reports to the development team for further investigation.

    Thanks! 😊

    Official Response
  • WinterxStrike
    2 posts

    @vanyar1 Yes I tried that before but for some reason it didn't trigger the house. It finally worked now. 👍

  • fanatic1123
    1 posts

    Same problem on PC. Going to the stone circles does not help.

  • suares97
    2 posts

    It worked. Thanks.

  • Stormsong89
    1 posts

    I have the same issue. I have tried approaching the house from all directions and all the stone circles, crouched and not crouched, I have left Jotunheim and come back, and it still won't appear. I get the green marker just floating in mid-air where the house is supposed to be.

  • nmhanzlik
    1 posts

    You may be on the wrong stone circle. I had this same issue. As I was coming back from the waterfall area I got the floaty orb. There is a stone circle that you hit first that seems like right one, but you need to keep going until you find the one with the wooden plank in the middle. The fire flies should show up again.

  • VisionaryTiger
    2 posts

    I have just had the exact same problem. I got the 3 roots needed. Come back to hand them in and her house is gone no matter which one of the four stone areas I stand on he house does not appear. As stated above, I did also try to wait in the stone areal with the wooden plank in it... The fire flies flew around me and the whispering voice continued but then still no house appears.

    Any help would be great 😞

  • kingyva
    1 posts

    You have to stand between the two trees with the skulls attached to them near the wooden bench thing. The same way you first approached the heart of the woods. Her house is protected by the same magic that protects the waterfall

  • mir3kk
    1 posts

    same problem house disappeared

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    Hey all, thanks for reaching out about this. mir3kk -  Sorry to hear this is happening still. If possible, can you provide us with a clip of the issue occurring for you?

    WinterxStrike - I'm glad to hear things worked out! Did anything in specific help solve the issue? Or were you able to simply come back some other time to complete the mission?

    Official Response
  • sklavounos_k
    1 posts

    @kingyva I stood there, then moved forward and it appeared! Nowhere near where it first showed up for me. Also every time I was reloading, my player had the drunk effect. Ubisoft your game is full of bugs, like seriously 😠

  • Zergowicz
    1 posts

    I have the same problem to. Ubi GJ

  • TheFlash0412019
    18 posts

    Just encountered the same problem on the ps4 getting real frustrated cause I've grinded enough to get just strong enough and the first quest is glitched I also can't continue in the main story as the bug in brewing Rebellion is ridiculous but apparently Ubisoft can't "Replicate it" and Reda I've got over 200 opals and I don't even know what's in the store and can't do his quest. I pray you update it soon or you'll lose many fans. FIX YOUR GAME UBISOFT 2 YEARS TO MAKE IT WE SHOULDNT HAVE THIS MANY ISSUES.

  • Windgaard
    1 posts

    @sunflowersprout Getting out of the circle leading away from the tree, i ran for about 2 sec turn around and the house appeared. Maybe it wil work

  • YazX_
    157 posts

    @zergowicz this is not a bug, its by design, you will encounter alot of locations like this, those are magical locations and you need to always ENTER the scene between two poles/columns with the skulls, sometimes there will be several polls with skulls and sequences of revealing the full scene, you will know there is magic by the flying yellow spell.

    the real bug is invisible walls, if you climb the tree without revealing the house, you will climb and hit invisible walls, happened to me with different locations as well.

  • Clifferto
    2 posts
    This post is deleted!
  • Clifferto
    2 posts

    I experienced the same issue as this I couldnt get past this mission, but FINALLY!!! I was running around North West of the area and got destroyed by a group of locals and when I spawned back in the house was there!!! I struggled for hours trying to resolve this by reloading but I guess it just came by luck. Valhalla is so buggy 😞

  • Kukulin35
    2 posts

    @visionarytiger yes, i have same problem. Ubisoft please fix this

  • BrodieRees
    3 posts

    had similar issues. I completed the waterfall portion, collected all the plants and got out of the waterfall area. There was a cut scene, I went falling down a hill and now there is nothing for me to do. The game has locked where it will not allow me to travel or pull up the world map at all. There are no quest markings and I have no clue how to proceed. Have tried going through the waterfall multiple more times and nothing happens.

    so annoying

  • BrodieRees
    3 posts

    I completed everything with the mission with finding the waterfall and all the roots. I got out of the waterfall area and had a cut scene with Loki etc before falling down a steep mountainside. After that the mission seems to still be ongoing but there are no markers to go after and no indication of next steps. The game will not allow me to open the world map and I am at a complete loss as to what to do next.

    This is very frustrating to encounter this issue so deep into the game. Please advise on how I can complete the mission and move on.

Suggested Topics

Community Details