Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • ImaginaryRuins
    354 posts

    @redeyejedi3 Agreed. I am not saying the game itself is bad; in fact I love it even more than Origins and Odysseys, but the no. of glitches and bugs are simply unacceptable.

    1. Opals still seeable by the Raven in the air despite they are not present
    2. Legendary animal trophies
    3. Duplicated Asguardian ship cosmetics (due to fishing store reward) and duplicated armors (due to tattoo shop)
    4. Treasures not spawning for several hoard maps (Ledecestrescire, Oxenefordscire, Eurvicscire)
    5. Fish despawning and big mackerel, flatfish, eel not spawning at all
    6. Multiple items wrongly remain in the Inventory despite having used them


    Please Ubisoft get them fixed ASAP.

  • streethawkfan
    14 posts

    @imaginaryruins Also fix Reda, can't do Viking for Hire or trade opals for gear...

  • NutellaToastNer
    1 posts

    The treasure hoard doesn't appear even though I found and looked at the map. I reloaded my save file and checked the same spot later but it doesn't appear.

  • ImaginaryRuins
    354 posts

    This issue has been reported multiple times, for a long time as well. Happened to my save as well; reload does not help.

    From what I know, Ubisoft is aware of the issue, but when it will be properly addressed is not yet officially revealed.

  • Vanyar1
    10 posts

    It may be wise to make a "mega thread"/"post here thread" for the treasure hoard bugs as there are a lot of threads regarding these kind of bugs. That mega thread should then be posted in the "Reported Issues" thread so people know that it's being investigated.
    The reason I'm suggesting this is because I was wondering if those bugs have been noted at all, and I only stumbled upon the answer from the Ubisoft guys here by accident. I'm pretty sure a lot of people are wondering the same because in most threads they can't find an answer.

  • TheChaosEffect_
    1 posts

    @mattacus94 I’m also having this exact problem in Ledecestrescire. I hope they come out with a fix soon!


  • RedeyeJedi3
    6 posts

    UPDATE: After the recent 1.1.0 update, 1 of 3 reported treasure hoard reward locations has been resolved. My affected locations were:

    Grantebridgescire - Was able to loot this treasure, and also have the treasure hoard map leave inventory. Received Snakebite Scheme (hull) 🙂

    Oxenefordscire - Was able to loot this treasure and get the rewarded XP. Treasure map still in inventory. No reward received. 😕

    Eurvicscire - No treasure at destination. 😠

    On another forum thread, it’s also confirmed this 1.1.0 update did NOTHING to address the issues with Big Flatfish and Big Mackerel spawns.

    At least all the slain legendary animals do properly show mounted in the great hall of the longhouse in your settlement.

    I’m done with ACV until Spring 2021. I shall then wait to peruse reviews on the additional content for Francia to see if it’s going to be worth the $39.99 that the Beowulf arc is presently clearly just a joke. Enemies in the new content must be beyond 490 power or I’m not buying.

  • Psych0_Trauma
    51 posts

    @redeyejedi3 just don't bother buying it. let it sit until it's half off.

  • ErickAshlock19
    1 posts

    @caponeor2 I am having the same issue as well on PC tweeted them several times and no response. only reason i ran into this thread is because i was having a issue with him acting drunk now and figured i would look for some more bugs.

  • larrykop1967
    65 posts

    There is 2 missing for me Eurvicscire and Oxenefordscire right now, Ledecestrescire was missing before, but after the patch, it did show up and i got it.

  • jaydakilla
    1 posts

    @zieeell were you ever able to get the hoard treasure? I can't get mine and we're over a month past your original post....

  • ImaginaryRuins
    354 posts

    @jaydakilla Even with patch 1.1.0 it apparently is still not solved, because I already checked. Xbox One.

    I wish Ubisoft could at least put it in the megathread to show that they are trying to look into the issue.

  • mattsmith5656
    1 posts

    I am 60 hours into my play through, and I’m working through a completionist play through. The fact that I never got credit for picking up the Ledecestrescire Hoard Map is still haunting me. THIS IS NOT the bug where I cannot interact with the treasure. I collected the treasure. If I remember right, it was a sail design. No, even worse. It says I am missing an artifact when I have collected all artifacts. Because of this, I will not be able to 100% the game. Which is mind-numbingly frustrating, especially when you expect to log 110+ hours into something. Please help.

  • Tombraider7769
    11 posts

    Having the same issue with a few maps.

  • mrbondarchuk
    1 posts

    Same for me

  • KoloheB
    5 posts

    @ubi-baron Here's a video of the missing horde in Ledecestrescire for me. Thanks!


  • KoloheB
    5 posts

    @redeyejedi3 And 3 more are bugged for me:

    Oxenefordscire:



    Eurvicscire:


    Suthsexe:



  • WHOA_iM_A_LADii
    2 posts

    @koloheb its January 9th and oxenefordscire and eurvicscire are still bugged for me. Just don't show up at the locations even though I have the maps. This is getting ridiculous.

  • Malandro_Rife
    1 posts

    I have the same problem on all the maps I found.

  • d-von2002
    10 posts

    Missing 5 Hoards myself.

    Ledecestreschire, Rygjafylke, Grantebridgeschire, Oxenefordschire, Eurvicscire.

    I have all the maps but can locate none of the treasures, 3 are at the bottom of wells. Hopefully they fix this bug soon, besides one bugged Mystery and the missing fish bugs, this was all I had left to do.

Suggested topics

Community details

8
Online
123.4k
Users
21.3k
Topics
109.4k
Posts