Welcome to discussions

Quick Suggestions

  • larrykop1967
    66 posts

    There is 2 missing for me Eurvicscire and Oxenefordscire right now, Ledecestrescire was missing before, but after the patch, it did show up and i got it.

  • jaydakilla
    1 posts

    @zieeell were you ever able to get the hoard treasure? I can't get mine and we're over a month past your original post....

  • ImaginaryRuins
    418 posts

    @jaydakilla Even with patch 1.1.0 it apparently is still not solved, because I already checked. Xbox One.

    I wish Ubisoft could at least put it in the megathread to show that they are trying to look into the issue.

  • mattsmith5656
    1 posts

    I am 60 hours into my play through, and I’m working through a completionist play through. The fact that I never got credit for picking up the Ledecestrescire Hoard Map is still haunting me. THIS IS NOT the bug where I cannot interact with the treasure. I collected the treasure. If I remember right, it was a sail design. No, even worse. It says I am missing an artifact when I have collected all artifacts. Because of this, I will not be able to 100% the game. Which is mind-numbingly frustrating, especially when you expect to log 110+ hours into something. Please help.

  • Tombraider7769
    11 posts

    Having the same issue with a few maps.

  • mrbondarchuk
    1 posts

    Same for me

  • KoloheB
    5 posts

    @ubi-baron Here's a video of the missing horde in Ledecestrescire for me. Thanks!


  • KoloheB
    5 posts

    @redeyejedi3 And 3 more are bugged for me:

    Oxenefordscire:



    Eurvicscire:


    Suthsexe:



  • WHOA_iM_A_LADii
    2 posts

    @koloheb its January 9th and oxenefordscire and eurvicscire are still bugged for me. Just don't show up at the locations even though I have the maps. This is getting ridiculous.

  • Malandro_Rife
    1 posts

    I have the same problem on all the maps I found.

  • d-von2002
    10 posts

    Missing 5 Hoards myself.

    Ledecestreschire, Rygjafylke, Grantebridgeschire, Oxenefordschire, Eurvicscire.

    I have all the maps but can locate none of the treasures, 3 are at the bottom of wells. Hopefully they fix this bug soon, besides one bugged Mystery and the missing fish bugs, this was all I had left to do.

  • Devman210
    1 posts

    This is still an issue, months after having been reoprted, it's not as if it's some little bug that can be ignored, it literally prevents players from collecting certain loot and completing certain tasks.
    I'm playing on Xbox One X.

  • Gwinbleid-XIII
    12 posts

    @ubi-baron So there was a patch/fix today, but hoard maps are still don't work. Why? How to get the treasures in Suthsexe (under the tree), Sciropescire? I still can't pick it up, there is no glowing or button indication. And Oxenefordscire map is still in my inventory, despite that I picked it up several times already. Give us what we paid for (as your Russian colleague claimed in another topic when was asked for English text and subtitles) and give us english text and subtitles, as you can't give us what we paid for.

  • doktorek52
    1 posts

    I can't see hoard treasure near abandone monastery in Suthsexe and fish in the ocean and big flatfish and mackarele despite the update.

  • Gwinbleid-XIII
    12 posts

    @doktorek52 pointless update. Didn't fix anything

  • d-von2002
    10 posts

    @d-von2002

    Update fixed my 5 missing hoards!!

    For some reason Oxenefordschire & Eurvicscire never cleared from my inventory. The other three maps disappeared from my inventory.

  • Tink-Tank
    31 posts


    What I don't understand is all this hoo-ha for what surely is one of the more simple in game features:

    Spawn item "map"
    Player picks up item "map"
    Player interacts with item "map"
    Spawn item "treasure"

    How can that be broken?
    Obviously I am oversimplifying it.. but it's not one of the more complicates parts of this game surely.
    And how can it take almost 3 months to fix?


  • Gwinbleid-XIII
    12 posts
    This post is deleted!
  • Gwinbleid-XIII
    12 posts

    @tink-tankmaybe someone messed up with triggers. Used the same asset and forgot to change it to correct treasure. Or with coordinates. It might be, that the treasures actually spawns, but out of reach of players 🙂 BTW, today I got treasure without even looking into the "map", so "Player interacts" step is missed 🙂

  • azullFR
    1737 posts

    @ubi-baron

    Artifact for Treasure hoarders map does not register as collected and can not be claimed again.

    Hello !
    This exact problem is still there at least for the Ledecestrescire Treasure at this date : Feb 7 - 2021
    (400 hours of gameplay...)

Suggested Topics