Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • McFamvan
    1 posts

    Hello,

    I happen to encounter the same issue... Nothing in my bag although I finished the mission...

    Did anyone find a solution?

    many thanks!

  • Hrafin
    Original poster 4 posts

    @mcfamvan I tried restarting the game, still nothing. It's in the uplay store to buy but Im supposed to already own it.

  • Hrafin
    Original poster 4 posts

    @ubi-baron thank you for your response, I tried resetting the license as you mentioned. I also restarted the game and saved just before the quest ends to have a save point that I can reload. So far nothing has helped my DLC appear in game, at this point I'm giving up on the game as I'm not sure what else is missing that is supposed to be in the game I paid for.

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @hrafin We're sorry to hear that you've still not had access to the content.

    If you still wanted this to be looked into, we would advise speaking with a Support Agent through one of the channels below:


    Official Response
  • priscolupo
    3 posts

    I have the same problem, with also the "missing / deleted manual save point" bug.

    For this reason, i copy here the message i posted on that thread:

    HI
    I have the PC Version of the game.
    I have the same problem, my manual saves every random time disappears from the list. Fortunately the autosave works, the game has never crushed so i had not lose the actual save point
    BUT
    I have another bug, related to the disappearing of the "Berserker" armour set bonus of the season pass, as happened to many people here.
    I spent many resources to maximize the set to max stats (level 4) for both armour and weapons, when the set reappeared in my inventory, it was back at level 1!!! Losing all resources spent!!!
    My previous save point vanished!!!
    So i have no save point, no resources back, and two unresolved bugs!!!
    At least i would like to have the resources back!!! And obviously, the bug fixed!


    Thanks

  • II.DelVloNiC.II
    1 posts

    Three times now my Berserker gear has disappeared mid game. This includes my wolf mount and raven skin. The next time I reload my game it’s back but all my upgrades are gone!
    Ubisoft, please fix this.

  • manchester-red7
    1 posts

    @ubi-baron
    Hi , last night i was playing a mystery mission and all of a sudden my game glitched and my character became naked (well knickers and bra) i lost all my LEGENDARY berserker gear so i equipped my raven gear , then i restarted my game this morning and it reinstated my berserker gear as SUPERIOR!!! in my opinion i've spent hard money on helix credits and purchased large materials packs 2 of them to be honest and upgraded the 5 piece and weapons to maximum level 10, lost everything to do with that suit back to level 1 superior, i would like an answer to what can be resolved, would i be reinstated with my level 10 legendary or not, as this valhalla game has been problematic from the start in my opinion

    regards manchester-red7

  • wboze1112
    4 posts

    I just noticed after an entire play through that I do not have the berserker pack as well. Please help me rectify this immediately. I have turned off my inherent as suggested and no luck. I have also restored licenses as suggested and no luck.

  • azullFR
    486 posts

    @wboze1112

    There is a "more-in-depth" way to restaure licences here :
    https://discussions.ubisoft.com/topic/96769/ultimate-pack-and-berserker-packs-fix-read-this/2?lang=en-US

    Great Thanks to @Assassin-Zain đź‘Ť

    Maybe this can help a little 🙂

  • wboze1112
    4 posts

    @azullfr I've done that. Thank you though. Still no berserker gear. If ubisoft can't figure this out I know what I'm not spending my money on anymore. Ridiculous to pay for the gold version and not receive the promises from that purchase. Standard games for me from now on if at all.

Suggested Topics

Community Details

26
Online
128.7k
Users
22.2k
Topics
114.9k
Posts