Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Alexia_8
    4 posts

    I have the same bug with tattoos and hairstyles..when I finished the mission with Toras mentor died..after that I can't change my tattoos or my hairstyles and I'm far enough at the story of the game and level of Evior and my settlement..
    The speech icon won't appear it's very frustrating..
    I've played all the AC games and this is by far he most bugiest for many reasons...
    I'm a bit disappointed to say the least...
    Ubisoft needs to fix this bug and more...it's been ages now..

  • Codiesel30
    2 posts

    Think I may have found a fix for Xbox 1.

    Open your menu.
    Press up on the d-pad to open the animus menu.
    Select “Change Eivor’s Appearance”
    Select from female, default, or male.
    (I went from default to male)

    This worked for me even switching back to default.

  • OlAshes
    1 posts

    On Xbox, here.

    I attempted to Change Appearance from Female to Male, then to Default. I reloaded the game and changed to Female again.

    With every change I also attempted to alter my hair and tattoos. However, the ones I purchased are still inaccessible.

    I'm a sucker for customization, and this bug is preventing me from doing much more than what is available at the start. It's infuriating.

  • Codiesel30
    2 posts
    Interesting, I didn’t even build the tattoo place until after Tove took over. Then when I built it Tove was unresponsive.

    When I did as mentioned above I didn’t reload my game at all, just ran up to Tove immediately after and could interact with her.

    Also I just checked and some of my newer found tattoos were available in the shop as well.

    Damn shame it didn’t work for you.


  • Pilouitfr
    1 posts

    @ilya-rabets I had the same issue and I think I fixed it by interacting with the grave. Eivor will tell a little sentence, then I was able to change tattoo and hair again. Hope this help.

  • elisyon35
    1 posts


  • mzaman89
    1 posts

    can the can the developers please fix this! It’s very very frustrating! One of the Ubisoft challenges is to have 5 tattoos and even when my character has got on all tattoo’s, even ones of the same suit, the challenge still shows as 1 tattoo out of 5!
    Has anyone else managed to complete this Ubisoft challenge?

  • Ubi-Keo
    Ubisoft Support Staff 586 posts

    @mzaman89 I'm sorry to hear that this challenge has not completed, it's not a known issue.

    Could you please try removing all of the tattoos then save your game, return and try equipping all of the tattoos again. If that does not work could you please confirm which platform you play the game on.

    Official Response
  • Markus_Orelius
    2 posts

    You first have to do the quest "carrying the torch" because before that the owner of the shop is not there.. Select quest and follow story, that would do it..

  • Markus_Orelius
    2 posts

    @markus_orelius after that REDA will be around to do everything you want (head, tatoos)

Suggested Topics

Community Details

59
Online
129.9k
Users
22.5k
Topics
116.5k
Posts