Welcome to discussions

Quick Suggestions

  • XboxOffyesse
    1 posts

    @jackermt I hit his horse that was next to his house and it ran off. He then followed it and hopped on. I was able to finish the mission.

  • dangermouse555
    30 posts

    So just completed this pointless quest only for me to get back to the settlement and it to keep telling me I must be anonymous. Obviously that is a glitch. Ubisoft, I am so shocked you have decided to release a game that clearly needs so much work done to it. All the while you keep taking our money for something that is broken. Would you pay for a new car if it didn't work? Why must we be expected to accept games that or "kind of nearly finished but not really but we're still going to charge you". Please sort this out

  • Scoo6yDoo1981
    2 posts

    @dangermouse555 I have just come across the same problem... so frustrating.....

  • bakgreenbay
    2 posts

    @jackermt

    i untracked the quest, then traveled to Norway. Then traveled back to England and tracked the quest and it fixed it

  • bakgreenbay
    2 posts

    @ledoveeekladivo
    see my previous reply hope that works for you

  • LedoveeeKladivo
    64 posts

    @bakgreenbay

    thank for reply . . . all I´ve tried but nothing.

    Don´t know why, but when i finished completly CENT STORY ARD (with "epilogue")....story ends on the edge of your village and after completing this story arc I see my friend Tarben rides on the horse around, so I marked this quest and finally finished it. Don´t understand what happend, but I am glad, that this bugged quest is done for me.

  • BlueCorp63
    1 posts

    This is crazy everyone going through this situation, I pretty much done with the game and he is still the only person i need to get done with for me to get to the last person " The Father", and I cant get rid of it. I have tried the longship, I have tried to lose him in battle i have tired everything but i cant get rid of Tarben I'm confused on what to do. Is there anything that I can do for him to get on my mission list?

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hello everyone, and apologies for the lateness of my reply here. For those of you that are still unable to escort Tarben back to the settlement due to him jumping in and out of the Longship, please give the following workarounds a try that were suggested by players on this thread:

    • Go back to Ravensthorpe, untrack and track the 'Man of Mystery' quest, speak with Tarben again in Ravensthorpe. (Xingent)
    • Go across the river and begin killing people (matty00192)
    • Hit Tarben's horse that's next to his house (XboxOffyesse)
    • Untrack the quest, head to Norway, return to England, and track the quest again (bakgreenbay)


    Many thanks to all of you that shared these workarounds!

    Should the issue persist after, please provide a YouTube link showing the issue fully. I'll be happy to forward this to the development team for further evaluation once received.

    Official Response
  • SpentCartridge
    1 posts

    What worked for me was:

    1. If he is absolutely stuck, return to Ravensthorpe, untrack, re-track the quest, then return to Tarben who's still stuck.
    2. When I approached him, he began to follow me again.
    3. With him following, I had to return to Ravensthorpe exactly as we had come during the early part of the quest. No deviation cross-country, no trying to take a different road.


  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @spentcartridge Thanks for sharing the workaround that resolved this issue for you! 😊

    Official Response

Suggested Topics

Community Details

41
Online
193.2k
Users
32.6k
Topics
163.1k
Posts