Welcome to discussions

Quick Suggestions

  • ty5594
    1 posts

    I’ve spoken to the man in Asgard chosen not to fight but he remains and the quest stays incomplete. It is the last one on my list to finish 😤 I have left the world came back finished the story came back, nothing.


  • k2natural
    1 posts

    Same issue here. Still bugged in Patch 1.1.0.

  • Ubi-Orion
    Ubisoft Support Staff 255 posts

    Hey there folks.

    I can confirm that this issue is known to the development team and is under active investigation at the moment. To assist the team with their investigation we would like to request save files from you if you haven't already submitted those to us and if you're playing on PS4 or PC, it is not possible to export save files on other platforms unfortunately. You should be able submit your save files to us by starting a Live Chat or contacting our support teams on Facebook and Twitter who will be able to open a case for you and then following these instructions. Thanks.

    Official Response
  • Afiafire
    3 posts

    Just a FYI I am playing on a PS5. Version of the game and this quest is bugged for me.

  • Mitchgray81
    1 posts

    @skissoret
    I found a fix that worked for me.
    I just stood in the fire right next to him until I desynced. On reloading, he instantly attacked me.

    Good luck.

  • Andy08THFC
    2 posts

    I'm on ps5 and this worked a treat!

  • zombiekillnmama
    1 posts

    I am an Xbox One player and this fix worked for me. Thanks!

  • RESIST_THIS
    1 posts

    @mitchgray81 worked for me as well! Thank you!

  • TheManWho__
    1 posts

    I'm playing on PS5 and I have this bug as well. Tried the fire truck mentioned above, but it's not working for me. Any news on a fix?

  • Kat3ina
    2 posts

    @skissoret I've seen someone mention how they've fixed it on PS5, I tired it on PS4 and it worked aswell. What I did is, I stood in fire next to him until I've desyncronised and after I reloaded he attacked me immediately 😊

Suggested Topics

Community Details

38
Online
193.2k
Users
32.6k
Topics
163.1k
Posts