Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • DeadHawkmummy
    1 posts

    I have a bug where I was fighting Nokkfylla Shine-Eye and he happened to climb on a wall during our fight. I defeated him only for him to be stuck there so I can’t talk to him to finish the quest. I can’t really go back to a previous save because I didn’t think to 40+ hours ago.


  • P6543213
    2 posts

    Hi everyone,i habe bug in the quest The Good man of Sherwood,i am a german ps4 Player. I can Start the quest until the second step..but than it buga.. i have to Done step 3 (hit the bunmy on top) but cant do it. It is my last quest do finish valhalla to platin trophy pls Help!!!!!

  • P6543213
    2 posts

    Hi Everyone. I have a problem i am a german ps4 Player and I need only one sidemissions to get the platin trophy. It is the quest the Good man of sherwood.. i can Start the Mission until step 2 than it bugs,cant do talk to the 3rd Person.. cant hit the bunny on top the hill.. pls help

  • kerrieboulton
    1 posts

    wealth ingots are invisible, killed the enemy holding the wealth but they’re not dropping it but still indicates that the wealth is still there. - stenwege camp

  • Dale_Factor
    2 posts

    In Lunden Mystery titled "Falling Stars" I am unable to interact with the quest NPC Ysane who is sitting there crying about Ostrid.
    This is the last anything I have to complete and it is stopping me from obtaining my Platinum trophy.
    I am too far to reload a save from before this point

  • Dale_Factor
    2 posts
  • TSSClutch
    1 posts

    Okay so I accidentally started off as a female character than switched later on when I figure out how to, however I'm still getting the conversation ques as if I were the female character. Also I'm fairly certain I'm supposed to be taller than I am.

  • guest-QalK7I0O
    3 posts

    @geoooooooorge yea when are they going to fix this?? I would like to use the sword at least in asgard

  • Iron_Will_717
    1 posts

    When I try to start the lundun mission, eivor just freezes and can’t move.

  • larrykop1967
    65 posts

    Started a new playthrough on the latest patch and i have only level 1 of man's best friend ability, i didn't get the 1st level when i did the Knud quest, i've only just noticed and i'm well over 200 power level, so going back to earlier saves isn't possible, i didn't have this bug before on my first playthrough on 1.02, so for me anyway, this bug isn't fixed

  • Jugaresbueno
    1 posts

    I can't continue the story because the ending of the york storyline is blocked, I can't speak with lufvjina to end the quest.

  • Elphz17
    1 posts

    In Jotenheim during the Lost Cauldron Quest, I am unable to interact with the cart while investigating where the cauldron might have gone. The eye appears but nothing happens with I click the interact button. Playing on ps4; I'm unable to progress due to this bug and even going back to previous saves hasn't worked. A fix would be very much appreciated.

  • NellieWilson
    1 posts

    @plasticoreo I paid her the minimum and she kept following me all the way to Turrim Larus Ruins and got stuck standing on a wall. She kept talking but was not responding. So I left her there and did other quests. The next day I went back and she was still there on that wall. I was able to climb the wall and basically stand in the same spot as her and the Speak prompt came up. It let me pay her the full amount to complete the quest.

    You need to find her, wherever she is, and hope she gives you the speak prompt. She's probably stuck somewhere. undefined

  • guest-6RwOxbmt
    1 posts

    5 times in a row when fighting Fenir, it glitches and i cant fight or it puts me in the red sky.

  • erok5
    1 posts

    During the defensive measures quest in Asgard enemies will stop spawning but the quest will not end. The barrier will stay red and hurt when you exit. When you fast travel to the vantage point it will desynchronize and sometimes crash the game. You can "wake up" asgard but there is no way to progress.

  • SparkleBunz
    1 posts

    NW Glowecestrescire Cairn doesn’t activate. Can not complete mystery. Walk up to it and it does nothing.

    This forum would not let me attach photos.

  • watersneiljake
    1 posts

    I'm doing a contract to rescue a civilian, I've rescued them but now it keeps saying "you must be anonymous" after I ran 800 metres from the hideout with no enemies around

  • marcusraptus
    1 posts

    Hello, When I'm moving, walking running swimming, Eivor will every so many second do an automatic attract. this is very frustrating especially in crowded areas killing civilians. I have not been able to find anything Google any knows of it and how to fix it? I can't hardly imagine it being skill tree feature cause it's gravely in convenient and annoying. thx everyone

  • boo-yah1907
    138 posts

    @marcusraptus if you are on laptop may i suggest turning the pad off.and use the external mouse only

  • azullFR
    394 posts

    @marcusraptus
    sorry, but I don't really see what your "automatic attract" is,
    I know the "R1" (PS4) attract after assassination in skill tree (that I disabled a long time ago... backward camera rotations are awfull)
    I know too some kind of auto-lock during combats (even auto-lock is disabled)
    I know too sometimes Eivor's face turning to and fixing an imaginery point in the sky (often when ridding horse on some locations)
    Could you send a link to a short video
    Are you using PC,PS,Xbox ?
    Nice day to you 🙂

Suggested topics

Community details

16
Online
119.8k
Users
20.7k
Topics
105.9k
Posts