Welcome to discussions

Quick Suggestions

  • Denkafromnorth
    2 posts

    Mystery in Snotinghamscire:
    The Good Men of Sherwood


    NPC spawning the mission dialogue got killed by Wolf, will not respawn after restart or fast travel.

    Therefor not able to achieve platinum on playstation

  • xprincevincex
    2 posts

    @xprincevincex CAN SOMEONE REPLY???????

  • matsze1992
    2 posts

    Hello,
    I am playing PC version of the game with ultimate edition
    I picked up quest below when I've appeared in Ravensthorpe, however they disappeared suddenly from my quest log and I cannot also see letters in the box to trigger them again
    "The Way of the Berserker"
    "The Legend of Beowulf"
    Also, every hoard map treasure cannot be picked up when finding the correct spot, also treasure maps are still in the inventory. Any ideas what to do?

  • Reaver7593
    3 posts
    This post is deleted!
  • matsze1992
    2 posts

    @matsze1992
    Welp, seems like the game stopped acting out when I've entered East Anglia region both quests reappeared in the log.
    What a mess...

  • miichiii95
    2 posts

    I've found two bugs in Glowercaesterscir on Xbox One:
    I cannot finish two quest. I restarted and reloaded but nothing changend.
    In the Lady of the Lake I talk to the woman after she trying to poison me. After Eivor said "Do you wan't to say any last words" or something similar, she doesn't react.
    In "Horn of Ragnar" I am in the house and suddenly the real owner appears. So I have the choice to kill the thief or kill the owner. No matter what I choose, the two of them still standing there and watching each other.
    Hopefully the patch next week is going to fix this bugs.

  • BonnitoDude101
    3 posts
    This post is deleted!
  • Raiszs_
    1 posts

    Hi there,

    I have an issue with the quest uninvited guests. I can't do anything and after a few seconds Eivor just drops down below the ground and dies.. Even if I try to upload previous saved games, it still starts at the same scene and the same thing keeps happening again.

    Can't upload the video.

  • Dadda236
    3 posts
    in west anglia, to the right of Elmenham, there is a resource, a nickel ingot, which despite having obtained the game does not report it to me as a hold, and therefore I lack a wealth to complete the east anglia. Could you please help me?
    
    


  • Philaffi1972
    2 posts

    book of knowledge in crepelgate fort next to lunden, I can’t move the bookshelf to get to the book?!

  • DUBBLEJD182
    3 posts

    Drinking challenge at odins rest in snotinghamscire not working, I go to the guy on odins rest I accept the challenge and place my bet but then it just does nothing and goes back to me standing in front of him, its taking the silver from me each time I try it but the challenge just doesn't start!!
    I've gone away for a while then come back but still doesn't work.

    I'm playing it on series x

  • laddcm
    1 posts

    I cannot complete the world event with the smelly house in Grantebridgescire. I cleaned the house and shot the platform under the father, causing him to fall like he's supposed to. But now he's just floating in the water instead of continuing the event like he's supposed to. Any suggestions?

  • LandOLincoln
    1 posts

     World Event (Skal to Your Wealth) the bear is nowhere to be found. Pig of Prophecy, I cannot speak to the pig the 2nd time, cannot get effect from drinking in order to interact with pig beyond the "Hello, pig" response.

  • Ya_Boi_Garbo
    1 posts

    I have 2 bugs that are stopping me from finishing 2 areas and I'm over 100 hours in on ps4

    the first is in Vinland, it is the world quest when you speak to a man in Nyhofn who is looking for someone i have completed the other world event that ties into this one and the body of the man from the flight of fancy quest has been shown to him but he will continue the mission, he will sometimes stand up like he is about to continue the mission but then sits back down again

    the second is the interact button for the Regan boss battle will not appear on screen. I attempted the boss twice when I was under leveled and I decided to go and level up before trying again but when I returned I couldn't activated the fight

  • HomesickDonkey
    2 posts

    This latest update didnt fix the weird glitch where weapons just grow in your hand, they're normal size when sheathed, but when you use the predator bow for example, it grows to the size of Eivor if not bigger. Melee weapons also grow in size

  • Zaokoon
    1 posts


    world event in lincolnescir near elfgarstun still buggy for me. man on back of a horse without any texturse. near a tree with a letter

  • Dizzlam13
    1 posts

    Orlog npc not appearing in Crawleah, Suthsexe. Went there before quest where you burn town and wasn't there. They did quest and still wasn't there. Tried reloading, resetting ps4 and still nothing. The game board is there and so is the icon but no npc to interact with. Plz fix.

  • UbiKoality
    Community Manager 440 posts

    @homesickdonkey I'm sorry to hear about this annoying glitch. For some insight, you can see everything that was addressed in the 1.1.0 patch here. If you are able to provide images of the bug you're having trouble with, I'd be glad to share them with the relevant team. Thanks!

    Official Response
  • Barrywipe5
    4 posts

    Hello,

    my stupid pnj Hunwald is blocked inside a rock.............

    Salve for a Fresh Wound - Talk to Hunwald (after you've to take out the enemies)

    While killing all the enemies, he died by the last one alive ( "!" mark to heal him), I kill the last enemy and Hunwald glytch inside the rock he was standing on.......
    Now the quest is completely locked as I can't talk to him... (can't restart it, reboot game, whatever, ...)
    Can't put a screenshoot as I've not the privilege...

    A fix would be appreciate...
    Kind regards
    Alex

  • gregory2303
    9 posts

    2 big issues who arent still solved:
    Last order member doesnt appear even by completing everything else
    Cant complete map because after the last patch one wealth in vinland was taken away from me, but i cant get it anymore because the guy is dead. Still zhat way after that patch

Suggested Topics

Community Details

139
Online
141.0k
Users
24.9k
Topics
129.1k
Posts