Welcome to discussions

Quick Suggestions

  • Wolvenfoxx
    2 posts
    This post is deleted!
  • HolyArch0n
    1 posts

    So I'm on xbox and whenever I try to load a save the screen goes completely black then after 30 seconds or so my game crashes, it was all fine before river raids update dropped.

  • shsreen
    3 posts

    Lunden story arc still stuck for me at the Firing the Arrow quest. Also Old Cellar is still bugged. 3 patches/updates have gone by but these bugs still remain. Very very disappointing.

  • bremmelgas
    2 posts

    One of my bows is glitched. I completed the Essexe arc and then immediately proceeded to the Suthexe arc. After completing Suthexe, I obtained the Arc of Elan bow via the conventional method. After the various cutscenes that play out after the Suthexe arc, I went to the blacksmith to upgrade this bow and here is where I think the glitch occurred.
    The Arc of Elan bow was initially fully upgraded at superior, and had the exact same stats as my fully upgraded flawless Hunnish Bow. After upgrading the Arc to Elan from Superior to Flawless, I assumed I would be able to activate the three added upgrade slots, but this was not possible. In upgrading, these three slots were filled and I was unable to upgrade Arc of Elan, but the stats also didn't increase, meaning that Arc of Elan had the same stats as a fully upgraded Superior and Flawless Bow.
    I reloaded and tried upgrading again, and the error persisted, so I have since re-loaded and have left the bow un-upgraded until the problem is addressed.
    I can submit photos if needed.

  • firewolf1971
    4 posts

    I'm having the same problem with the St George's Helm I searched every chest in River Dee the chests opened but No Helmet so I loaded and earlier save I saw a post above said it was in deesbury but it also can appear in The forward Camp too so i will check both and report if I can get it other armour pieces I got No Problem I'm on PS4 as hawk2000_- can you look into it

  • james21lol
    2 posts

    “the tale of sonic of the hill”

    After I finish him off the game doesn’t give me xp or finish the mystery so it’s just bugged him standing there.

  • FirebirdUK3
    11 posts

    I'm on Xbox series X and had a few issues with the new update, mainly around fast travel. When I chose version locations to fast travel to, I get the change of scene, where you can move Eivor around while it's loading, bit instead, the game just hangs. Eivor stood moving and the game doesn't respond to anything. I have no choice but to quit the game and load it again. Never had the issue before.

  • Tommando87
    1 posts

    Could u guys maybe fix the bug where Trygve wont get on your ship in a mission "old friends" ?
    I have tried everything now (burnt the ships, rowed back and forth the the riven, tried to shoot trygve near the boat so he can hop in, meditated, done different missions and tried to return) and i've lost my hope and stopped playing cuz of this problem. Those guys and Trygve are just standing there stupid on their horses and wont budge.
    Not the first bug or glitch i've encountered, but this one is just totally blocking my story mission progression and im fed up with this.. Love the game, but these sudden crashes and bugs are killing me.. =(

    Im playing on PC.

  • guest-yPcKU8So
    1 posts

    Hi my username is CLIComs and i cant carry halfdan in the eurovicerie when he is drunk. I have tried every thing but it doesnot work. The button for carrying is not showing.

  • decker528
    2 posts

    I completed the quest "burning the firebrand" but no new quest came up for me to continue with the story. Ive restarted, gone and done other quests, and everything i can think of but I'm still stuck a month later

  • Draaahh
    1 posts

    Big fish still failing to spawn (Flatfish/Bream), fish just travelling under boat not being able to be brought up, Oxenfordshire and Eurvicshire Treasure Hoards both unable to be collected, they appear, you interact, but nothing appears in Inventory and maps remain there too.

  • ChimamireNoHana
    14 posts
    This post is deleted!
  • Skysral
    5 posts

    Hiya,

    I’m currently on 98%. Cannot get the platinum because of 2 issues I’m having.

    Eurviscire:

    1. Stenwege Camp shows a yellow wealth dot just outside the main gate but when I get there, nothing is there to collect. Cannot complete the region. I think this has something to do with being too stealthy when I was there for a mission. I managed to sneak into the base and kill the leader with only alerting one guard. Once this was done I was informed the base was under Norse control. I think the ingot was with one of the pictish elites and as they’re gone, it’s disappeared. Please tell me there is a way to fix this other than restarting and losing my almost 160hrs.
    2. Lost Drengir - reconstructing Ragnars death doesn’t work for me, tried all the fixes suggested online.


    Any help would be greatly appreciated, I really enjoyed the game and would like to complete it fully.

  • hickyRN
    1 posts

    Hello. I've just bought AC Valhalla, and the sound is not working properly. I have background sound, but no speech or dialogue, so I can't hear or read what the characters are saying.

  • guest-qCW2dpqI
    1 posts


    Having an issue with Deebury Raid. In the middle of raid on Deebury I realized I had reached my Foreign Supply limit so I ended. I can’t remember if I had turned off the console or went back to the shop to end it properly and return to Ravenathorpe.

    Regardelss, the Deebury Raid symbol is shown on the world map, as it should, but when I get to it, it’s all burned out already and no yellow beacon to initiate a raid.

    I’ve restarted the console expecting it to correct itself but it hasn’t. So currently, I am unable to complete the quest by obtaining the last piece of St George’s set that I need.

    Any advice?

  • FletchTheFish
    3 posts

    @slav_peppa_pig Did you ever get a fix on this? I now have this bug and I can't progress with the storyline

  • FletchTheFish
    3 posts

    "The supply line" quest line is not functional for me. I have destroyed all the crates and completed that quest but it is not giving me the next quest and seems to be stuck. This unfortunately is game breaking for me as I can not complete the quest arc

  • guest-7PoErFsz
    1 posts

    There is a bug what makes appear a purple box in Exe river map, when you open it (like a normal chest)It gives you an armor part what you only can get on Reda's shop or buying his full armor on the shop with Helix credits.

  • hoppy2782
    2 posts

    @xdgkx96
    i am having the same problem... its the very last one i need ... did u come up with a work around because i cant find one i tried everything

  • ck201822
    1 posts

    When trying to enhance gear at the Blacksmith in the Settlement, about half the time I scroll down, the inventory will scroll back up to the top before I can decide what to enhance. There is sometimes a delay of a couple of seconds before it does so, but other times it is nearly instantaneous. Has been a problem more often than not for me since the River Raid update.

Suggested Topics