Welcome to discussions

Quick Suggestions

  • boltstorm1
    2 posts

    Hi don't know if this has been reported

    Trying to complete a part of order of the ancient in glowecestrescire when entering the town across the bridge or freezes nothing responds and then goes back to home screen and close game. On Xbox sires x have upload video to you tube as unlisted the link is


  • labar7676
    1 posts

    My bow (Nodens arc) had just 106 attack instead of 133. Does anybody knows why?

  • guest-P0bPSQfJ
    1 posts

    On PS4 I have got into a state where I can do very little.

    I can't talk to Halfdan, that quest is blocked. This is the first one I noticed that I couldn't do. I talked to him before I had accepted the quest, which should not have been the big deal it turned out to be.

    The wedding quest is blocked. The only NPC I can communicate with in the settlement is Gunnar, which takes me down to the blacksmiths shop. I don't need anything from the blacksmith. Sigur is dancing like an idiot, he and Gunnar are on top of the hill.

    I can't talk to Vagn to do river raids.

    I can't talk to Ranvi.

    I can't talk to Reda in the settlement, but I can pick up contracts in other settlements.

    I can't drink the potion in the seer's hut, so that quest is blocked, too.

    Why is the raven's sight so bad. Sometimes he flags things, other times not, sometimes you can focus, other times not.

    I have a lot of hours in this and don't want to do it all again. Please patch it so that these missions can be completed/started. Either that or I expect I won't be able to play the DLC when it comes, so I just won't bother buying it.

  • Lanfear1982
    1 posts

    Pc CTD everytime i try to transmog to the vinland outfits.

  • Awuulius
    3 posts
    This post is deleted!
  • Mauchau74
    1 posts

    Your latest update has caused an issue for me on my PC. When I try to run the game in Borderless window I can only see the top left quadrant of the screen, almost as if its running the wrong resolution but its not according to the settings. No issue with full screen or windowed mode just this issue on borderless window. I did not have this issue before this 1.2 update.

  • guest-233n79yo
    1 posts

    I have a glitch in the forge and the flame were the cutscene won't play and I can only speak to gunnar wich sends me down to the blacksmith

  • BALARIE5
    1 posts

    My raven doesn t sit on my shoulder when idle. On a new save, it does. Can u help me?

  • EmilyMortensen
    2 posts

    I'm having a problem with Tarben in "The baker's plaint" quest.
    First time, i accepted, got to the market, sailed home, but the quest never ended when i arrived at the docks. I loaded my game saved before taking this quest hoping it would fix it, but now whenever i arrive at the market nothing happens, Tarben is just standing on the boat, no cutscene, and i can't fast travel, nor can i save, when this happens, i have tried it multiple times now, and it's getting quite frustrating.

  • Alessandro0996
    6 posts

    Help. Please fix this bug. I have found out that dead bodies of horses would not be removed in Ravensthorpe even after restarting the game😔. Try riding a horse from your stable. Bring it in front of Reda's Shop. Kill the horse. Save game. And the dead horses will stay there forever. 😔😔😔.

  • guest-rzAqIN2T
    2 posts

    Playing the Gorm Assasination quest. Went out of the camp to grab a couple berries and chase some of the men in the camp out of it. Well, when I went back to go after him his tracking marker doesn't even work..Shows that he's all the way off the map where you can not go. I have even went back to load previous saves and still the same... How can I fix this????

  • guest-TSv8bLaI
    1 posts

    Help please! I’ve given Hytham all the medals and then found Ragnars resting place and got his dagger. But then... that’s it. No ending cutscene or anything? All the quests are done and nothings happened?

  • jacklovett2
    1 posts

    Following the road and pressing Y to go to objective rarely works. Sometimes I go in the correct direction but the horse won't stop so continues to ride past the objective. Other times the horse just goes in the complete wrong direction. Experiencing this on xbox one. It's been happening since day one I think, it's getting pretty annoying.

  • imsoreallover
    2 posts

    @almulder same issue here. Very frustrating.

  • imsoreallover
    2 posts

    Jorvik questline broken.
    The welcome party is the active quest.
    No marker shown.
    Spoke to one guy then went to house.
    Just... Nothing.
    Please fix this.

  • emanumitous
    8 posts

    Hello, in the mission salve for a fresh wound, hunwald is stuck in the rock, so i can't talk with him, and i can not continue the mission, if you can help, i will be happy, thx for the support.
    and I play in the xbox one s.

  • emanumitous
    8 posts
    This post is deleted!
  • Mauzoman187
    1 posts

    Im on an avange player Quest. The player died by the fighting chickens in Snotinghamscire Hemthorpe. It is not possible to kill the marked chickens. When i attack they don't loose health.

  • azullFR
    677 posts

    @carldemor
    wanna see (hear) a funny sound glitch ?
    have a lool there (28s video)
    https://discussions.ubisoft.com/topic/96747/yule-ostara-event-introduced-a-gremlin

    🙂

  • emanumitous
    8 posts
    This post is deleted!

Suggested Topics

Community Details

73
Online
139.0k
Users
24.3k
Topics
126.1k
Posts