ubisoft discussions

Quick Suggestions

  • Itsybitsyaboudi
    1 posts

    I have 3 bugs ever since the Yule festival was added. First: After every reset in Reda's shop, I see 2 contracts available for Opal. I pick 2 of them but only 1 appears in my Quest Log. I tried different ways to attain both of the contracts but the bug persists. This means I can only get 5 Opals a day which is insane! I would really like you to fix this bug ASAP. Second: Everytime I load my game, Eivor has the effects of being drunk (Foggy Screen, Camera tilting a bit), and everytime Eivor dies, the effects reappear. This issue does go away after a while, but it is soo frustrating and puts me off from playing the game altogether. Third: I accepted the quest to travel to Vinland after the Yule festival, and when I finished the arc, I noticed that Eivor can no longer carry more than 12 arrows in his pouch which is also not appearing on his clothes. To be clear, I had already upgraded his arrow pouch to the max way before the update of the Yupe Fesitival. I would really appreciate if you fix these bugs especially the first bug. This is substantially lowering my chances of getting items from the helix shop for free.

  • BennyG916
    1 posts

    On the mission More Intel It says to speak to Randvi about Wincestre but it doesnt give me any option to talk about it. Does anyone know whats going on and how i can fix this? All help is appreciated, thank you


  • Slav_peppa_pig
    1 posts

    I cant finnish the supply line where you have to destroy supply crates in dhustone quarry because i have done that before starting that mission already...crates appear broken but with "sense" theyre still marked as mission objective. I tried to bring oil canister onto it and blowing it up but it didnt help...also i cant finish case of a missing ale because i went into water with ale and now i cant even start mission or speak to ake

  • Steije2006
    3 posts

    @itsybitsyaboudi first do the ones you have
    after that the other one will appear on your screen

  • durka1311
    1 posts

    Good men of Sherwood bug

    Unable to complete this mystery because the NPC that has you shoot the chicken is dead. No idea how he died, when I arrived at the location he was dead near the targets.

  • LansSolo
    13 posts

    Soooooo many bugs with yule festival. None of the quests complete or go beyond initiation. How many bugs can one game have???

  • Hideousbeing
    1 posts

    On PS4.

    When trying to complete the quest "Of Fist-Dances and Sweaty Oaths" I can talk to the guy out front and follow him downstairs, then he asks me if I'm ready to fight and I say yes, the screen goes completely black. If I use Odin sight I can see during the Odin sight pulse/ but no other light source works, and there is no fight he's just standing there. All of the spectators can be attacked and killed but the 3 people you are supposed to fight just stand there. I tried walking outside the screen is still completely black.

    Not sure if it matters but I am getting the drunk effect on start up.

    Also I tried both dialog options to get to the fight and either way the bug came up.


  • mikita.bernard
    3 posts

    The quest “Defensive Measures” does not work. If I try to leave I die. I can’t even spawn to a new locations without dying instantly. This has my whole Asgard experience stalled because it will not allow me to move forward with this quest.
    The quest “A rivalry for the Ages” does not work because the key I am supposed to use is not in the game despite saying it’s there.
    Also, whenever I load into the game or spawn into a different spot my character is completely drunk for some unknown reason.

    The issues have been going on for quite some time and still haven’t been fixed.
    It’s making the game very unpleasant.

  • yuli_black
    3 posts

    @bennyg916 you need to click on it on the alliance map. It’s very small and hard to find. It’s within Hamtunscire

  • NinjaPigeons93
    1 posts

    A follower got trapped behind a door during a raid. This follower was the one that was needed to open a 2 person "force open" chest, so whenever I tried to open the chest nobody else came to help, despite there being up to 8 others also stood in the room. Thankfully I worked out this was the issue, managed to get behind the stuck viking, and managed to knock them out by using my charge ability.

  • ARCH-NEMESlS
    1 posts

    @valentikroy Same problem. I sided with the cave fellow, and tried to scare off the priest and his followers with the wolves nearby and raven distract. Most of them fell to the wolves. There’s no dialog after that with the cave fellow to close out the quest. I wait several days and come back, to find new followers but no priest...and no dialog options. I can’t attack the cave fellow or the bear either since they’re allies; everyone else is considered civilian.

  • GrenadeMessiah
    1 posts
    This post is deleted!
  • ImaginaryRuins
    418 posts

    Still need to fix:

    1. Mark of Sol bow still purchasable after buying it.
    2. Bjorn not staying in long ship crew.
    3. Big flatfish, eel and mackerel not showing up.
    4. Asgard ship cosmetics doubled due to buyable from shop and fishing shack rewards
    5. armors duplicated due to talking to tattooist (NOT fixed as Ubisoft claimed)
    6. quest items / chest keys remaining in Inventory after using them / quest finished
    7. the 3 new skills disappearing from skill tree
    8. treasures not spawning after acquiring their maps


    Playing on Xbox One.

  • scarlet42
    2 posts

    Hi I’m having several issues since doing the last update...
    xbox one version
    every time I teleport or first log in or after I die and come back I’m “drunk” for awhile after which is really annoying
    unable to complete one of the Yuletide missions.. the booze barrel one, after we get the barrel it won’t let us return it anywhere.
    lost my fully upgraded arrows and now can only carry 20, it got stuck at 12 for awhile so traveled back to Vinland and it reset my quiver back to 20 max arrows and I can’t upgrade it again because I have zero cloth and haven’t picked up any cloth anywhere to re-upgrade my quiver to max.
    I never got the early purchase rewards mission or can even find how to install it.
    lots and lots of bugs but I’m really frustrated with the quiver one that halted my forward performance

  • guest-rjDivMyF
    2 posts
    This post is deleted!
  • guest-rjDivMyF
    2 posts

    When I go to aim with my bow, rather than drawing back the arrow to cause maximum damage, it rapid fires. I have tried restarting, reloading, etc. nothing works. Please help!

  • AnneGrenon
    2 posts
    This post is deleted!
  • Crimsondemon0
    1 posts

    Hi I Have two world mysteries in Glowecestrire that won't work. One is Bron and the locket and the other is The singing lady in the woods. When I get to the point where combat is suppose to start they remain a neutral blue and I can not fight them

  • SordidMeerkat14
    6 posts

    Eivor's dialog gets permanently stuck on the same line after freeing the cats in a world quest. It doesn't reset when promoted into another dialogue and will even keep repeating the line during another dialogue. The line is "there you are, run for the fields, tot tot, fight you battle." Leaving the game doesn't fix it either.

  • flipsy06
    1 posts

    Hey Ubisoft

    massive issue with my game the raid on Cicestre Abbey has been completed but not recognise as done. Now every time I load in it is glitched can you please assist

Suggested Topics