Welcome to discussions

Quick Suggestions

  • evileye1025
    1 posts

    I know that Ubisoft is aware of the bug on the mystery in Lunden. I have tried all the work arounds and nothing seems to be working. I have excited the animus and changed from a male to a female and nothing works. I am just wondering if this is a bug that will be fixed. Right now I cannot earn the completionist achievement because of this bug. I have put way to many hours into this game to start a new one just so I can do one mystery. Please give some more info on when we might expect this to fixed.

  • Lsilva2838
    1 posts

    Hi I have a few bugs to report one in vinland. Thats where I'm supposed to be able to get the black bear furs and everything I kill anything well all it does is give me leather...kill a fish here is leather..and on top of that I can't get the last treasure I need to get the completion trophy due to the enemys not responing he just lays there and I can't get it.

    Also in the homestead I have killed all the alphas but only like 2 show up on the walls not sure what that is about either.

    Besides that it's a amazing game and I love it I have like 160 hours on it so thank you for a great game

  • FlipDizzle
    2 posts

    During honors hubris quest I go to speak with the Picts after the beginning dialog. When it goes to the loading screen after approaching the picts on the road near the fort, the game freezes during loading screen. I have tried some fixes I saw online but nothing works as well as deleting and reloading the game. Almost a week now. I am now stuck and cannot continue the game/story. This is unacceptable and game breaking Ubisoft.

  • Subject86
    1 posts

    I have encounteredva bug in the bishop's residence in Winchester. The crate blocking the hole in the wall from which you shoot the door lock to the chest room is stuck and will not budge at all. I have tried meditating, fast traving and reloading and the problem persists.

  • deoxide
    1 posts

    Hello. Sorry if someone alredy told this but here it goes...

    Im at 87% completion, trying to get to 100 and hunting all the trophies but i got a problem.

    Finished main story and all the other Q, and dont have the lunden arc and suthsexe arc trophies. Done those arcs on ps4, changed after to ps5...
    And i cant get the new wealth in vinland cause the guy that holds it its dead on the floor and I cant loot it, and with this cant get the trophie of all regions completed.

    Hope you get it fixed on the next patch.

    Btw, thanks for the amazing game, story, everything... love it even with this problems. Keep up the good work.

  • shadowofajoke1
    6 posts

    @syngrey had you actually retrieved the hammer? Hamdan was probably waiting for you to find his dog.

  • Nanook_MoonSong
    1 posts

    After I finish what I assume is the main storyline, and you return to the animus I am no longer able to fast travel regardless of what I do. From removing the disc to turning the PlayStation 4 off and then back on nothing's work.

  • ktownn
    1 posts

    Hi There,

    I am attempting to complete the quest "Farewells and Legacies," however my screen goes black and my game cuts off every time I try and initiate the Althing. Specifically, the day transition cut screen happens and then the screen goes black before loading the Althing. I have attempted this several times with the same result. Furthermore, I have fast traveled away and even started a new quest and come back to it, but still nothing works! Help please 🙂

  • phattyt
    1 posts

    I'm attempting to discover clues to locate The Adze. She is one of the last three order members I need to kill. It appears when I killed Cola (the Zealot) earlier in the game he never dropped a clue. I did get the clue for winning the drinking game but that is literally the only clue I can get. I even went to the house in Cweornic where the 3rd clue is supposed to be and it isn't there. How the heck can I finish this if Cola didn't drop his clue AND the clue didn't spawn in the house?!

  • Agathalynn
    1 posts
    This post is deleted!
  • o0SwagBr0o
    1 posts

    Ok so i did the hunters house or whatever and I did the first quest with Petra but now I’m stuck I’ve reached skill 130 and her brother has still not gone missing can’t fix it bc can’t go back in the save plz help

  • Denkafromnorth
    2 posts

    Mystery in Snotinghamscire:
    The Good Men of Sherwood


    NPC spawning the mission dialogue got killed by Wolf, will not respawn after restart or fast travel.

    Therefor not able to achieve platinum on playstation

  • xprincevincex
    2 posts

    @xprincevincex CAN SOMEONE REPLY???????

  • matsze1992
    2 posts

    Hello,
    I am playing PC version of the game with ultimate edition
    I picked up quest below when I've appeared in Ravensthorpe, however they disappeared suddenly from my quest log and I cannot also see letters in the box to trigger them again
    "The Way of the Berserker"
    "The Legend of Beowulf"
    Also, every hoard map treasure cannot be picked up when finding the correct spot, also treasure maps are still in the inventory. Any ideas what to do?

  • Reaver7593
    3 posts
    This post is deleted!
  • matsze1992
    2 posts

    @matsze1992
    Welp, seems like the game stopped acting out when I've entered East Anglia region both quests reappeared in the log.
    What a mess...

  • miichiii95
    2 posts

    I've found two bugs in Glowercaesterscir on Xbox One:
    I cannot finish two quest. I restarted and reloaded but nothing changend.
    In the Lady of the Lake I talk to the woman after she trying to poison me. After Eivor said "Do you wan't to say any last words" or something similar, she doesn't react.
    In "Horn of Ragnar" I am in the house and suddenly the real owner appears. So I have the choice to kill the thief or kill the owner. No matter what I choose, the two of them still standing there and watching each other.
    Hopefully the patch next week is going to fix this bugs.

  • BonnitoDude101
    3 posts
    This post is deleted!
  • Raiszs_
    1 posts

    Hi there,

    I have an issue with the quest uninvited guests. I can't do anything and after a few seconds Eivor just drops down below the ground and dies.. Even if I try to upload previous saved games, it still starts at the same scene and the same thing keeps happening again.

    Can't upload the video.

  • Dadda236
    3 posts
    in west anglia, to the right of Elmenham, there is a resource, a nickel ingot, which despite having obtained the game does not report it to me as a hold, and therefore I lack a wealth to complete the east anglia. Could you please help me?
    
    


Suggested Topics