Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • andyrandy92
    1 posts
    This post is deleted!
  • pineapplegrl
    1 posts

    Currently doing “The measure of a Norseman” quest and I have to escort Fennir to the treasure which I can not because he is stuck in the middle of the ocean. Please help. I can’t talk to him or the “king”

  • FURIOUS_69
    1 posts

    In Vinland, I can’t return to Olav at Sky Fall as there is no teal marker and the cave where he was is not there. I tried restarting and going back to England then back to Vinland with no luck.

  • tparkerx5
    1 posts

    All my quests aside from the settlement ones are completely gone. I have the new quest notification in the menu but no quests to select or markers for objectives. Any one else have this issue or know of a fix?

  • zazu2008
    2 posts

    I have completed the Lunden story arc and I still have quests to do there because they were bugged and wouldn't let me finish them like the one with the guy trapped in his warehouse, the moveable crates became stuck and I could not move them. I have not checked to see if the patch fixed it or not.
    I moved on, spoke to Randvi and now I am supposed to speak to Hytham. I went to Oxenefordscire to beat the dice guy for a clue and realized I can't fast travel or save now.
    Please fix this. I don't want to play only to lose progress because I can't save. I already lost progress when the Compass quest glitched on me.

  • guest-C3l3c9eE
    1 posts

    Glitch in liconscire no one will come and help me.force open last chest

  • frauenarzt007
    1 posts

    After finishing Asgard questline KI in England is not noticing me at all

  • BarrfindV
    2 posts
    This post is deleted!
  • Cipher894
    1 posts

    I can't complete "Green Children of Anglia" event, can't interact with the stool to finish it. Problem with Randvi romance, i chose the "Now is not the time" and the option to start it disapeared, 87% completed game. And i preffer not to restart it. Any help?

  • BarrfindV
    2 posts

    What the heck. I was playing and running with my Scimitar and then game crush. I enter back and he vanish, he don't exist and my wolf. Store showing that I don't own anything that I have buy there. What you want me to buy my stuff again? I must admit this is really great idea for taking money from players but I doubt that anyone will be happy about that. I`m like furious right now.

  • guest-gVpsPIF
    2 posts
    This post is deleted!
  • indiscordium
    1 posts

    @meljanehayes I was having the same problem with Tedmund. Eventually I just shot him out of frustration and the prompt to tie him up miraculously appeared 😂

  • reddevilrody666
    3 posts

    When you play Orlog and select the dices you want, some of the dices can't be returned to your hand. If you select the dice you selected to play with, the dice just dissapeares. I am playing on Xbox One S. AC Valhalla Disk Edition.

  • Zemog-10
    2 posts

    Order members are not dropping the diamond shape runes like they're supposed to be doing, they now only drop lesser runes. I've killed 7 order members since the patch drop and none of them dropped the diamond runes.

  • Kbionbg
    1 posts

    Im having a couple of bugs with the mysterys.

    The first is collecting the bear testicals for the elixir in Ledecestrescire. I go the the cave (even checked on walkthroughs I'm at the right one) but there are no bears. And no other bears I've found have had them

    Second is in Lunden. The guy in the Wearhouse with the jars that make you vomit. There is no one in there for me to help.

    My partner has been able to complete both on her game but they never appeared for me

    I have tried re loading the game as well as waiting for a few updates. Not breaking the main story but I am trying to 100% each area and they are the only things stopping me in those two areas.

    I'm playing on PC



  • carnina2011
    1 posts

    In est anglia, i miss 2 riches cause one is bugged after the patch. Resolve quickly i can't do the 100% . Another player have my problem.

  • ElishevaLight
    1 posts

    For The Twit Saga II mystery, after I freed the conscious brother and killed the bandits, I set the unconscious brother on my horse to move him. Parts of his dialogue played out but the conscious brother is following me instead of guiding me and I have no idea where I'm supposed to go. Any time I pick up the fallen brother the awake one stops moving entirely, and when I set him down, the other rushes to his side and just stands there.

  • plasticoreo
    1 posts

    ESSEXE WORLD EVENT BUG (The Gleewoman)

    Upon first encounter everything works fine. The woman followed me a bit and I paid her to leave me alone. I didn't pay the full price the first time so the the world event didn't finish (marker didn't disappear). The second time I pass through the ruin I found her still there. She then starts to follow me again. Although this time she does not give me the option to pay her... She just follows me endlessly no matter what I do so I fast traveled to a new location to get rid of her. I tried reloading saves yet she still doesn't let me pay her so I just pressed on with the game and left her there. But by the time I decided to go back and finish the world event the woman was no where to be found! I tried to spot her with oden's vision and my crow with no avail. Now I'm stuck with a bugged world event that is going to keep me from completing the game, please help.

  • itom213
    6 posts

    I can't edit my original post.
    Twit Saga Part1 fixed for me after 1.04 patch. (PS4)

  • ColDon70
    1 posts

    I died on the game and now every time I load my character back in I’m falling under the map???? I don’t understand how I’m stuck falling? It needs to be fixed can someone help me? I’m 16 hours in and will have to restart! I’m currently playing on Xbox

Suggested topics

Community details

7
Online
123.9k
Users
21.3k
Topics
109.8k
Posts