Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Caosblowupzero
    1 posts

    I have an Xbox and I have the exact same problem is there a workaround or any way to glitch the story back on track help please this is urgent!!!!

  • Masquerade_Fuse
    3 posts

    @ubikobold

    Hello. Thanks for replaying and trying to solve this issue. I would like to inform the PS4 players have a same problem. Not all of the players stucked where they have to talk Randvi. Conditions are different for different players. For instance [SPOILER ALERT] I finished “Burning the Firebrand” quest and switch off the game. The next day when i start to play I saw the quest still active and I can not interact with objectives/NPC, but the Ancient Order member in that quest is dead (have to be dead at the end of this story).

    Just make sure, the Jorvik main quest is bugged. It could be glitched in any quest of the main story arc.

  • UbiKobold
    Ubisoft Support Staff 531 posts

    Hello there. Thank you all for your continued updates, and I am sorry to see that this has been affecting all platforms! The Game team has been notified and is currently investigating this issue. If you are playing on PC or PS4, could you please create a ticket and submit your save files? After that, return here with your ticket number and I will forward that information to the Game team. Thank you very much!

    Official Response
  • Cedro0910
    2 posts

    Bonjour a tous,

    Je vois que jai le mele soucis que tout le monde..
    Je suis bloqué au debut de la mission, la carte des alliances ou sa me dit parler a Randvi mais impossible de lui parler...
    Vu mon level impossible daller explorer dautre region, je vien de finir dexplorer les 3 plus petites region et la derniere etait est anglie..

    Le bug a til etait resolu ? Si oui merci de me dire comment, sinon quand est ce quil sera resolu ?

    Cordialement.

  • da_dragon_82
    1 posts

    I'm still having an issue. I can not talk to the NPC to complete Jorvik. I tried realizing saves and it didn't work. I just process with the game and now stuck. I return numerous times and still not able to talk to the NPC.

  • scramblingbalam
    2 posts

    @ubi-raziel I think it's a deeper issue than a single quest I was able to do all the areas except Jorvik, Eurvicshire, Hamtunscire, and Winchester (cic). Eurvicshire shows up as a white Bishop but the other locations don't even show up on the map. Weird stuff I did...I went on to Glostershire before Essex and Linconshire by fast traveled out of the boss fight in Glostershire with Mordon. But I had no problems until I tried to pledge to Eurvicshire, then it just doesn't work. Is Jorvik supposed to appear as a separate Bishop/Raven 🤔 cause mine never did.

    Hope you get this fixed soon!

  • scramblingbalam
    2 posts

    @ubikobold I'm playing on PC and tried to create a ticket but that link you gave just goes to the account/support landing page.

  • carolinewindle0
    2 posts

    I have almost 140 hours logged into this game, and over half of the map completely cleared of treasures and what not. I managed to finish “pricking the needle” but for the “Burning the firebrand” it tells me to infiltrate the Minster. I go there, and the leader of the Red Hand is just standing there in front of the bonfire with a blue dot above her head as if she is an ally. I have tried uninstalling and reinstalling the game, meditating, teleporting back to Randvi, gone back to a different save file NUMEROUS times, and lost several hours of pillaging time of all the items around Jorvik.
    I’ve googled the hell out of this issue and several people are having similar if not the same issues as I. The farthest back I’ve seen people complain about this is almost 75 days ago.
    Ive been playing AC since the very first one, and was very excited to see what Valhalla would bring to the table. I’m not going to be a happy camper if I can’t finish it due to a game breaking bug.

    Ticket number; 13960679

  • guest-RedQYwKj
    2 posts

    Hey, completed firebrand quest.
    Went to talk to the lady who would send me to the docks.
    She said go but no quest marker.
    I think this is because I killed the dude with the key before I was meant to?
    Here is the video:


    Hope this makes the patch coming out in Feb address the issue as I cannot progress the story and would rather not start over.
    Is there some way to access the previous autosaves on the cloud?

    Cheers,

  • guest-RedQYwKj
    2 posts

    @masquerade_fuse Can't complete the 'needle' quest because I think I already killed a character involved.

Suggested Topics

Community Details

28
Online
130.5k
Users
22.6k
Topics
117.3k
Posts