Welcome to discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Unable to progress with "Road to Hamartia" as Halfdan does not enter the room after the door is forced | POST HERE

    11 Likes/243 Replies/10958 Views
    2 posts

    This is very frustrating because I have already explored the place with Gunmar the blacksmith. The only quest I need to do to progress ubisoft fix the issue. It has been like two, three weeks and no fix or reply.

  • SomeDudesMom583
    15 posts


    Any updates? Just got an email that Ubisoft had closed my ticket on this issue. I reopened it immediately. Not sure wht they would close the ticket? Seems absurd. Cannot progress further as I am more than 100 hours in the game and only have this quest left. It's terrible that this is at a pinnacle too. Such a great game being crushed by this issue. Beginning to leave a bad taste in my mouth..... Please let us know if you have ANY info to update us with. Thanks!!!

  • spen123
    2 posts

    @somedudesmom583 me too. Crazy that this is still not resolved! Can’t do anything!

  • spen123
    2 posts

    @ubikobold WHY is this still not sorted?! You have likely hundreds of users unable to progress and completely stuck?!

  • ChewyWaffles
    9 posts

    Same thing here. Stuck on Series X - some dude in blue showed up out of nowhere when I had to force the door. It wasn't Halfdan. Now Halfdan stands still like an idiot and does nothing. Cannot progress.

  • Obi1kanobi1982
    8 posts

    I was able to pass it, but i had to start the game over. I followed the main story line without doing any side missions, until i was able to play that part, when i did. i went to the location. before i broke through the roof entrance Holfden walked around to the front entrance. then i broke through, dropped down, slid through the hole in the wall, dived down, swam under, and popped out, broke through the wall, Halfden then followed me to bust through the red door. i'm on pc. I finnished the main quest line. with no problems after that. in about 12 hours straight play

  • Spiviii
    2 posts

    Can't continue the story with Halfdan Jarl because I already opened the door inside the ruins were you need to force open door with Halfdan.
    Jarl just stays near door and don't move.

  • jayphenom75
    2 posts

    Same issue here! This is very frustrating since I have committed many hours to the game. Is it me or does this iteration seem to have more bugs than previous entries?

  • jayphenom75
    2 posts

    Same issue here! I opened the door prior to Road to Hamartia through random exploration. When I did Force Open, Tarben the Baker helped to open the door. I was never able to complete The Baker's Plaint quest because I could not get into a boat for some reason; now Tarben randomly shows up and follows me around. This is very frustrating since I have committed many hours to the game. Is it me or does this iteration seem to have more bugs than previous entries?

  • Pjaworow
    6 posts

    I’m having the same issue the baker has been following me and ended up opening the “force door open” now Halfdan won’t enter the room and I’m stuck

  • ChewyWaffles
    9 posts

    @obi1kanobi1982 That's great but there's no way I'm starting over. Took me about 30-40 hours to get to that point.

  • Coolspikes1
    1 posts

    lmao brand new update and this wasn't even considered for a fix. Why is there no update on this? There is several hundred people with this issue and zero updates. Oh and it's been more than a month now.

  • FE4R_Phoenix
    2 posts

    @coolspikes1 Yeah Exactly nothing has changed.

  • Spiviii
    2 posts

    Cant continue the story any longer because Halfdan is staying still and not coming in the mission "Road to Hamartia"
    I visited the guest area before and Tarben was following me for the baker guest and he forced the door open and now Halfdan dont know what to do with the already opened door.
    I recorded clip of Halfdan being stuck and seeing the "Force open" option while door was opened.

  • JBQ.
    Original poster 16 posts

    Really disappointing, issue reported month ago and still not fixed.
    It should be prioritized as we are unable to progress with MAIN story. It's like we paid for unfinished product and it's not alpha or beta version...

  • ChewyWaffles
    9 posts

    @jbq Yep - was hoping the fix for this was in this update. It's the only main quest/territory I have left!

  • r0gu3ptm
    50 posts

    @chewywaffles Same here, i cant get past this quest.... its so annoying

  • Antokyo_yt
    2 posts

    What a build up, the update didn't even fix the bug. The bug has been out for a month or so. I could've finished this game two weeks ago. I have completed everything on the map such as wealth,raids,artifacts,mysteries, etc. I'm really disappointed that I have spent $100 for this game yet the game ain't even properly finished with too many bugs.

  • guest-9K1ITt0O
    5 posts

    I'm also experiencing the same issue on PS5. I've spent just over 60 hours playing the game and can't progress any further without the fix. As others have said it's a main game braker issue - none of us are able to complete without the patch.

    I had a random female turn up (I think her name is Petra) to help me open the door. I'm not sure if it's linked but I tried (and failed) to complete the "Have You Seen This Man" side quest however experienced a glitch there on the "Discover what happened to Wallace" part - I kept experiencing glitches and was unable to complete the mission. It didn't bother me too much as I saw it as just a side quest.

    However the Halfdan bug in Road to Hamartia is a show stopper and really dissapointing.,

    Will we ever get a fix for this and if so how long will we have to wait?

    Has anyone found a way to overcome it? I've tried shooting the fire vases in lots of different locations but haven't managed to find a way to free Halfdan from standing outsdie in the central courtyard with the ladder...

    Really appreciate any help anyone can provide!

  • r0gu3ptm
    50 posts

    I spend 100 pounds on this game thinking its going to be the best AC ever, but this is ridiculous... it has been reported oevr a month ago and still no fix... i know how testing works because i used to work for Gameloft, the sister company of Ubisoft; ths is really sloppy for the testing teams... apparently the walkthrough tests have not been performed properly...

Suggested Topics

Community Details