Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
    6 posts

    @smithy10gb I think so!
    I really Hope this will be resolved asap, I've stop playing since Saturday because of it.

    I have also the same issue with Bjorn, I managed to put him in my crewship but not hired him as a Jomsviking

  • Ubi-Borealis
    Ubisoft Support Staff 2077 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • KapitanAhab
    2 posts

    I'm playing on PC; my settlement is level 3; I have a shop, tattoo studio, blacksmith's, hunter's hut, assassin's office, stables, cartographers and seer's hut. Currently I cannot use any of those - there is no icon allowing to enter into interaction with NPCs in those stores.

    The issue started during the notorious Seer quest (which I am still unable to complete). Only after the issue occured I built the cartographer's hut (in the hope that it will somehowe resolve the issue, it did not).

    Before the issue occured I concentrated on exploration and side quests (I completed quite a lot of those). At the time I did not upgrade any of the buildings.

    I stopped playing the game because of this bug.

  • smithy10GB
    Original poster 70 posts

    @kapitanahab out of curiosity, did this happen after your settlement was raided or before?
    I only ask because a lot of us have had this happen after our settlement was raided.

  • BossBigBang
    4 posts

    Anyone have any updates or positive results on this issue?

  • smithy10GB
    Original poster 70 posts

    @bossbigbang at the moment I think the dev team is looking into the issue but it's one of those where we don't have clear info yet. If you @ UbiWoofer in this thread with all the info he asked for above I'm sure it would help speed things along 🙂

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    Thank you so much for your prompt replies, and for answering my questions as best you could. I've now submitted a formal bug report to the devs with the details provided, as well as linking them to this thread and the video provided by claud1o-. Hopefully the information given so far will make it easier for them to reproduce the issue and identify the root cause.

    If anyone has submitted save files via their support case, please quote the case reference number here in this thread so that I know to check those and can grab those files and add them to the report as well. Thank you to anyone who has taken the time to do so already, I realise it's time consuming to prepare those and upload them, but it is a massive help to the devs to have those available for testing and it is very much appreciated.

    As soon as I hear anything back from the devs, I will of course write here again. It looks as if we've had a few cases come in through our ticketing system for the same issue, so it may already be something they've been looking into, but I can't be sure!

    I'll reply to a few individual posts below, as there were some specific questions / points for me to address:

    @claud1o If you're referring to the issue with "Taken for Granted", I've reported that earlier today as well after gathering information, so please refer to the megathread for that issue for the latest updates.

    @MnrGod Regarding Reda becoming adult-sized, did you happen to capture a screenshot or video clip of this? I've seen it reported that this also happens in one of the world events where a child NPC is present, so I'd like to add any resources you may have to that investigation!

    @smithy10GB I was unaware that I am famous! I hope if I am, it is for the right reasons, haha. I believe you may be mistaken regarding it being myself helping CohhCarnage as well, as I don't believe I've had the pleasure of interacting with him before.

    @BossBigBang I'll reply again as soon as I have any news to share, promise!

    Official Response
  • smithy10GB
    Original poster 70 posts

    @ubi-woofer oh haha I swear I have seen your name mentioned on his streams but I guess not, either way you are being increadably helpful.

    Thank you!

    6 posts


    Hi, first of all, thank's for your efficiency. I've contacted the support for this issue last Saturday. The case number they give is the 13258320, I have uploaded pictures to show up the bubbles are no longer above npcs to interact with them

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    @smithy10GB Maybe I have and I just don't know it! If you ever catch my name in a stream again, you'll have to let me know!

    @D-L-DONKEYSHOT Thank you! I've uploaded the images you provided to the report as well for the devs to refer to now.

    Official Response
  • smithy10GB
    Original poster 70 posts

    @ubi-woofer awesome will do, just a heads up it's the same for me as in the clip another poster gave you, except for me I'm missing functionality on the -

    And there was another but I can't remember.

    Just out of curiosity Woofer, do you happen to know if this issue is fixable in a patch because I really don't want to lose 55 hours of progress.

    I understand there may be some way for the dev team to reset the npc's but as for fixing the bug I hope it can simply be patched, at the moment I'm hesitant on playing because I don't feel good about spending more time gathering and doing side quests if I will have to restart.

    Thank you.

  • claud1o-
    50 posts

    @ubi-woofer Thank you again for taking care of this, really appreciated.

    I opened a support case on Nov 14 and the case number is 13256732 - I have just uploaded my savegame where you can find:

    • settlement bug
    • Randvi romance quest bugged (I chose "not the right time" and the Q does not show as completed & I am unable to interact with her apart from the alliance map

    I hope to hear good news soon!

    Best regards

    @smithy10gb Same here. I stopped playing but in case patching will not solve existing saves I am not sure I will go on playing (sadly)

  • claud1o-
    50 posts
    This post is deleted!
  • StefanoM13
    1 posts

    Hi, i’m playing on PS4, my settlement is level 2 actually I can talk with all the NPC but I can’t give them all the stuff like the medallions and Pages of the code to Hytam, and even the roman relics to Ottaviano.
    Hope that ubisoft can fix it asap

  • evilapplemoose
    8 posts


    For me the issue seem to have started when I reached level 4 of my settlement.
    I went back to an old save from when I still had level 3, and I was able to speak to the Barracks NPC.

    Another problem occurred during this test though; I tried to go back to my level 4 save, but instead it loaded the level 3 save again and my level 4 save was gone.
    I am 100% sure I loaded the correct saved file, and didn’t overwrite it. The person next to me saw it happen.
    I closed the game, restarted and loaded another file from a few hours ago. Luckily that worked, but I did lose about 3-4 hours of gameplay.

  • XBalls3Nuggets
    4 posts

    Same issue here, RightNow it's only effecting the shipyard and barracks. Do we just post here to gripe, or does someone help us?

    Xbox One

  • smithy10GB
    Original poster 70 posts

    @xballs3nuggets UbiWoofer has been a great help, he is making sure the dev team get all the info so if you have anything to add that might help make sure to @ UbiWoofer without the space 🙂

  • Ubi-Spud
    Ubisoft Support Staff 675 posts
    This post is deleted!
    Official Response
  • subilaci
    3 posts


    Hi my friend!

    Here is an other video.

    I can't interact with Reda. I can't take the misson (Viking for Hire) and can't open the opal shop. Shop is the bigest problem...
    PS4 slim with 8.01 system, lvl 5 settlement.
    I can send a game save if u need it.

  • CosiestDragon19
    3 posts

    @maskoliar try loading the auto save file where you come to England

    6 posts

    @subilaci hey I assume I've heard about it
    Maybe you can try this : awhile Reda will tell a story, kids will listening to him, you only have to stand nearby (with the kids) until he finish and then you should be able to talk with him again.

    I hope this will help you!

Suggested Topics

Community Details