Welcome to discussions

Quick Suggestions

  • Bushwickedly
    109 posts

    @guest-wb2uqrcm Depending on how far along your settlement is, it might need more main quests before advancing. I got to the end of level 4 after upgrading everything possible, and ALL wooden boards were gone (should have boards locked from advancing vs. missing as it's confusing), despite the bird showing 2 locations that had the supplies requirement there (meaning they can be upgraded).

    After doing a main quest (pick one with the green longhouse icon as a reward) it upgraded to level 5, and wood boards reappeared for what I could upgrade now.

    This game you MUST manually save at LEAST every 15 minutes. I learned this back when early elder scrolls games were beyond broken when released and you are learning it now. Autosaves save rapid-fire every minute in some instances (making them worthless when it has 5 auto saves all in the last 6 minutes whereas at least one that's always 30 minutes old and one a few hours old would help people tremendously) but game overall has enough critical bugs that manual saves are mandatory unless you want to constantly restart a game that'll take over a 100+ hours. Game has quick save option but would use manual saving in sub menu instead. When it fills up with saves, scroll all the way down to manual save 1 and overwrite it, and next time overwrite no.2, etc.. Takes 30 seconds to do and minor inconvenience vs. restarting. Game tries to be witcher-like vs. earlier incarnations so not easy/fun starting over. Having that manual save to get by a bugged quest, npc, etc., or avoid it until patched, will make your life easier.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • Bushwickedly
    109 posts

    @bushwickedly Also, if you ALWAYS have a full list of saves logged i.e. 20 manual save files (or whatever each game allows) spanning at LEAST 5 hours back or further if possible, on large games like this, means you'll almost always have an "out" to either bypass an area or maybe get lucky and avoid a bug 2nd time around.👍

  • UnCaNnYaNdY
    4 posts
    This post is deleted!
  • UnCaNnYaNdY
    4 posts

    @guest-kjfkd3v0 im having similar issues, but its the ship lady the quartermaster chick and the stable boy that i am not able to interact with. Why Me? i love settlements and im over 80 hours in and decided at about 40- 50 that hours that i wasnt going back to my 18 hour save with hopes that ubisoft may fix it!

  • TKNaberius
    1 posts

    @archangel62513 I can't talk to half of my settlement, the hunters, the cartographer, the stableboy, the shipyard, or the barracks. I put in a help ticket and so far all I have gotten is basic troubleshooting steps that didn't work. I tried uninstalling and reinstalling the game and that didn't work either.

  • Shraman
    7 posts

    @heartpunches I agree, no one is responding to this, wich mean they still don't know what it is so my hopes are not very high. I'm so mad right now.

  • Rakkertje08
    15 posts
    • Addressed various issues with quests or world events that prevented players from completing them.

    Maybe this one.. but odds are not in our favour..

  • FireIce38
    28 posts

    Update 1.04 should drop any second now. When you guys get it, let us know if it has fixed your game.

    I'm not quite far enough to know if it has affected me or not.

  • Eung232
    5 posts

    No fixe for me, it amaze me how no one seems to care about this near game breaking bug

  • Shraman
    7 posts

    @eung232 The maj haven't fixed anything. Amazing, so now I have to wait for a new fix that will propably by in two weeks, and I don't want to continue the story because I'm afraid that I will be blocked in a near future. On top of that I can't change my tatoos/hair/boat/crew/mount/crow, that is to say, everything. I can just fish like a [censored]. AMAZING a fishing game that I paid 69€, thank you Ubisoft, I learned that your games are not worth the price, it will be useful in the future.

  • chriskean86
    11 posts

    Paid £85 for my version and I dont want to play it anymore because of this bug. Its a shame because the game is awesome outside if it. Just a shame its so big and ignored by Ubisoft

  • Eung232
    5 posts

    @shraman for real, i should have get this game in 6 month. It would have been cheaper for a more enjoyable experience

  • Shraman
    7 posts

    @eung232 That's exactly what I was thinking. It would have been way cheaper and the it would be complete. It looks like games are still in Alpha when they are release now because of deadlines. It pisses me off so much.

  • evilapplemoose
    8 posts

    @fireice38
    It did not fix this issue. Still the same problem.

  • ckcjbfb01
    3 posts

    Very disappointed that this wasn't fixed in the recent Update. I can't interact with the shipyard, barracks and staples wich is just frustrating. The staples and barracks used to work at least one time and thats it. I have tried everything, from reloading to fast travel to a different location, even going as far as reinstalling the game twice and just nothing happened. I'm more than 50 hours in and the fact that the game doesn't allow me to utilice core features is disappointing at least. I also have not seen a Single response by ubisoft itself considering this issue, even in it seems to not be rare at all. Was realy looking forward to the update...and was just disappointed.

    Playing on ps4

  • smithy10GB
    Original poster 70 posts

    @ckcjbfb01 yeah it's getting a bit much now, you would think out of all the known bugs ubi would prioritise the one that physically blocks gameplay...

  • elcarancho
    7 posts

    The problem still persist... It was not fixed... This is a big screw up...

  • Rakkertje08
    15 posts

    At least some other bugs are fixed... my torch has visual flames again and light/hevay attack stats are working.. but still can't interact with Petra and the mission 'the Huntress' is not starting (which should start after building the hunter hut). Whole side line quest with Petra is not possible, because she has not a 'text box option' above her (so i can't interact with her). At least other NPC are interactable, should be lucky if i'm reading through your comments..

  • HRHSuperCorgi
    2 posts

    Update still did not fix settlement issues. Like others, I cannot speak to the barracks, cartographer, ship yard, or the hunter to return legendary animals. Super disappointing.

  • FireIce38
    28 posts

    Does this issue not affect PS5 and Xbox Series X? I only ever see people bring up PS4 and Xbox One. Mostly PS4.

    If so, guess that would explain it. They only care about improving the next gen versions.

    They literally listed fixing the screen tearing on Xbox Series X|S, but not fixing it on Xbox One X|S.

Suggested Topics

Community Details

94
Online
192.9k
Users
32.5k
Topics
162.8k
Posts