Welcome to discussions

Quick Suggestions

  • LinnetBob
    2 posts

    Cannot interact with Olsen the Cartographer. Never have been able to since building his shop. I can interact with EVERYONE ELSE in the village, just not him. I'm on PS4. My settlement is very nearly at 6, although I built his shop ages ago. I've completed the main game and have kept going back to him, but no speech bubble appears.

  • BobbyFioretti
    11 posts


    I find it hard to believe that they're unable to reproduce the issue, and I also find it hard to believe that they're unaware of what makes NPC's function properly. Again, while we're not aware of what is causing the issue to happen, we are aware of what the malfunction is. If the developers are unaware of what makes NPC's function properly, they're not very competent at their job. We need a bandaid fix for this asap so people are able to go about playing the game while the devs root out the cause of the issue. To say that they need to know what causes it in order to fix it sounds like stalling.

    The community has been reporting the issue for almost 3 weeks at the very least. The community has answered all the questions, provided videos, and provided save files. The issue is that certain NPC's cannot be accessed by players. Priority number 1 would be to make them accessible. Very simple concept. What makes NPC's interactable? That's not working, so fix it.

  • Ubi-Woofer
    Ubisoft Support Staff 1268 posts

    Thank you for the additional reports, indians2023, SmallChik3nz, oscarurby and LinnetBob. I'll pass these additional details on 🙂

    @claud1o I apologise if my colleague requesting a video has caused you any discomfort or frustrated you further. Having reviewed the contents of your case as they were prior, it doesn't appear that a link to this thread had been provided, so they have requested this not knowing you had already done so here in this thread. Rest assured as ever that we're doing what we can to get this looked into.

    @BobbyFioretti I appreciate you are frustrated however I have given you the full information available to me at the moment. As stated previously, this isn't an issue the developers came across in their playthrough and it has not been able to be reproduced as yet since. If anything should change I will let you know. I would appreciate it if you could mind your tone as well. 🙂

    Official Response
  • TommyPage1
    1 posts


    Lost the ability to talk to settlers in Ravensthorpe. Can't speak to the following;

    Raid Master in Barracks
    Fish Merchant

    No button prompts appear above the head. I have the PS4 ultimate edition including the berserker & beowulf dlc quests and am running the latest version (currently 1.04).

    Please fix as soon as possible all the fish in my bag are starting to smell.

  • HeathenShip6935
    8 posts

    I built the cartographer hut this morning...and immediately found i could not purchase anything shown - the only action possible is to go to B to exit.

    Same as Reda - no purchases possible 8(

  • kjsulli
    1 posts

    I have the same issue on PC. can only talk to Gunnar and i need to talk to redvi to progress the story. this is game breaking and i am very disappointed as i just bought the ultimate edition game and cant even play past the introduction to england.

  • claud1o-
    50 posts
    I apologise if my colleague requesting a video has caused you any discomfort or frustrated you further. Having reviewed the contents of your case as they were prior, it doesn't appear that a link to this thread had been provided, so they have requested this not knowing you had already done so here in this thread. Rest assured as ever that we're doing what we can to get this looked into.

    Can you blame me?
    I can not play the game (as intended) since 20 days today. On top of this settlement bug I have issues also with quests, which caused me stopping playing hoping for a quick patch.

    And yesterday, after I submitted the link to the video, they answered me "if you have not completed our troubleshooting steps, please check them as this may resolve the issue"

    Come on, this is ridiculous.

  • SlimStorm786629
    1 posts

    I built the shipyard in my settlement but I can’t access the shop or change anything.

  • kodare97
    10 posts

    I am playing on Xbox One and have racked up just over 100 hours play time. I haven't been able to interact with the majority of NPCs in my settlement since around 20/30 hours in. I have tried every suggested fix and none have worked. Some NPCs I have previously been able to interact with such as the barracks and the shipyard and others I have never been able to interact with such as the cartographer and the hunters hut. I have tried adding new builiding with the hopes that those NPCs would be unaffected but I cannot interact with them either. I have contacted ubisoft support several times providing details and videos but my support cases have been closed despite the problem not being fixed. I can only interact with the blacksmith, the tattoo artist, the trader, reda and hytham. I have built every possible buidling in the settlement and other than the aforementioned NPCs I cannot interact with any other NPCs as they do not display the speech bubble above them. I was really hoping for a fix with the previous title update (1.0.4) but obviously that was not the case. I understand the issue is difficult to pinpoint and implement a fix for, however having contacted ubisoft support numerous times only for my case to be closed is somewhat irritatingly. Really hoping that a patch is released soon to address the issue but at this point I'm losing hope that the issue will ever be addressed, which is a shame as apart from this bug I have really been enjoying the game.

  • michaud354
    1 posts

    I know that somebody already wrote about it, but they never received any answer, so here i am. Since a couple a days, i'm unable to interact with a lot of my settlement NPC's. Latest patch, loading an old saving or desintalling et reinstalling the game didn't change anything. To be honest, i don't think i'll be playing the game until this bug is fixed.

  • Flash62000
    2 posts

    Same issue on PS4

  • LinnetBob
    2 posts

    @heathenship6935 I can't even speak to the cartographer. There is no speech bubble above him. Sometimes I knock him off his chair for fun and he stands there and points at me, but I'd rather buy maps from him!!!!!

  • Sonnyjlopez
    1 posts

    Hello Ubisoft,
    In approaching your franchise and sticking with it through oddities and glitchy games. This one is super annoying. In the midst of a general slow year in gaming this one seemed awesome. I feel like this was rushed to market to capitalize on that fact. From the COVID reference on the laptop to the unfinished and clearly broken Ravensthorpe settlement. It looks like most people are gaveling the same issue. It clearly seems to be related to the attack on ravenstorpe and possibly the way of the berserker dlc. You tout and sell the fact that you can customize your own ship. That is a feature many have not seen. You give the opportunity to Recruit  others’ Jomvikingr. Pay all you want you will never see them. Just the lonesome berserker can be seen wander the docks sometimes. I have a Fishery I never used, thanks for the fishing line I guess I can feed some kids who trick me with it. I have a tanner that only got to mount one of my trophies. The rest of the time, I can only swing by to bang his daughter. My cartographer set up, but and must not have ink or a voice be cause I can’t speak to him nor have I seen a map. 

    I feel like it is an audacious move to ship a product that is in finished. I bought a pre-order, I was unaware I was to pay for the right to be a game tester for you. I have been playing this franchise since the beginning and even feel fondly about the Prince of Persia predecessor. Paying for the right for you to dump junk on me and have me test it sours that. I really am annoyed by the clunkyness of the game and the fact that you shipped an unfinished, broken grind fest. 

    Even looking at the patch notes shows the widespread incompetence. NPCs who don’t react to arrow death, or hits land on NPCs, stamina charges. With holes like arrows count as heavy damage being fixed. It is clear this was an incomplete project. Or just the things that you changed that you hit like the change in the skill nodes where the start part where it informs you changed.

    Even here in this forum you are asking us to get to where it happened and see how it bugs out. On top there has been a clear and blatant radio silence from your side on this and many issues. 

    I guess that must sound crazy, I understand. I just wanted to let it out, because Ubisoft, this is the final goodbye. 
    I am done as one of your costumers. 

    Sonny Lopez

  • morphus83
    3 posts

    I have the same issue, boat yard, fisherman, barracks, hunters Lodge, no dialogue option to interact with npcs

  • PapaBellerose
    2 posts

    I have the same problems with my settlement...

    I have been following this issue since November 16, 2020 and still nothing done about it.

    Can we have any Update about when should we be expecting the patch ? I don’t want to play until the issues are dealt with.


  • aldaei90
    3 posts

    Guys, what I’m about to say might sound stupid, I really believe that if this issue got out to social media and “”game journalists”” there picked it up it’ll be resolved way faster! I feel the ubi devs are too comfortable now with how well the game was received and sold and they wouldn’t want this to affect them . in summary, I feel like if a month passes since the issue started we should organize in social media and be a louder voice ubi devs will here ....the community managers here can only do so much !

  • Hambone2021
    6 posts

    I was able to get out of this broken state on Xbox One, where eventually I was unable to talk to any NPC's in Raventhorpe, no Barracks, no Shipbuilder, no Hytham, etc. None of them would present the interaction bubble.

    To 'fix' it, I started trying to complete any open quests in the village.

    1. I had never visited my room in the long hall and spoken with Sigurd, so I did that. Then I went and built the Seer's Hut and Cartographer based on instructions from that a note from Randvi in my room there said to do.

    2. There was an outdoor interaction near the stables where Sigurd talked about leaving to talk to another clan etc. I went through that interaction but did not leave the village.

    3. Valka was glitched and when walking from the dock would always stop at the top of the hill. Randvi was supposed to be there but was not. So I force quit the game on Xbox One, and restarted where you see the full menus etc. When I resumed, Valka was again at the dock with the box to carry and the dialogue was correct when walking up the hill with her, this time Randvi was there to greet us.

    4. I then followed Valka, put down the box and was presented with the quest to get her potion ingredients. I gave her the ingredients to make the potion she talks about to put you deeper into your dreams.

    5. I drank that potion and went to Asgard. I opened a few chests there but did no side quests, but then went to the main hall area for the primary active quest in Asgard. I chose Thor and closed the Bifrost gate. After talking to Loki and the builder, I went to the door to Leave Asgard.

    When I got back to Raventhorpe from the Asgard dream state, all of the town NPC vendors are now active.

    I don't know for sure what combination of the above fixed the issue. My belief is that it was fixed somewhere between the steps 3-5. At any rate it's now fixed so I wanted to pass this along.

    Hope it helps someone else!

  • aldaei90
    3 posts

    @hambone2021 how far into the game are you ? Sigurd is still not in the settlment for me !

  • smithy10GB
    Original poster 70 posts

    @ubi-woofer I don't understand how much more I can help, literally everyone on this thread is having the same issue, there is no more info than what was provided already.

    I wish I could give more info but everyone here has already covered everything applicable, not to mention save files and clips have been provided already by the other guys on the forum, I just wish I knew it would drag out this long because now I can't even get a refund because I'm outside the 2 weeks.

    It just feels like by the time this bug gets fixed the game will lose value, I would have payed £59.99 for a game I probably won't play until goes on sale because it just seems like that is how long it will take to get fixed.

    I'm pretty sure this bug was actually first mentioned 2 updates ago and we still have no progress, I just really want to play the game I paid for.

    It's even more annoying because all of this time we have been missing the daily/ weekly items in the merchants, items I have no idea if or when they will be back.

  • Mai.Mai1
    2 posts

    I'm having the same issue everyone else is. After completely the berserker quest, almost all my npc's on my settlement won't speak to me for anything and the only ones that talk to me are petra who keeps bugging me about being her girlfriend, tove in the tattoo shop, yanli in the merchant and Tarben the bread maker. This is extremely upsetting to be almost 100 hours into this game and have never been able to access the shipyard, cartographer or barracks. This is overwhelmingly dissappointing and absolutely no one anywhere outside this forum is talking about it. Also, i've fully upgraded all my buildings but 1 and Randvi's journal still says I have a lot to do. I'm upset😭

Suggested Topics