Welcome to discussions

Quick Suggestions

  • kodare97
    10 posts

    I am playing on Xbox One and have racked up just over 100 hours play time. I haven't been able to interact with the majority of NPCs in my settlement since around 20/30 hours in. I have tried every suggested fix and none have worked. Some NPCs I have previously been able to interact with such as the barracks and the shipyard and others I have never been able to interact with such as the cartographer and the hunters hut. I have tried adding new builiding with the hopes that those NPCs would be unaffected but I cannot interact with them either. I have contacted ubisoft support several times providing details and videos but my support cases have been closed despite the problem not being fixed. I can only interact with the blacksmith, the tattoo artist, the trader, reda and hytham. I have built every possible buidling in the settlement and other than the aforementioned NPCs I cannot interact with any other NPCs as they do not display the speech bubble above them. I was really hoping for a fix with the previous title update (1.0.4) but obviously that was not the case. I understand the issue is difficult to pinpoint and implement a fix for, however having contacted ubisoft support numerous times only for my case to be closed is somewhat irritatingly. Really hoping that a patch is released soon to address the issue but at this point I'm losing hope that the issue will ever be addressed, which is a shame as apart from this bug I have really been enjoying the game.

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • michaud354
    1 posts

    I know that somebody already wrote about it, but they never received any answer, so here i am. Since a couple a days, i'm unable to interact with a lot of my settlement NPC's. Latest patch, loading an old saving or desintalling et reinstalling the game didn't change anything. To be honest, i don't think i'll be playing the game until this bug is fixed.

  • Flash62000
    2 posts

    Same issue on PS4

  • LinnetBob
    2 posts

    @heathenship6935 I can't even speak to the cartographer. There is no speech bubble above him. Sometimes I knock him off his chair for fun and he stands there and points at me, but I'd rather buy maps from him!!!!!

  • Sonnyjlopez
    1 posts

    Hello Ubisoft,
    In approaching your franchise and sticking with it through oddities and glitchy games. This one is super annoying. In the midst of a general slow year in gaming this one seemed awesome. I feel like this was rushed to market to capitalize on that fact. From the COVID reference on the laptop to the unfinished and clearly broken Ravensthorpe settlement. It looks like most people are gaveling the same issue. It clearly seems to be related to the attack on ravenstorpe and possibly the way of the berserker dlc. You tout and sell the fact that you can customize your own ship. That is a feature many have not seen. You give the opportunity to Recruit  others’ Jomvikingr. Pay all you want you will never see them. Just the lonesome berserker can be seen wander the docks sometimes. I have a Fishery I never used, thanks for the fishing line I guess I can feed some kids who trick me with it. I have a tanner that only got to mount one of my trophies. The rest of the time, I can only swing by to bang his daughter. My cartographer set up, but and must not have ink or a voice be cause I can’t speak to him nor have I seen a map. 

    I feel like it is an audacious move to ship a product that is in finished. I bought a pre-order, I was unaware I was to pay for the right to be a game tester for you. I have been playing this franchise since the beginning and even feel fondly about the Prince of Persia predecessor. Paying for the right for you to dump junk on me and have me test it sours that. I really am annoyed by the clunkyness of the game and the fact that you shipped an unfinished, broken grind fest. 

    Even looking at the patch notes shows the widespread incompetence. NPCs who don’t react to arrow death, or hits land on NPCs, stamina charges. With holes like arrows count as heavy damage being fixed. It is clear this was an incomplete project. Or just the things that you changed that you hit like the change in the skill nodes where the start part where it informs you changed.

    Even here in this forum you are asking us to get to where it happened and see how it bugs out. On top there has been a clear and blatant radio silence from your side on this and many issues. 

    I guess that must sound crazy, I understand. I just wanted to let it out, because Ubisoft, this is the final goodbye. 
    I am done as one of your costumers. 

    Best,
    Sonny Lopez

  • morphus83
    3 posts

    I have the same issue, boat yard, fisherman, barracks, hunters Lodge, no dialogue option to interact with npcs

  • PapaBellerose
    2 posts

    I have the same problems with my settlement...

    I have been following this issue since November 16, 2020 and still nothing done about it.

    Can we have any Update about when should we be expecting the patch ? I don’t want to play until the issues are dealt with.

    Phil

  • aldaei90
    3 posts

    Guys, what I’m about to say might sound stupid, I really believe that if this issue got out to social media and “”game journalists”” there picked it up it’ll be resolved way faster! I feel the ubi devs are too comfortable now with how well the game was received and sold and they wouldn’t want this to affect them . in summary, I feel like if a month passes since the issue started we should organize in social media and be a louder voice ubi devs will here ....the community managers here can only do so much !

  • Hambone2021
    6 posts

    I was able to get out of this broken state on Xbox One, where eventually I was unable to talk to any NPC's in Raventhorpe, no Barracks, no Shipbuilder, no Hytham, etc. None of them would present the interaction bubble.

    To 'fix' it, I started trying to complete any open quests in the village.

    1. I had never visited my room in the long hall and spoken with Sigurd, so I did that. Then I went and built the Seer's Hut and Cartographer based on instructions from that a note from Randvi in my room there said to do.

    2. There was an outdoor interaction near the stables where Sigurd talked about leaving to talk to another clan etc. I went through that interaction but did not leave the village.

    3. Valka was glitched and when walking from the dock would always stop at the top of the hill. Randvi was supposed to be there but was not. So I force quit the game on Xbox One, and restarted where you see the full menus etc. When I resumed, Valka was again at the dock with the box to carry and the dialogue was correct when walking up the hill with her, this time Randvi was there to greet us.

    4. I then followed Valka, put down the box and was presented with the quest to get her potion ingredients. I gave her the ingredients to make the potion she talks about to put you deeper into your dreams.

    5. I drank that potion and went to Asgard. I opened a few chests there but did no side quests, but then went to the main hall area for the primary active quest in Asgard. I chose Thor and closed the Bifrost gate. After talking to Loki and the builder, I went to the door to Leave Asgard.

    When I got back to Raventhorpe from the Asgard dream state, all of the town NPC vendors are now active.

    I don't know for sure what combination of the above fixed the issue. My belief is that it was fixed somewhere between the steps 3-5. At any rate it's now fixed so I wanted to pass this along.

    Hope it helps someone else!

  • aldaei90
    3 posts

    @hambone2021 how far into the game are you ? Sigurd is still not in the settlment for me !

  • smithy10GB
    Original poster 70 posts

    @ubi-woofer I don't understand how much more I can help, literally everyone on this thread is having the same issue, there is no more info than what was provided already.

    I wish I could give more info but everyone here has already covered everything applicable, not to mention save files and clips have been provided already by the other guys on the forum, I just wish I knew it would drag out this long because now I can't even get a refund because I'm outside the 2 weeks.

    It just feels like by the time this bug gets fixed the game will lose value, I would have payed £59.99 for a game I probably won't play until goes on sale because it just seems like that is how long it will take to get fixed.

    I'm pretty sure this bug was actually first mentioned 2 updates ago and we still have no progress, I just really want to play the game I paid for.

    It's even more annoying because all of this time we have been missing the daily/ weekly items in the merchants, items I have no idea if or when they will be back.

  • Mai.Mai1
    2 posts

    I'm having the same issue everyone else is. After completely the berserker quest, almost all my npc's on my settlement won't speak to me for anything and the only ones that talk to me are petra who keeps bugging me about being her girlfriend, tove in the tattoo shop, yanli in the merchant and Tarben the bread maker. This is extremely upsetting to be almost 100 hours into this game and have never been able to access the shipyard, cartographer or barracks. This is overwhelmingly dissappointing and absolutely no one anywhere outside this forum is talking about it. Also, i've fully upgraded all my buildings but 1 and Randvi's journal still says I have a lot to do. I'm upset😭

  • FireIce38
    27 posts

    @aldaei90
    I assume he would have to be talking about the first interaction with Sigurd in the longhouse when he shows you your room.

    Because he also mentioned a conversation with Sigurd by the stables about leaving camp.

    Both of these happen VERY early in the game. Like literally right after you set up Ravensthorpe.

  • Hambone2021
    6 posts

    Hi @aldaei90,
    I'm guessing I'm about ~20 hours in, but I've done a lot of random adventuring. I built Raventhorpe up to almost level 4 before I ever went into the longhouse to talk to Sigurd and continue the main quest. I think that step may have still have been part of the quest Settling Down. So potentially you would get to that conversation much earlier.

    I don't think that step alone changed anything, but I needed to do it to get the Valka step to work, which allowed me to get to Asgard, and when I came back from Asgard, all the vendors worked.

  • CITIZEN-225
    1 posts

    I have them built/unlocked, but I can no longer interact with the NPCs at the stable, fishing hut, shipyard, barracks and Reda. They acknowledge me when I approach, but the 3dot indicator to speak to them doesn’t appear and I’m not prompted to “press Y” to speak. I’m on xBox One.

    I have tried resetting my routers, etc.

    Anyone else have this and did they find a fix?!?

  • Y2john84
    48 posts

    This bug is clearly triggered upon completion of the berserker add on quest, I havnt been able to access barracks ever since appointing the berserker to my raider team, I still have halted progress in this as I will soon complete the main story without use of half my settlement, can a hotfix be sent to activate everyone's vendors, and you can investigate the root cause for a permanent fix whilst we can still atleast play the game? This game would be so awesome if it worked, please update when you can ubisoft

  • evilapplemoose
    8 posts

    @y2john84
    For me the problem started before the Berserker quest. I think it started right after the attack on Ravensthorpe.

  • ZigyZaga
    1 posts

    Same here. Patch 1.04 actually made things worse. I too cannot access any of the settlements NPCs after building their respected homes/business. So many clipping issues with npcs and any fabric swaying from Eivors armor. Textures don't load in on time nor the character models. Character path mapping is off track as well and is particularly annoying when combined with cutscenes where the NPCs just walk right through each other. Not to mention the constant crashes & framerate issues. Its a real shame, please fix this really narrowing experience that people payed good money for.

  • BobbyFioretti
    11 posts

    @y2john84 I haven't even completed the Berserker quest because I've seen so many people report even more issues after doing so. My list of inaccessible NPC's is different from most, so it seems that although the Berserker quest definitely affects the interaction on some NPC's, it's definitely not the cause of the issue altogether. I might make a save prior to doing the quest just to see what happens after completing it, but again, I'm afraid to even attempt it as I don't want to ruin my settlement experience altogether. Either way, there needs to be a fix.

    @Ubi-Woofer I believe my tone has been pretty respectable considering the situation and the lack of action by Ubisoft. Focusing on my "tone" instead of the issue at hand is another example of why so many people (not just me) are expressing their displeasure with this situation. Whether or not the devs came across this issue or are able to reproduce it is irrelevant to the fact that they need to implement a temporary fix as soon as possible so people can play their game semi-properly. Does the issue need to be pinpointed for them to temporarily insert a Barracks, Tattoo shop, and Shipyard into another town? This should be pretty standard anyway, don't you think? Stables (thank the gods) have multiple NPC's across many towns where you're able to customize your horse/wolf. Because of this fact, we aren't stuck with zero customization on our horses for 90% of the game. Even though I'm practically finished with the game 100%, and it seems pretty pointless now, I'd still like to customize my ship and the Jomsvikings that are in it, as well as customizing/upgrading my own Jomsviking. My personal Jomsviking was created at power level 80-ish. I'm power level 400+ and have almost every piece of gear possible. I think I could make him a little better by now? There are clearly many other CUSTOMERS who feel the same way. Give us something in the form of a bandaid fix. To ask every single person for a video seems outrageously counterproductive. How many times do they need to see different players walk up to an NPC that has no chat bubble or interaction option? One video seems pretty sufficient, wouldn't you say? Especially when you have 100+ other people saying "me too".

    I realize that putting certain NPC's into other towns, such as the Hunter, Fisher, Cartographer, and all of the feast-related NPC's, can be troublesome and is likely unrealistic. Yet, the customization NPC's (Shipyard, Tattoo, and Barracks) should be fairly easy and would give us back a little enjoyment that we feel we've been robbed of after paying for an unfinished and buggy game. After all, we are the ones who are essentially paying all of you. Throw us a bone here, and take a little heat off the fire.

    @hambone2021 I've finished all three Valka/Asgard missions and my NPC's are still inaccessible, so I'm unsure if this would be a fix/workaround. Valka also wasn't glitched for me when she first came to town. I just brought her and the box right to her area then built her hut. Glad it worked for you. Lucky guy!

  • BobbyFioretti
    11 posts
    This post is deleted!

Suggested Topics

Community Details

145
Online
190.9k
Users
31.8k
Topics
160.6k
Posts