Welcome to discussions

Quick Suggestions

  • FireIce38
    28 posts

    @aldaei90
    I assume he would have to be talking about the first interaction with Sigurd in the longhouse when he shows you your room.

    Because he also mentioned a conversation with Sigurd by the stables about leaving camp.

    Both of these happen VERY early in the game. Like literally right after you set up Ravensthorpe.

  • Hambone2021
    6 posts

    Hi @aldaei90,
    I'm guessing I'm about ~20 hours in, but I've done a lot of random adventuring. I built Raventhorpe up to almost level 4 before I ever went into the longhouse to talk to Sigurd and continue the main quest. I think that step may have still have been part of the quest Settling Down. So potentially you would get to that conversation much earlier.

    I don't think that step alone changed anything, but I needed to do it to get the Valka step to work, which allowed me to get to Asgard, and when I came back from Asgard, all the vendors worked.

  • CITIZEN-225
    1 posts

    I have them built/unlocked, but I can no longer interact with the NPCs at the stable, fishing hut, shipyard, barracks and Reda. They acknowledge me when I approach, but the 3dot indicator to speak to them doesn’t appear and I’m not prompted to “press Y” to speak. I’m on xBox One.

    I have tried resetting my routers, etc.

    Anyone else have this and did they find a fix?!?

  • Y2john84
    48 posts

    This bug is clearly triggered upon completion of the berserker add on quest, I havnt been able to access barracks ever since appointing the berserker to my raider team, I still have halted progress in this as I will soon complete the main story without use of half my settlement, can a hotfix be sent to activate everyone's vendors, and you can investigate the root cause for a permanent fix whilst we can still atleast play the game? This game would be so awesome if it worked, please update when you can ubisoft

  • evilapplemoose
    8 posts

    @y2john84
    For me the problem started before the Berserker quest. I think it started right after the attack on Ravensthorpe.

  • ZigyZaga
    1 posts

    Same here. Patch 1.04 actually made things worse. I too cannot access any of the settlements NPCs after building their respected homes/business. So many clipping issues with npcs and any fabric swaying from Eivors armor. Textures don't load in on time nor the character models. Character path mapping is off track as well and is particularly annoying when combined with cutscenes where the NPCs just walk right through each other. Not to mention the constant crashes & framerate issues. Its a real shame, please fix this really narrowing experience that people payed good money for.

  • BobbyFioretti
    11 posts

    @y2john84 I haven't even completed the Berserker quest because I've seen so many people report even more issues after doing so. My list of inaccessible NPC's is different from most, so it seems that although the Berserker quest definitely affects the interaction on some NPC's, it's definitely not the cause of the issue altogether. I might make a save prior to doing the quest just to see what happens after completing it, but again, I'm afraid to even attempt it as I don't want to ruin my settlement experience altogether. Either way, there needs to be a fix.

    @Ubi-Woofer I believe my tone has been pretty respectable considering the situation and the lack of action by Ubisoft. Focusing on my "tone" instead of the issue at hand is another example of why so many people (not just me) are expressing their displeasure with this situation. Whether or not the devs came across this issue or are able to reproduce it is irrelevant to the fact that they need to implement a temporary fix as soon as possible so people can play their game semi-properly. Does the issue need to be pinpointed for them to temporarily insert a Barracks, Tattoo shop, and Shipyard into another town? This should be pretty standard anyway, don't you think? Stables (thank the gods) have multiple NPC's across many towns where you're able to customize your horse/wolf. Because of this fact, we aren't stuck with zero customization on our horses for 90% of the game. Even though I'm practically finished with the game 100%, and it seems pretty pointless now, I'd still like to customize my ship and the Jomsvikings that are in it, as well as customizing/upgrading my own Jomsviking. My personal Jomsviking was created at power level 80-ish. I'm power level 400+ and have almost every piece of gear possible. I think I could make him a little better by now? There are clearly many other CUSTOMERS who feel the same way. Give us something in the form of a bandaid fix. To ask every single person for a video seems outrageously counterproductive. How many times do they need to see different players walk up to an NPC that has no chat bubble or interaction option? One video seems pretty sufficient, wouldn't you say? Especially when you have 100+ other people saying "me too".

    I realize that putting certain NPC's into other towns, such as the Hunter, Fisher, Cartographer, and all of the feast-related NPC's, can be troublesome and is likely unrealistic. Yet, the customization NPC's (Shipyard, Tattoo, and Barracks) should be fairly easy and would give us back a little enjoyment that we feel we've been robbed of after paying for an unfinished and buggy game. After all, we are the ones who are essentially paying all of you. Throw us a bone here, and take a little heat off the fire.

    @hambone2021 I've finished all three Valka/Asgard missions and my NPC's are still inaccessible, so I'm unsure if this would be a fix/workaround. Valka also wasn't glitched for me when she first came to town. I just brought her and the box right to her area then built her hut. Glad it worked for you. Lucky guy!

  • BobbyFioretti
    11 posts
    This post is deleted!
  • trickjc
    4 posts

    I can't interact with my shipwright, my cartographer, or my barracks NPC to change my jomsvikings. Has been like this since I completed way of the Berserker mission, right after my settlement was attacked by Rued

  • Gresteh
    3 posts

    Ok, as far as i can tell it only affected my blacksmith, and it began just after the invasion of the settlement, during the battle the blacksmith was outside but he didn't fight in the battle, he was doing weird movements, after the battle ended he was outside of his place and i was unable to interact with him... HOWEVER... i managed to find a workaround that fixed the issue:

    Just leave the animus, go back to Layla and then go back to the game, after that my blacksmith changed into a random NPC, moved to its posoition and then changed back to being the blacksmith... after that i could interact with him again. I tried many things before, like going to a previous save (i noticed shortly after that quest so i didn't lose much time), but i was unable to avoid it, every time my blacksmith was stuck outside its position and i was unable to interact with him, he was the only one affected.

    As i said, the fix is easy, just leave the animus and go back once again, that did the trick for me.

  • rdelp
    1 posts

    Having the same issue. The tatoo artist was fixed once i completed a side mission with them, but I have recruited fighters and can't talk to the Quartermaster to get them assigned to my boat.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    Hello there everyone!

    Thanks for reaching out with this. Our team is currently aware of issues with interacting with certain NPCs in Valhalla, and are looking into a solution. If you'd like to assist in this investigation, our team would greatly appreciate a copy of your game's save data! You can provide this to us by creating a new ticket with our dedicated support team, and attaching the files to your new case.

    We'll continue to update you as soon as we have more information to share.

    Official Response
  • kodare97
    10 posts
    This post is deleted!
  • Thoruos85
    1 posts

    @gresteh
    afraid that’s not solving anything for me, was still worth a shot though.

  • adamryanleal
    7 posts

    @gresteh This FULLY FIXED IT FOR ME!!! I'm incredibly thankful for this suggestion.

    I left the world and got out of the animus, walked around and interacted with a couple of things, then went back, and NOW I CAN TALK TO ALL MY SETTLERS AGAIN!

    You've helped me finish my 110-hour run.

    I would suggest everyone try this. It worked for me!

  • Gresteh
    3 posts

    @thoruos85 Sorry to heat that... i was right by the blacksmith when i left the animus, perhaps the trick is to be close to the stuck chracter? When i returned to the game the blacksmith had turned into a woman, walked to the blacksmith's position and just when she reached that point it turned back into the blacksmith.

    I left the animus, opened the computer, closed it, entered into the animus and then everything got fixed, but as i said i left the animus just by the stuck character.

  • adamryanleal
    7 posts
    This post is deleted!
  • adamryanleal
    7 posts

    UPDATE: The "fix" of leaving the animus and returning was temporary. I advanced my Hamtunscire arc end quest and then I could no longer talk to anyone else in the Settlement. I tried it again (leaving the animus and returning), and it worked for a single settler (the boat person), but then it stopped again.

    Now when I try to leave the animus and come back while standing right next to the person I need to speak to (Randvi, etc.), it no longer works. I was very excited. Now I'm sad again.

    UPDATE 2: I got it to work again, but only for Randvi. Advanced a quest, then I couldn't speak to the next person (Hytham). This is ridiculous.

  • Gresteh
    3 posts

    @adamryanleal my blacksmith is still working correctly, but i'm early in the game as my settlement is just level 3. I did it just it got bugged, but since i havent done the berserker quest i may still have problems in the future... and i havent finished any acrs since, i've just accepeted the one after the invasion.... perhaps if i finish an arc it will get bugged once again.

  • kodare97
    10 posts
    This post is deleted!

Suggested Topics

Community Details

157
Online
194.3k
Users
32.8k
Topics
164.2k
Posts