Welcome to discussions

Quick Suggestions

  • adamryanleal
    7 posts

    I would be very happy to provide a save file (on PS5, so not sure if possible), or any videos of this issue occurring (I have quite a few).

    I'm at the VERY end of the game, and this is driving me mad. I've gotten every single wealth, artifact, and mystery in all zones (except Jotunheim, which I can't start, as Valka is sitting on a horse and won't speak to me), and I'm WAY past Power Lvl 400 (45 mastery points past).

    I really loved my time in Valhalla, but this game-breaking bug right at the end is really spoiling my whole experience. The word that the Devs can't even replicate the issue is really uninspiring as well. I'll participate in any way I can to help resolve the issue!!! Let me know, please @Ubi-Woofer !

  • Hambone2021
    6 posts

    @bobbyfioretti Sorry to hear that but I will add a couple of things.

    In the course of the 5 steps I outlined, at a couple of points I did some manual saves and fully killed the game and reloaded immediately after the manual saves. That may have had some impact. Also, since someone else had success leaving the animus and coming back in, and one of my steps was leaving for asgard then coming back in, it's possible one of those actions somehow refresh the NPC access within the village. Possibly go to Asgard, perform a manual save in Asgard, force quit the game, then reload and see if anything changes when you finally leave Asgard and appear back in the village.

    I agree in general that it is crappy we are having to deal with this at all. Ubisoft should have enough reports and ability to gather data on this issue and have already extremely escalated this for resolution, especially given how long it has been going on and it's debilitating impact on the game.

    Just hoping that one of the above actions may help you in the meantime. Good luck!

  • Jenz_91
    1 posts

    @xballs3nuggets same thing with me, completed the game but still cannot talk to my NPCs in the settlement. It was after the berserker quest or when my settlement got attacked, cannot remember which. I was unable to talk to the barracks or shipyard. Then much further into the game (cannot recall when) I was unable to speak to the stables. I have completed the game now, thinking it would of sorted itself out by now 😞 I just want a pretty boat! Lol

  • Y2john84
    48 posts

    Can't you just create an option in the pause menu to "go to" settlement vendor on screen functions as a temporary fix so we can play the game please?

  • trickjc
    4 posts

    @ubiwan I'm not sure how to do that, but of you can guide me through it I would be happy to help by sending it over

  • kymbeee
    3 posts

    @bobbyfioretti Same for me, I never did the Berserker quest. I just hadn’t gotten around to it yet when the NPC problems started. I agree with your suggestion that they provide NPCs in other areas as a workaround for the ones we can’t access in the settlement. As I already stated, the ultimate edition was a complete waste of money. Ubisoft took my money, now they can provide the product they took my money for. Had I known I wouldn’t get the extras, I probably would have just bought the glitchy standard edition, waited and paid for the season pass, and said hell no to the berserker add on stuff that I haven’t been able to use (with the exception of the armor). Instead I was dumb and gave them all that money up front and never got the product I paid for. In all the years since the original AC, this is the first time I’ve succumbed and pre-ordered or purchased right at release. Shame on me I guess.

    I’ve just finished the main storyline in Jorvik, so I’m long past the point of doing random set up tasks in the settlement. Some of the settlement NPCs work for me (tattoo shop, museum, fish guy last time I checked) but the definite no’s are barracks, cartographer, shipyard, stables. The shipyard and cartographer never worked. The barracks and stables worked in the beginning but just stopped. I didn’t notice whether it was before or after the raid on the settlement, but it’s entirely plausible that it was after. I stopped playing several days ago, with the hopes they would fix this quickly and I could resume after the fix. Wishful thinking.

    To the customer support folks, thanks for reading. I know you’re just doing your jobs. I’ve been in your shoes, it sucks having to deal with us. Thanks for being the go-betweens.

  • Y2john84
    48 posts

    @adamryanleal can you let me know what you did please? I tried and it hasn't worked for me

  • adamryanleal
    7 posts

    @Y2john84 I just followed @Gresteh's steps. I left the animus, interacted with an item or two there, then came back. I was then able to speak to exactly one settlement person, then it "broke" again. Now I can no longer do this. I cannot speak to Hytham or Randvi, no matter how many times I try this "trick". I can interact with all of the items in the Settlement, like the feast bell, getting on horses, setting up decorations using the dragon heads, etc. I just cannot speak with anyone. The chat bubbles appear over their heads, but the speak prompt never shows up.

  • CrampedNebula61
    1 posts

    I have upgraded the shipbuilding yard in Ravenscroft. I cannot speak to the female character even though she is outside the hut planing some wood. When. Ipproach, she says hello but no dialogue bubble appears. As a result, I can’t upgrade my longship. The male character is missing. Can’t see him anywhere. I am beyond level 2 ( at 4) and have tried restarting and reverting to a previous save without any luck.

  • Y2john84
    48 posts

    @adamryanleal thankyou, I'll try again

  • BobbyFioretti
    11 posts


    It seems you're in the same exact situation that I am in, which is rare, because most others have finished the Berserker quest and aren't able to speak to the Tattoo shop, Hunter, Fisher, and Museum like we are. So, we know that the Berserker quest isn't the cause of the issue, but that it does add to the initial problem. It may or may not have started after the raid on Ravensthorpe, but I didn't notice it then. I noticed it when Reda suddenly stopped working, which is when I was able to turn in the "Viking For Hire" quest for my first 10 contracts from Thousand Eyes.

    Whatever causes the issue, we need a temporary solution so we can go about playing the game without missing out on 50% (or more) of the customization features. As I said before, I'm essentially finished with the game, I'm now just completing all territories and trophy hunting, but I'd still like to be able to speak with the settlement people. I'm not even sure if I've missed any side quests from some of the settlement NPCs, as the majority of them were immediately inaccessible. Luckily for me, I saved all the feast buildings for last, so I didn't miss any of the "important" ones. Still, though, this is poppycock.

    I'm still contemplating on whether or not I want to even attempt the Berserker quest to see how it impacts my settlement. I suppose I can make a manual save and load it if anything weird happens, but I've still got some Hunter and Fisher deliveries to do, and I don't want to lose access to them before I finish those. Bah

  • Timmy100802
    1 posts

    I have it right now because I am saving the ending of Asgard for when I get the Xbox series x and I hope that completing the last alliance or the wedding will fix it

  • taang
    1 posts


    yeah👌 or give us a reset settlement button, so we can craft the houses again every time it glitches😉

  • The_Grayest_Ben
    4 posts

    The "leaving the animus" trick didn't do anything for me, however my Valka did reactivate when I finished picking the plants for part 2 of the Asgard arc. The rest of my problematic NPCs are still ignoring me, but at least I'm (somehow) able to continue with "Going Deeper".

  • adamryanleal
    7 posts

    I'm stuck at "Give the plants to Valka" and she's sitting on a horse in the stables.

  • M4t7_the_Ninja
    3 posts

    The tattooist for me is just stood on the stool in her building and you can't talk to her or interect with her in any way

  • AciDropper
    2 posts

    Having the exact same issue since day 2 of release im 76 hrs in so I'm not gonna sacrifice all that progress tried uninstalling also got a ps5 and upgraded to ps5 version (transferred saves from ps4) and still cant talk to these npc's 😕

  • heartpunches
    13 posts

    @Ubi-Woofer @Ubi-Borealis

    any word on whether or not the devs have been able to reproduce this issue yet? or if they're considering adding another way to interact with the customization/crew elements of the shipyard and barracks the way we can use shops and stables outside of ravensthorpe? like others, i'm trying to figure out whether or not i can continue to invest time in this game.


  • stokekirk
    2 posts

    @smithy10gb try paying 80 quid for the same issue, I was so keen on getting this game I bought the, allegedly, all singing all dancing version. I have devotedly bought and played every AC game from Ezio collection onwards Ubisoft, but do feel extremely let down by the absolutely unfinished state of this game. Oh, and if you didn't guess, I cant interact with barracks fisherman hunter stables or cartographer either! Its blatantly a game that's been rushed out way too soon and I can't lose going on 100 hours gameplay. I fear you've shot yourselves in the foot with this one as never again will I pay full price for an Ubisoft game. I'll even wait 18 months if i have to for the price to drop in future!

  • Y2john84
    48 posts

    Nowhere else would this be allowed.
    "thanks for your money, enjoy your table, we will deliver the chairs in a month"

    "next gen gaming"

Suggested Topics

Community Details