Welcome to discussions

Quick Suggestions

  • SK_Gael
    4 posts

    I'm another person with this issue.
    I would like to ask if 1.05 patch was supposed to fix this issue. I am reading all over that 1.05 patch is live, available, and fixes this and that, but my PS4 says that 1.04 is the most recent update available. 1.05 hasn't showed in automatic downloads, and when I "check for update", it says the installed application is the latest version, which is 1.04

    @mnrgod lol WHAT!?

    @smithy10gb that's EXACTLY why I stepped away from Valhalla to continue Yakuza

  • Ubi-Borealis
    Ubisoft Support Staff 3561 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • SK_Gael
    4 posts
    This post is deleted!
  • SK_Gael
    4 posts
    This post is deleted!
  • ChilLotus
    1 posts

    I can’t talk to the npc:s in the barracks, the shipyard, the fishing hut and the hunter hut.
    I think it happend after ”A brewing storm” but i’m not sure.
    I have tried to restart the game, uninstall and reinstall the game and restart my xbox but nothing has worked. I also can’t reload a save because i noticed a while after it happend.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hey ChilLotus! I appreciate you reporting this issue you're encountering with not being able to speak to some of the NPCs in your settlement after completing "A Brewing Storm". This is an issue our team is aware of and has posted about on the Known Issues thread. While we do not have any updates to share at this time, please rest assured that our teams are working on this as fast as they are able to and will share updates accordingly.

    Official Response
  • METALUX666
    1 posts

    Reported this over a week ago. Since the quest "Have you seen this man". Have not been able to interact with Wallace at the Hunter Hut in the settlement.

  • nankurunais
    1 posts

    Hi, I can’t interact with the Tanner Wallace to give him the legendary animals and the cartographer. I’m about 75h in this game and hoped the update would have fixed this.
    I play on PS4

  • chriskean86
    11 posts

    Oh look, this STILL isn't fixed 😕

    Imagine having a bug that cripples the only part of the game you sell bonus content for. Lunecy

  • SHIFTY1986
    1 posts

    Exact same issue here pretty much every npc uninteractable including reda. This likely to be fixed any time soon? Games be out how long? Bug riddled.....

  • FireIce38
    27 posts

    @sk_gael As far as I am aware, there is no patch 1.05.

  • Y2john84
    48 posts

    I'm gutted about this, please, please, just add an option in the pause menu to access settlement vendors, clearly finding the root cause is not going to fix anytime soon, so whilst you're investigating, add this simple link in the pause menu, please

  • lewisstorer89
    19 posts

    @fireice38 This article is from Dec 1st and mentions NPC bug fixes -
    https://www.dbltap.com/posts/ac-valhalla-patch-1-05-notes-everything-you-need-to-know-01erfnge9ttx

    no idea where this actual Patch is though because I dont believe I have it either.

  • Y2john84
    48 posts

    @lewisstorer89 what the heck?! I havnt got either and my ps4 says latest version (1.0.4) this is a mess, a mess I can't and won't afford again

  • lewisstorer89
    19 posts

    Man, Cyberpunk 2077 is going to kill this game stone dead. I played Odyssey more than this and I actually thought that was average compared to Origins.
    Deary me. Some excellent ideas went in to Valhalla but this has to be the poorest execution of an AC game ever. This is worse than Unity's launch.
    Ive not been able to play Valhalla now since about the 18th of Nov whilst waiting for a fix to this issue.
    Now Cyberpunk is about to release.

  • lewisstorer89
    19 posts

    @y2john84 me either bro. Mine's still 1.04 so no idea how this has released across all platforms on the 1st because we dont have it haha.

  • heartpunches
    13 posts

    @lewisstorer89 @Y2john84 any sites that are reporting a released 1.05 aren't accuate— the most current release is 1.04, and until ubisoft officially announces a release date for the next patch, that's what we're stuck with. the official ac twitter page and the ubisoft blog are the best place to get legit info on patch releases, but there is a rumor that 1.05 will drop in mid-december, so fingers crossed for that!

  • TheTakenKing640
    1 posts

    Svend doesn't even show up for me. Tried a bad hairstyle for fun. Now I'm stuck with it.

  • FireIce38
    27 posts

    @lewisstorer89 I wouldn't be so sure. Cyberpunk 2077's two largest cons are framerate issues and that it's a buggy mess.

    Possibly even more buggy than Valhalla.

  • smithy10GB
    Original poster 70 posts

    Ubisoft seriously need to start communicating with Microsoft to get people their refunds, listen to this, I am being denied a refund because its over 2 weeks since purchase and I played for more than 2 hours.

    OK so because I spent since the 16th trying to communicate with ubisoft about a game breaking bug, I'm getting shafted.

    Also, who knows what's wrong with this 2 hour thing? Well I'll tell you.

    NOT ALL BUGS HAPPEN WITHIN 2 HOURS

    This is B. S.


    And guess what, we still don't know when it will be fixed, so we have paid £59.99 or more, for a game with essentially no real support and what is essentially a no refund policy (and they know it too well)

    I sense a class action lawsuit if this gets traction.

  • MembaBerries
    2 posts

    Just like everyone else here I am having the same problem. It saddens me to see this issue goes back almost a month ago, and has yet to be fixed. But I feel I need to add to the pile so here it goes. P.S. There are some spoilers:

    Xbox One
    51+ hours of play time
    4/6 village level
    153 Power
     
    Can't speak with:
    Shipwright lady
    Barracks lady 
    Fishing kid
    Stable guy (won’t speak to me despite picking his side of the argument) 

    Can speak with: 
    Black smith 
    Tattoo artist (but only after the quest where her husband died) 
    Opal Contract kid
    Assassin order man
    Thrift shop woman 
    Roman statue guy (but only after completing the quest to get his statue back from London dude) 

    I'm not sure the exact moment it happened but I have completed the Berserker quest.
    Not to mention the Asgard quest line is literally unplayable. Glitched during “Defensive Measures” quest. But I know there is another post for that so I won't continue here.

    And if these glitches, are any indication of how this company is being run, then we are in BIG trouble!

Suggested Topics

Community Details

104
Online
191.4k
Users
32.1k
Topics
161.2k
Posts