Welcome to discussions

Quick Suggestions

  • smithy10GB
    Original poster 70 posts

    @fireice38 cool next week, so what about the past month where I have been unable to do most things in the game?

    I simply compared ubisoft to CD project Red, in less than a week CD has had 2 substantial updates out to try and patch their game, it has taken ubisoft over a month, do you see the issue?

    Also, what if this update does Not fix the issue?

    What then, do you expect me to be happy having to wait potentially another month for a fix? Let's be honest it wouldn't be the first time an update with the intent to fix a problem ends up making it worse.

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • GTR31770
    3 posts

    I have developed the cant talk to NPC in Raventsthorpe bug - other than Yanli, cant interact with anyone. Hopefully some additional info that can help you trace the fault. 1.Cannot speak to any NPC in town, other than Yanli (normal behaviour) - speech bubbles present, but no option or ability to interact 2. Had it before now multiple times, a simple 2-3 times reload of (the same) save always fixed it before - now no change. Changed gender - no impact. 3. Got out of Animus (wont spoil, but something is different here already), got back in - loaded in next to Reda, for a split second had 'Speak' square, and then it disappeared. 4. Feast and cosmetic acting normally. 5. Plants acting normally, but have no ínteract square. 6. Mystic stuck on a horse at the stables - got her second lot of plants recently. 7. Lvl 300-andsomething, just finished humptunscire (last one i did, all others done), cannot interact with Randvi. Town was at lvl5.8, could upgrade to lvl6. Beserker quest done some time ago, and he's been on my crew for ages. Always connected to Ubisoft Connect with no internet issues. Old PC, gtx980, 16GB, i7-6700, Win 10 19041.685 64bit, GeForce 460.79 with period-relevant everything else hardware, running on low settings. Anything else we can do or info we can provide to get some progress on this?

  • Y2john84
    48 posts

    @fireice38 I care

  • Ccryosis
    2 posts

    Can't progress at all because of this glitch/bug. I need to talk to Randvi and Hytham to progress but because of this bug it's impossible. If it matters settlement level 5 and currently trying to complete the hamtunscire arc.

  • FireIce38
    27 posts

    Hmm....well patch 1.1.0 is out tomorrow.

    Unfortunately this issue doesn't appear to be in the list of fixes.

  • heartpunches
    13 posts

    @Ubi-Woofer @Ubi-Borealis will this be addressed in the 12/15 title update? i see "addressed various npc behavior/animation issues" in the patch notes, but i'm not sure if that fixes the settlement glitch. if at all possible, could you please respond with a yes or no before the update drops?

    thanks!

  • kodare97
    10 posts

    It doesn't look like this issue is addressed in the next title update. As much as I understand that it can be difficult to find a solution for this bug, I have had no access to the majority of my settlement NPCs for around a month now and it has ruined what otherwise is a really good game. I am doubtful this issue will ever be addressed, especially since we've been waiting for this bug to be addressed for two updates now. Any update on the issue from the ubisoft team would be really appreciated, as I am starting to lose hope.

  • Ipiidinthepool
    1 posts

    I'm 45 hours in and I cannot talk to rada, cannot start the quest chipping away, the pilgrimage to st albaines, or viking for hire, it sucks to be this far in and lose hope in the game.

  • AciDropper
    2 posts

    @archangel62513 93hrs in and same boat here since the beginning of the game...

  • smithy10GB
    Original poster 70 posts

    Imo it's straight up theft at this point, 1month in and still no update to fix the issue....

    Not to mention we are being refused refunds because all ubisoft and Microsoft are doing is pointing fingers at each other instead of refunding a faulty product.

    I can't get a refund via Microsoft because it has been over 2 weeks (Thanks for that ubisoft!!)

    I can't get a refund from ubisoft because they just point at Microsoft.

    How about this ubisoft, since you guys can ACTUALLY TALK TO MICROSOFT AND NOT BOTS, HOW ABOUT YOU TELL THEM ABOUT THIS ISSUE SO WE CAN GET OUR MONEY BACK FFS.

    Honestly at this point I just want my money back, if the game gets fixed in a week, I'll buy it again. But more then likely its going to take months otherwise it would be in the notes for this update.

  • smithy10GB
    Original poster 70 posts

    @fireice38 do you see why I'm getting annoyed now?

    Ubisoft keep saying rubbish like the update will be in a future update or we are aware of this issue, but still nothing is getting done about it.

    Because its taking so long can't even get a refund despite the game being faulty as fk.

    Funny thing is, I can get a refund, if I want, for cyberpunk.
    Because CD project Red are not ignorant and understand the issue. But I won't, because I can still play their game.

    Ubisoft on the other hand doesn't give a rats [censored] if the customer gets their money back for their faulty product and just keeps giving their customers false hope and [censored] promises, every time a refund is mentioned they just swirve and dismiss it instead of sorting the problem.

    CD project Red are already issuing refunds due to the buggy nature of cyberpunk, there is no reason why ubisoft can't to the same, it's straight up [censored] theft at this point.

  • tperfecto12
    6 posts

    @ubi-woofer I just submitted a case around this issue. It is very disappointing that it is still continuing after the most recent patch. Case number 13591430

    @heartpunches it was not

  • tperfecto12
    6 posts
    This post is deleted!
  • PapaBellerose
    2 posts

    @Ubi-Woofer

    I am honestly really disappointed that you told us the problem will be solved in the next update. You did not even care not let us know that the problem will not be solve and keep us updated. For you, and Ubisoft, it is a big lack of professionalism.

  • FireIce38
    27 posts

    @papabellerose They never said it would be solved in the next update. They said it would be solved in a "future" update.

  • Y2john84
    48 posts

    @fireice38 oh OK, so that makes everything cool then, thanks 👍

  • FireIce38
    27 posts

    @y2john84 You're welcome!

  • WildEagle64
    1 posts

    I loaded up the new patch and still have no access to the shipyard and barracks and stables I'm probably 100 hours in and would love to actually be able to use them any chance your gonna fix this ubi?

  • sgonabe
    2 posts

    @Ubi-Woofer

    Enough is enough. This problem was reported over a month ago, and after two major updates it has been neglected twice. This is akin to buying a car and finding out the stereo stops working after mile 50. It isn't vital to starting the car, but it sure makes driving a lot more fun and manageable. Plus, I paid for the stereo too. Thankfully, no major plot bugs have cropped up, but at Power 135 I am not going to play the game again, knowing they are out there and that many Settlement features have been disabled for five weeks with no date or clear plan to fix them.

    This is the last title I will buy from UbiSoft. I have never purchased a new game with so many bugs, crashes, and other problems. I stayed away for this reason, having had a similar experience with Unity. The Settlement bug was the last straw. I feel completely duped. I feel like I bought the snake oil. This is thievery. Never again, UbiSoft.

  • V3R4TYR
    9 posts

    It is now Patch 1.1.0, and I am playing on the PS4. I still cannot interact with the Shipyard, Cartographer, Stables, and Barracks. This issue only remains in my main game with 216 hours. Both my second and third game do not have this issue... yet.

Suggested Topics

Community Details

85
Online
190.5k
Users
31.6k
Topics
160.1k
Posts