Welcome to discussions

Quick Suggestions

  • HardhatCanine30
    1 posts

    In the settlement I cant speak to the person who Customizes the ship and the person at the Barracks

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • HomeyChicken
    1 posts

    @blakehayward

    Same on ps4. I can't talk to the shipbuilder or the barracks. I could talk to the shipbuilder when first unlocked then lost the option, I've never been able to talk to the barracks. Was really hoping the Dec 15th title update would fix this but no luck.

  • Ryan__Steel
    1 posts

    I cannot talk to the Shiprock,barrack and hunter in my settlement after processing in the game. I use to he able to talk to the shipdock and barrack people but now there is no possible way. I tried everything and still bugged. Anyone know more about this

  • smithy10GB
    Original poster 70 posts

    Lagit when are these devs going to stop [censored] us and actually help us get out money back. This is a joke it's been a month and I still cant do [censored].

    I bought the game as a complete product, not a broken product.

    If the product was still in development it should have been classed as early access, not a full release.

    I want my money back. Here's the deal, my money or a lawsuit.

    You are selling a faulty product and refusing to help with a refund, and as far as I, the customer, can tell there is no real eta on a fix.

    You say "A future update"

    When!?!? It could be 2025 for all I [censored] know, the fact that this "fix" still hasn't been implemented is not a good sign.

    Ubisoft should be working with the respective platforms, specifically Microsoft and Sony to get people their money back instead of brushing it off, you guys can't keep selling broken games with the expectation of patching it into a playable state, it's false advertising, look at what happened with fallout 76.

    Get us our refunds! We have waited long enough.

  • STEVE713748
    1 posts


    I can’t interact with the shipwrights. The barracks and every time I die the game goes black and white and does not return to normal color unless I engage a NPC in a conversation, meaning I often have to return to my settlement to interact with Gunnar. 140 hours in and it’s still a problem.

  • DRU-MANIC
    1 posts

    Shipyard, barracks, stable, hunter, and cartographer are not working for me. Also have a couple of wealth and artifacts that seem to have fallen through the map. This is my second playthrough attempt. I didn't see this problem on the first attempt, but ran into a game-breaking quest bug and then all NPCs in the game disappeared, just ghost towns. Now, I run into this. Makes me wish I hadn't bought the game. Ugh

  • Foxxyred520
    2 posts

    I'm around 150 hours in and still can't talk to a lot of my NPCs. Cartographer never worked, hunter, ship builder, fisherman, barracks. Hoping for a patch soon. I want to customize my stuff!

  • Kandsmerlin
    2 posts

    I have a similar issue with the NPC's.

    I've completed the main story line and am now focusing on the world-event quests. In my play-through, I managed to adopt a wolf and a fox into the settlement but since update 1.1.0, they have disappeared along with the children that hang around the long house /mead hall in my settlement.

    I hope I'm not the only one who's lost my wolf and fox. Ubisoft please fix this.

  • joshisaacs
    1 posts

    Same problem. Can’t interact with half the NOCs in Ravensthorpe.

  • Y2john84
    48 posts

    This is disgraceful, there is no defence for this, I've been more than patient, I've been polite, and I've tried to help find the root cause of this bug and still no fix. I have gone to Sony PlayStation with this now. Goodbye

  • chriskean86
    11 posts

    Hey look. A seasonal event that requires interaction with settlement NPCs that everyone in this thread can't take part in. Bravo. Great use of my season pasd

  • ibivan
    9 posts

    this is like being, in the airport on a delayed flight. No information, no updates. I am sure we will get 250 more armor mod micro-transaction packs released before the part time one developer that is working on this problem gets it solved

  • heartpunches
    13 posts

    @Ubi-Woofer

    thank you for responding above: re the 1.10 title update; i appreciate that you're still communicating with us about the issue. that being said, can you please let us know whether or not the devs believe they'll have this glitch patched before the end of the yule festival season? it's a settlement-based festival, and given that none of us on this thread can interact with settlement npcs, we're missing out on what is supposed guaranteed post-launch content.

    i don't really know how to convey how ridiculous this whole situation is without getting strident, but suffice it to say: this game currently seems like an abject waste of money during a difficult year where i already considered the purchase a splurge.

    any update you can give us right now would be greatly appreciated. thank you in advance.

  • justin.foa
    1 posts

    I cannot interact the Randvi and Basim to continue the quests in Revensthorp. This is after I've finished all the pledged territory quests. Basim has a letter but when I approach him it doesn't give the option to speak with him.

  • RaymundAngelo
    1 posts

    Im having same issues aswell. Please UBISOFT troubleshoot this

  • TimeKillerOmega
    1 posts

    Hi, so im playing on the xbox one x, i have currently 50 +hours in the game and well ive spent every minute attacking zealots and collecting and havent played hardly any of the story, well i finally decided that at gear rank 100 that ill start the campaign back up, so i ranked up my settlement unlocking valkas quest to escort her to her hut and she stops mid walk after talking to the blacksmith, now none of ravensthorp even randvi cant be interacted with so now i the only thing i can do in the game is rank and collect items thats not blocked by story events. As a bonus i cant take part in the yule festival cause i cant gain alliances due to my settlement acting the way it is

  • Y2john84
    48 posts
    This post is deleted!
  • Keltic102
    1 posts

    in my game at least it seems to happen if the game crashes in the settlement.

    only noticed this might be the case as I interacted with hythem and the tattooist and tried to upgrade my weapons. The game crashed after I exited the upgrade menu and I chose to load the last autosave. after it loaded I realised that I couldnt interact with either hythem or the tattooist now. loading the save before this fixed it.

    I cant interact with barracks, fishery and the shipyard but i do recall it crashing after trying to upgrade weapons when i was about 30hrs in and didnt think to load an earlier save.

  • xv3791
    3 posts

    during the festival in the village no one talk(the icon to speak ) in the shops only the 3 in the festival !, the blacksmith ,trader have no speak icon and the quest to go with the seer to the hut the seer stops on the road, radvni also dont speak and can not see the aliance map !!!!!!!!! are this bugs from the yule festival?!?!?!?!?!!

  • ubi-smash
    Ubisoft Support Staff 501 posts

    @xv3791 Heya! If you did not get the Yule Festival notification, please restart the game or perform any save/load action to activate the event. Please note either the Ledecestrescire or Grantebridgescire quest arcs has to be completed to access the seasonal content. If you have already started the event and are unable to progress, please share with me any screenshots of the area you are currently stuck on at this time so I can look over further.

    Official Response

Suggested Topics

Community Details

128
Online
139.7k
Users
24.6k
Topics
127.4k
Posts