Welcome to discussions

Quick Suggestions

  • Amit_Vyas
    1 posts

    Dismayed to see that this is still not fixed in the latest 2.00 update for PS4.

  • JayTee308
    1 posts

    @tallpaul713 I have the same issue have constructed most of my settlement however the NPC's for hunter hut fishing hut barracks and shipyard don't have their chat bubbles so I can't interact with them either

  • chriskean86
    11 posts

    This still isn't fixed and there's a settlement based seasonal update coming that I'd love to play but I put the game down 2 weeks ago. What is wrong with game companies. Why are games being released so broken?

  • Xsarsus
    11 posts
    1. Made a raid
    2. Upgraded blacksmith
    3. Had a auto-dialog with Gunnar – upgraded my axe
    4. Left the dialog and cannot talk to anyone now

  • Xsarsus
    11 posts
    This post is deleted!
  • S7R1V3R
    1 posts

    Still broken after today's update despite the devs saying it is fixed.

    I work as a product manager with a of team software engineers, developing and maintaining a product I would be absolutely SAVAGED by the business if I said I had fixed a major bug and then it turns out that it is not. This is not good enough. The devs clearly don't understand the root cause of the problem, clearly are not testing thoroughly enough and the community team are being kept in the dark and/or trotting out replies without substance.

    Can we have a senior dev explain as to what they are struggling with here?

    Edit: I see that while the patch notes refer to various NPC improvements, apparently that excludes the inability to interact with the NPCs you engage with most. Fine. Can I instead ask that we get clarification on the timeline for this patch? If it's in the next major patch in Jan, I'm getting a refund.

  • undlose
    1 posts

     I Stil can't buy att Reda’s Shop..the cursor only stands att the back button is on ps4..I can only get jobs.

  • kodare97
    10 posts

    After this latest update I have lost hope that this issue will ever be addressed. I have completed the main story and most regions and although I have really enjoyed the game I won't be playing any longer, as it appears this bug will never be fixed, which means I cannot collect any rewards or customise my ships or jomsviking with items I have purchased from the store. I think the main game is great but the fact that ubisoft have not addressed such a game breaking bug is incredibly frustrating and has ruined an otherwise very good game.

  • trickjc
    4 posts

    @kodare97 I agree with everything you're saying this is a really stupid bug that applies to a major aspect of the game

  • smithy10GB
    Original poster 70 posts

    @ubi-woofer yeah I understand that, but the only reason I am outside the 2 weeks deadline is because I was on these forums reporting the issue, surely you guys at ubisoft can do something about that.

    I just find it insane how I am getting shafted so hard for trying to help bring this issue to your attention, if I didn't bother messing about with all of this I would have been able to get a refund, I literally haven't even played the game since I reported the issue.

    And trust me, I have tried getting a refund through Microsoft but its always automated bots I speak to that don't help at all, surely you guys have a contact you can speak to because we both know this is a big issue.

  • smithy10GB
    Original poster 70 posts

    @s7r1v3r good luck.

    I don't mean to sound negative but they have made it borderline impossible to get a refund on console, if you are on console.

    I'm seriously going to look into legal options because this straight up ignores the consumer rights act.

  • SirGwill
    2 posts

    Even after the 1.1.0 patch I’m still having issues with Talking to Wallace the Hunter about handing in legendary animals, I’ve only ever spoken to him once before the side mission to find him and after that I haven’t been able to speak to him. I had a similar issue with Reda but that’s been fixed for me.

    Im currently 115 hours into the game and am close to 100% it, just dreading when the only thing I have left to do is legendary animals I can’t even hand it 😞

    P.S. I can’t even add Bjorn to my raider crew after the mission with him, everytime I add him and fast travel anywhere he’s replaced in my crew

  • GTR31770
    3 posts

    "Thanks for offering your help - the team have identified the issue and are working on the fix, which is coming up in a future update. I'm afraid for the moment it's just a case of waiting for it to be ready. I apologise for the inconvenience caused by the issue, and hope that you're enjoying Valhalla overall!"

    Ok, post patch feedback. Tried my autosave continue, no behaviour change. Tried a manual save from the same point. First time of loading could speak to the blacksmith, upgraded a weapon, could talk to reda, could get new contracts, thought yay, it's fixed. Ran to report to Randvi - no 'Speak square'. return to others I had just spoken to, no speak square or ability to interact. reloaded the same save,c an speak to the blacksmith, go to reda, no speak sqaure and enters 'broken state' where i cant talk to anyone but yanli. Tried everyone in town. Interestingly, speaking to Nessa, returns me to the half broken state where i can talk to the backsmith again. From my 20 minutes of testing, can the talk to crew lady, blacksmith, ship ugrading without exiting half broken state. Can always 'reset' to half broken state by talking to Nessa. Even getting close to the following npcs, makes it enter fully broken state: reda, cartographer, geting close to randvi, getting close to mystic (and getting nearby quest message). Too dumb to make video, but happy to stream to the devs on discord, and show behaviour live if they want

  • Radioactive917
    2 posts

    I can't talk to a single person in my settlement, I'm 60 hours in and would prefer not to restart considering I've literally cleared out entire provinces for loot. I have no idea what it's like to use the boat or anything.

  • GTR31770
    3 posts

    @radioactive917 Try Nessa on the left of the docks as you look at the river. For me it reset to half-broken state as above

  • Radioactive917
    2 posts

    @gtr31770 I'll check it out thank you

  • Y2john84
    48 posts

    Please ubisoft, your struggling finding this route cause to find the bug, I understand and I appreciate you must be working hard, is it possible for you to just had the settlement functions in the pause menu as a quick fix so we can enjoy the 50% of the game we haven't got? Surely you can just add this function as a dlc pack? Then you can work on the bug without losing players, I can't afford to keep paying £70 for a game that isn't what it says it is upon launch, please add this function

  • evoloki
    1 posts

    I had this issue earlier in the game and it seemed to fix it self after doing other missions. Now I'm 106 hours in and it has done it again, I only have 3 quest available. All 3 are in raventhorp and I can't interact with anyone in raventhorp except the item merchant. So I am litterally stuck till this issue is fixed.

  • BlakeHayward
    1 posts

    I can't talk to the shipwright npc on ps4. Any ideas?

  • HardhatCanine30
    1 posts

    In the settlement I cant speak to the person who Customizes the ship and the person at the Barracks

Suggested Topics

Community Details