Welcome to discussions

Quick Suggestions

  • heartpunches
    13 posts

    @Ubi-Woofer

    thank you for responding above: re the 1.10 title update; i appreciate that you're still communicating with us about the issue. that being said, can you please let us know whether or not the devs believe they'll have this glitch patched before the end of the yule festival season? it's a settlement-based festival, and given that none of us on this thread can interact with settlement npcs, we're missing out on what is supposed guaranteed post-launch content.

    i don't really know how to convey how ridiculous this whole situation is without getting strident, but suffice it to say: this game currently seems like an abject waste of money during a difficult year where i already considered the purchase a splurge.

    any update you can give us right now would be greatly appreciated. thank you in advance.

  • Ubi-Borealis
    Ubisoft Support Staff 2929 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • justin.foa
    1 posts

    I cannot interact the Randvi and Basim to continue the quests in Revensthorp. This is after I've finished all the pledged territory quests. Basim has a letter but when I approach him it doesn't give the option to speak with him.

  • RaymundAngelo
    1 posts

    Im having same issues aswell. Please UBISOFT troubleshoot this

  • TimeKillerOmega
    1 posts

    Hi, so im playing on the xbox one x, i have currently 50 +hours in the game and well ive spent every minute attacking zealots and collecting and havent played hardly any of the story, well i finally decided that at gear rank 100 that ill start the campaign back up, so i ranked up my settlement unlocking valkas quest to escort her to her hut and she stops mid walk after talking to the blacksmith, now none of ravensthorp even randvi cant be interacted with so now i the only thing i can do in the game is rank and collect items thats not blocked by story events. As a bonus i cant take part in the yule festival cause i cant gain alliances due to my settlement acting the way it is

  • Y2john84
    48 posts
    This post is deleted!
  • Keltic102
    1 posts

    in my game at least it seems to happen if the game crashes in the settlement.

    only noticed this might be the case as I interacted with hythem and the tattooist and tried to upgrade my weapons. The game crashed after I exited the upgrade menu and I chose to load the last autosave. after it loaded I realised that I couldnt interact with either hythem or the tattooist now. loading the save before this fixed it.

    I cant interact with barracks, fishery and the shipyard but i do recall it crashing after trying to upgrade weapons when i was about 30hrs in and didnt think to load an earlier save.

  • xv3791
    3 posts

    during the festival in the village no one talk(the icon to speak ) in the shops only the 3 in the festival !, the blacksmith ,trader have no speak icon and the quest to go with the seer to the hut the seer stops on the road, radvni also dont speak and can not see the aliance map !!!!!!!!! are this bugs from the yule festival?!?!?!?!?!!

  • ubi-smash
    Ubisoft Support Staff 547 posts

    @xv3791 Heya! If you did not get the Yule Festival notification, please restart the game or perform any save/load action to activate the event. Please note either the Ledecestrescire or Grantebridgescire quest arcs has to be completed to access the seasonal content. If you have already started the event and are unable to progress, please share with me any screenshots of the area you are currently stuck on at this time so I can look over further.

    Official Response
  • tperfecto12
    6 posts

    Guys I honestly don’t know what else to do except to keep harassing abs bashing them until it’s fixed. Maybe if we make enough noise they will finally fix it. It is very disappointing and believe this will be my last game with Ubisoft in general if they can not fix it or make amends.

  • FireIce38
    27 posts

    @y2john84 Why should everyone on PlayStation suffer because you and a select few others are experiencing this bug?

  • smithy10GB
    Original poster 70 posts

    @timekilleromega yeah it sucks, in the week that cyberpunk has been out cd project red have had 3 updates, ubisoft have only had 2 since I mentioned this issue and it's been over a month, they still didn't fix it.
    At this point I just want my money back and they are even refusing that and seem to have no intention of helping me get it back.

    It's just straight up stealing at this point and they just dont give a damn, definitely the last time I spend money on a ubisoft product. Just another company that doesn't give two flying [censored] about their community, and to think I was sticking up for them during my first 2 weeks with this issue. Now I just feel like a [censored].

  • Y2john84
    48 posts
    This post is deleted!
  • Y2john84
    48 posts
    This post is deleted!
  • Y2john84
    48 posts

    I deleted a few comments, this bug is turning us against each other, when in another time we would have been getting along, this bug is frustrating, but doesn't excuse us for getting at each other necks, sorry @FireIce38, I wouldn't care as much if I didn't love this game so much, I know it will be fixed at some point

  • XPurpleDanX
    1 posts

    I am playing on xbox one. I cannot speak to wallace to turn in legendary animals. I can only speak to petra as a romance but no chance of speaking with wallace. The same happened with svend until certain events freed up the hair and tattoo shop.

    Please provide a patch so i can be rewarded for my hunting.
    PurpleDan

  • xv3791
    3 posts

    @ubi-smash i started the game from norway now in Grantebridgescire in the Glory Regained quest the game says to regroup with sona and she does nothing!!!!!! ,normaly someone comes out from the longhouse , now i can not proceed ! i did not push any button about the festival though i saw the message

    undefinedundefined

  • Tibcsuu8370
    2 posts

    Cant speak with Blacksmith and others,Randvi is out of aliance map..Please fix it

  • beatdownXnoki
    2 posts

    Yeah, I've had this glitch for about 3 weeks now.
    I'm done with Grantebridgescire and Ledecestrescire and I had the attack on Ravensthorpe already. After that, I've been working on the events and collectibles in East Anglia (without touching that area's quest line other than pledging it). I then got back to Ravensthorpe to build some facilities (stables and tattoo shop), following which neither the tattoo artist nor the stable boy were interactable, as were the shipwright and the barracks lady.
    The other NPCs that have been reported in this thread, namely Hytham, the Roman artifact collector, Randvi, fish boy are all interactable still.
    Starting the Yule fest didn't change anything.

    Didn't bother me that much because I've had enough other games on my backlog but now I'm just craving Valhalla and it kinda sucks that almost all meaningful ways of progression are glitched out.
    I don't get how a comparatively small dev/publisher like CDPR manages to crank out 2 substantial patches on 5+ platforms over the course of a week while a huge corporation such as Ubisoft just leaves dozens of known and reproducible glitches in their game for weeks (turning into months). I'm not one to sharpen their knives and pitchfork, it's just really sad because the game itself is great and it seemed much more... passionate than some of the earlier installments of the series.

  • Dr_Ayon
    5 posts

    @timekilleromega
    same here....

  • smithy10GB
    Original poster 70 posts

    @Ubi-Woofer don't mean to sound like a [censored], but what I said would happen is now happening and I'm even more [censored].

    The game is now on sale on xbox, a game I paid in full for over a month ago and still can not play.

    This is a joke, I hope you can sort something out on your end and get me a refund or something because this is just shocking now £59.99 for a game that I have had over a month and can still not play. Not to mention no real news on an update, no news on any form of compensation and to put it bluntly, no [censored] given on ubisofts side. This is likely the last time I spend money on a ubisoft product.

    I have the new motto for ubisoft. No news, No fixes and definetly no refunds.

Suggested Topics

Community Details

51
Online
143.5k
Users
25.4k
Topics
132.0k
Posts