Welcome to discussions

Quick Suggestions

  • smithy10GB
    Original poster 70 posts

    @ubi-woofer let's be honest I already have a huge sanction on my account, it's a £59.99 game that I can't do much with, and now it's also a big event that, let's be honest, I'm also going to miss.

    Please please please tell me what I paid for.

    Pretty sure I paid for a COMPLETE game over a month ago, not an EARLY ACCESS game.

    This is such a meme at this point.

    Also wth are we supposed to do? We are all going to miss this new event, what are we going to get for it? Nothing but false hope.

    Let's be honest, ubisoft don't believe in making amends for their mistakes so in 6 months time when this issue is actually sorted it will just be brushed under the carpet and not a single person here will get any sort of compensation for the months without a game that we have all paid for.

    Such a shame, it finally started to look up for ubisoft but after this whole event I don't think I'm going to ever spend money on any of their products again. Developers need to learn the hard way, I just hope others take the same action because it seems like the only way to get anything from ubisoft is with cold hard cash.

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • smithy10GB
    Original poster 70 posts

    @lethalrabbid just a heads up I have had experience with video game development and at this point I believe his comments towards the devs are fully deserved.

    Not only are they providing any real info on the matter but it has also been over a month. Over 1 month with their grubby hands on our cash and we can't even play the product we paid for.

    No help with refunds, no help with in terms of an eta, not a spec of compensation for this mess and if you use your eyes, you will see that the devs priority is not actually with the bug, but rather the event.
    Yes the event that WE CAN'T EVEN TAKE PART IN.

    So yes, I would say its completely justified.


    If you bought a TV and half the screen was permanently black, then you asked for a refund only to be completely denied something that should be well within your rights under the consumer rights.
    Would you not be atleast a little bit frustrated?

    The first 2 weeks I gave them the benefit of the doubt, but it's clear at this point that they have no intention of fixing the bug any time soon, if that where the case I can't see a reason for the devs not to just give us a freaking eta.
    But no, they keep saying in a "future update".

    Future can be any time, could be 1 month, 1 year, or ubisoft favourate "Future" NEVER.

  • Ubi-Woofer
    Ubisoft Support Staff 1009 posts

    @ApGOD48 As I previously advised, a fix is coming for this issue in a future update - thank you for your patience and understanding in the meantime. I'm afraid I don't have further details at this time however I hope to know more very soon!

    @smithy10GB Your honest feedback on this experience is appreciated, and I've been passing forward your comments and the frustrations expressed throughout. If I do hear anything back regarding compensation or other plans, I will let everyone know. In terms of the fix for this issue, I can assure you it is not "never" coming - it is planned for a patch already scheduled. I don't have confirmation of the patch date or details as yet, but as I've said, I'll share more when I know more!

    Official Response
  • dill-1993
    1 posts

    I cant use the barraks or long ship or fishing store

  • claud1o-
    50 posts

    @ubi-woofer nothing wrong with how you have managed this and other posts on bugs, but I feel very close to @smithy10GB position as we were amongst the first unlucky to have this bug on Nov 12, straight after the game was released
    It is now Dec 24, 1 month and a half has passed and all we get is vague reassurances that in a future patch, the matter is priority, we appreciate the frustration, devs are working hard to look into it etc.

    Fact is that nothing has been done on the dev side, we could not play the game as intended and this is an extremely faulty product which has, by the way, very negatively impacted your company's reputation at the eyes of many customers/players.

    It is shameful that it took almost 30 days to just acknowledge the issue on the dev side, and I would blindly bet they started working on it not earlier that 15/20 days ago.

    The fact that we have no timeline whatsoever only adds more shame on Ubisoft and uncertainty to us.

  • kalen12345
    1 posts

    Having problems with the game it won’t let me finish the missions or talk to anyone

  • HappyCarnage21
    1 posts

    I too am getting the same error messages on my Xbox one. I can interact with my npcs still (mind you I havnt tested all of them) but when I'm trying to get contracts it pops up with an error message. I changed my ubisoft password because that was recommended, and it worked for a while, but now I'm back to getting error messages. Its very frustrating since I'm trying to complete the quest for 10 contracts but I can't get the contracts to complete it.

  • samstra101
    3 posts

    I have this problem on the ps4 and ps5 for 2 months, i’m still waiting for the patch... it’s gamebreaking and I will never ever buy the gold edition of Ubisoft again.. Sorry guys

  • tperfecto12
    6 posts

    @ubi-woofer We def look foreword to being kept in the loop and getting this fixed because it is very frustrating. Can you also please advise you let staff to stop giving out false information. All the help your fellow team member are advising does not work. It is clear this is an issue with the game made by Ubisoft. I am very sick of creating cases and given nonsense answers on how to fix this. It is a bug in the game and can only be fixed and corrected by Ubisoft. Hell even an official statement/apology for Ubisoft would go a long way to all the customers that have been affected by this for over 50 days

  • Schakoww
    5 posts



    A BIG XMAS GIFT!!

    PC version patch 1.1.0
    Bought the standard game on 22/12/2020.
    Add the Quest The Way of the Berserker with Token but never started the quest.

    This issue happened to me yesterday 24th December.
    Everything was working (other than the Quest A Wise Friend, aka Valka), but when I did an upgraded the settlement to level 4! Bang magic. I can't talk.to anyone, ANYONE, except people from Yule Festival.

    OTHER ISSUE: I don't use BOW to fight. So I change the controller config to be MOUSE2 my shield/parry and archery on "Q". But to go Fish, I must change the controllers to default again because Fishing doesn't recognize my config.

  • FierceFighting
    2 posts

    same over here

  • lewisstorer89
    19 posts

    This, THIS right here, is exactly why I was reluctant to buy digital versions of games. After years of putting it off, i finally relented and bought the digital version of Valhalla.

    And low and behold im stuck with some 5h!t I cant use or get money back from (because clearly they arent going to make refunds available). Had I bought a physical copy i could have traded it into a game store for like 3/4 of my money back in the first week this bug happened (release day week).

    I bought the Berserker version for £54.99, then added £6 extra of my own money for some tats and the wolf mount from store. So im $80 down the drain.
    How have we gone from the masterpiece that was Origins that I had no bugs with whatsoever - to eventually where we are now?
    Shocking.

  • laevers
    1 posts

    IM WITH pc setelment level 4 i cant interact with npc eccept the store i cant acces the alliance map anymore so im stuck in the story line all problems startet from wen the yule festival began first no problems i also cant escort the seer too her hut + i began the berserker quest after i no longer can comunicate with setlement npc but the bear is stuck aan the lake nothing happens

  • LethalRabbid
    8 posts

    @smithy10gb I do understand the frustration, and I unfortunately have no game development experience... (I actually envy you for that 😛 ) but I think that the problem here is Ubisoft's management-style and maybe even the specific studio this game is being created at.
    Yeah, sure, the devs probably get a nice paycheck, but that's peanuts compared to the bonuses upper management get when the deadlines are met... and they determine support resources 😉 ...
    Then we have the issue of "there's no profits to be gained from proper maintenance" mentality, which is a company (and not only Ubi's btw) issue... I am sure that some devs really care about the gamers and thus want to fix the bugs they created in their 40+ hours working weeks, but they probably need more resources, which are probably being blocked because of the earlier mentioned mentality issue from management/stakeholders...

    I just hope for all us gamers who love the series (damn, I have played every main game so far and I am still in love with the entire franchise) that this is being fixed soon and that we can enjoy the game once again...

    I'm stuck @40 hours, no alliance map interaction possible, not a single settlement npc available and thus can't upgrade gear and I was just collecting nickle ingots to get my gear to the next tier... my quests all require NPC interaction... and starting over isn't a good idea since there seems to be no actual cause pinpointed as of yet... (unless I missed something)...

    So I really feel your pain 😞, I just don't think attacking the "executing groups" approach (might seem a bit hypocrit as I am stating it's "management's fault"... 😅 but I am actually trying to address the 100% profit - 0% customer satisfaction feeling being created)

    Anyways, enjoy the holidays, I hope you find something else to keep you busy and your minds of this [censored]ty bug 😉

  • HojoJames22
    2 posts

    Playing on PS4.

    I've got to the point of periodically loading up the game to see if I anything changes or to try a quick fix for a bug. Very annoying now and rather unfortunate. I've just had another look now and apart from having the issue of no settlement npc interaction, I now can't use my raven.

    I'll putting the game down again until the next update. I really wanted to go through the yule event but I can't be bothered with it as it seems like issue are piling up with the increase in content.

    I'll hold out for a refund, if I can still get one, as I'd like to see the product fixed so I can play on. But If no improvements are made soon with some sort of update then I'll have to give up.

    @Ubi-Woofer

  • Dclark5891
    5 posts

    I had the issues of not being able to talk to npcs on my first playthrough. In that playthrough I did the berserker mission. On my second playthrough I avoided the berserker mission and have had no issues. The problem as I've seen many state is in the completion of that mission. Avoid doing it at all costs.

  • KubaPac321123
    1 posts

    Unable to speak to any npc in ravensthrope. Its so anoying you just cant do anything in the village

  • Darksilver355
    1 posts

    -I cant speak to any npc in hreafnathorp.
    if i go to another city i can speak with a shopkeaper

    -I'm in the middle of the quest: a wise friend and valka always stops moving at the same place and i cant continiue the quest

    could you pls help me with my problems

  • sheedali
    1 posts

    Just fix this problem already Ubisoft PLEASE!

  • Schakoww
    5 posts

    @laevers
    I starting to distrust this problem begins when you do the upgrade from level 3 to level 4.

Suggested Topics

Community Details

85
Online
190.5k
Users
31.6k
Topics
160.1k
Posts