Welcome to discussions

Quick Suggestions

  • kalen12345
    1 posts

    Having problems with the game it won’t let me finish the missions or talk to anyone

  • HappyCarnage21
    1 posts

    I too am getting the same error messages on my Xbox one. I can interact with my npcs still (mind you I havnt tested all of them) but when I'm trying to get contracts it pops up with an error message. I changed my ubisoft password because that was recommended, and it worked for a while, but now I'm back to getting error messages. Its very frustrating since I'm trying to complete the quest for 10 contracts but I can't get the contracts to complete it.

  • samstra101
    3 posts

    I have this problem on the ps4 and ps5 for 2 months, i’m still waiting for the patch... it’s gamebreaking and I will never ever buy the gold edition of Ubisoft again.. Sorry guys

  • tperfecto12
    6 posts

    @ubi-woofer We def look foreword to being kept in the loop and getting this fixed because it is very frustrating. Can you also please advise you let staff to stop giving out false information. All the help your fellow team member are advising does not work. It is clear this is an issue with the game made by Ubisoft. I am very sick of creating cases and given nonsense answers on how to fix this. It is a bug in the game and can only be fixed and corrected by Ubisoft. Hell even an official statement/apology for Ubisoft would go a long way to all the customers that have been affected by this for over 50 days

  • Schakoww
    5 posts



    A BIG XMAS GIFT!!

    PC version patch 1.1.0
    Bought the standard game on 22/12/2020.
    Add the Quest The Way of the Berserker with Token but never started the quest.

    This issue happened to me yesterday 24th December.
    Everything was working (other than the Quest A Wise Friend, aka Valka), but when I did an upgraded the settlement to level 4! Bang magic. I can't talk.to anyone, ANYONE, except people from Yule Festival.

    OTHER ISSUE: I don't use BOW to fight. So I change the controller config to be MOUSE2 my shield/parry and archery on "Q". But to go Fish, I must change the controllers to default again because Fishing doesn't recognize my config.

  • FierceFighting
    2 posts

    same over here

  • lewisstorer89
    19 posts

    This, THIS right here, is exactly why I was reluctant to buy digital versions of games. After years of putting it off, i finally relented and bought the digital version of Valhalla.

    And low and behold im stuck with some 5h!t I cant use or get money back from (because clearly they arent going to make refunds available). Had I bought a physical copy i could have traded it into a game store for like 3/4 of my money back in the first week this bug happened (release day week).

    I bought the Berserker version for £54.99, then added £6 extra of my own money for some tats and the wolf mount from store. So im $80 down the drain.
    How have we gone from the masterpiece that was Origins that I had no bugs with whatsoever - to eventually where we are now?
    Shocking.

  • laevers
    1 posts

    IM WITH pc setelment level 4 i cant interact with npc eccept the store i cant acces the alliance map anymore so im stuck in the story line all problems startet from wen the yule festival began first no problems i also cant escort the seer too her hut + i began the berserker quest after i no longer can comunicate with setlement npc but the bear is stuck aan the lake nothing happens

  • LethalRabbid
    8 posts

    @smithy10gb I do understand the frustration, and I unfortunately have no game development experience... (I actually envy you for that 😛 ) but I think that the problem here is Ubisoft's management-style and maybe even the specific studio this game is being created at.
    Yeah, sure, the devs probably get a nice paycheck, but that's peanuts compared to the bonuses upper management get when the deadlines are met... and they determine support resources 😉 ...
    Then we have the issue of "there's no profits to be gained from proper maintenance" mentality, which is a company (and not only Ubi's btw) issue... I am sure that some devs really care about the gamers and thus want to fix the bugs they created in their 40+ hours working weeks, but they probably need more resources, which are probably being blocked because of the earlier mentioned mentality issue from management/stakeholders...

    I just hope for all us gamers who love the series (damn, I have played every main game so far and I am still in love with the entire franchise) that this is being fixed soon and that we can enjoy the game once again...

    I'm stuck @40 hours, no alliance map interaction possible, not a single settlement npc available and thus can't upgrade gear and I was just collecting nickle ingots to get my gear to the next tier... my quests all require NPC interaction... and starting over isn't a good idea since there seems to be no actual cause pinpointed as of yet... (unless I missed something)...

    So I really feel your pain 😞, I just don't think attacking the "executing groups" approach (might seem a bit hypocrit as I am stating it's "management's fault"... 😅 but I am actually trying to address the 100% profit - 0% customer satisfaction feeling being created)

    Anyways, enjoy the holidays, I hope you find something else to keep you busy and your minds of this [censored]ty bug 😉

  • HojoJames22
    2 posts

    Playing on PS4.

    I've got to the point of periodically loading up the game to see if I anything changes or to try a quick fix for a bug. Very annoying now and rather unfortunate. I've just had another look now and apart from having the issue of no settlement npc interaction, I now can't use my raven.

    I'll putting the game down again until the next update. I really wanted to go through the yule event but I can't be bothered with it as it seems like issue are piling up with the increase in content.

    I'll hold out for a refund, if I can still get one, as I'd like to see the product fixed so I can play on. But If no improvements are made soon with some sort of update then I'll have to give up.

    @Ubi-Woofer

  • Dclark5891
    5 posts

    I had the issues of not being able to talk to npcs on my first playthrough. In that playthrough I did the berserker mission. On my second playthrough I avoided the berserker mission and have had no issues. The problem as I've seen many state is in the completion of that mission. Avoid doing it at all costs.

  • KubaPac321123
    1 posts

    Unable to speak to any npc in ravensthrope. Its so anoying you just cant do anything in the village

  • Darksilver355
    1 posts

    -I cant speak to any npc in hreafnathorp.
    if i go to another city i can speak with a shopkeaper

    -I'm in the middle of the quest: a wise friend and valka always stops moving at the same place and i cant continiue the quest

    could you pls help me with my problems

  • sheedali
    1 posts

    Just fix this problem already Ubisoft PLEASE!

  • Schakoww
    5 posts

    @laevers
    I starting to distrust this problem begins when you do the upgrade from level 3 to level 4.

  • LethalRabbid
    8 posts

    @dclark5891 for me, it started before completion of that quest, after upgrading my settlement to lvl 3. However, I did this just before the yule festival and did not pay attention to the npcs then, so I can't really relate it to exactly one thing... except perhaps getting the beserker quest, because I accepted it around the same time of my settlement lvling up , and since I have seen many people pointing at that particular quest, that may indeed be the culprit here...

    Do you remember if you accepted the quest in your new playthrough? As to avoid me starting over and the theories are proven wrong and screwing up my game again? 😁

  • Schakoww
    5 posts

    @lethalrabbid

    It is possibly be related to Berserker`s quest, I bought it with U tokens and I just read the letter in my room, after I did the upgrade.
    I'm doing only the Daily Contracts to get Opals, coz I won't put my time into it and realize this its an insoluble problem (this post is from 17nov2020)
    Devs are more the 1 month to solve it.

    Suggestion: add 1 NPC to rebuild the settlement or unbuild, rebuild, kick out, and invite NPCs.

  • rudge03
    2 posts
    This post is deleted!
  • Esyke
    2 posts

    Hi guys! I had the same problem, but finishing the Valka quest fixed it for me. Which was also broken lol, she stopped midway through. So I used a horse to herd her to her tent and now its fine.

  • rudge03
    2 posts

    My NPC problem is fixed, might not help everyone as from what iv read it occurs at different stages, I had a valka mission bug where she stopped at the top of the hill and couldn't communicate with NPC s, I went into the great hall and there was a woman there who had been robbed and offered a mission guthrum the baker when i finished that the valka mission worked and then after that my npc were back, as i say might not help everyone its seems that the guthrum side mission was stopping everything for me.

Suggested Topics

Community Details

119
Online
195.0k
Users
33.0k
Topics
164.8k
Posts