Welcome to discussions

Quick Suggestions

  • HojoJames22
    2 posts

    Playing on PS4.

    I've got to the point of periodically loading up the game to see if I anything changes or to try a quick fix for a bug. Very annoying now and rather unfortunate. I've just had another look now and apart from having the issue of no settlement npc interaction, I now can't use my raven.

    I'll putting the game down again until the next update. I really wanted to go through the yule event but I can't be bothered with it as it seems like issue are piling up with the increase in content.

    I'll hold out for a refund, if I can still get one, as I'd like to see the product fixed so I can play on. But If no improvements are made soon with some sort of update then I'll have to give up.


  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • Dclark5891
    5 posts

    I had the issues of not being able to talk to npcs on my first playthrough. In that playthrough I did the berserker mission. On my second playthrough I avoided the berserker mission and have had no issues. The problem as I've seen many state is in the completion of that mission. Avoid doing it at all costs.

  • KubaPac321123
    1 posts

    Unable to speak to any npc in ravensthrope. Its so anoying you just cant do anything in the village

  • Darksilver355
    1 posts

    -I cant speak to any npc in hreafnathorp.
    if i go to another city i can speak with a shopkeaper

    -I'm in the middle of the quest: a wise friend and valka always stops moving at the same place and i cant continiue the quest

    could you pls help me with my problems

  • sheedali
    1 posts

    Just fix this problem already Ubisoft PLEASE!

  • Schakoww
    5 posts

    I starting to distrust this problem begins when you do the upgrade from level 3 to level 4.

  • LethalRabbid
    8 posts

    @dclark5891 for me, it started before completion of that quest, after upgrading my settlement to lvl 3. However, I did this just before the yule festival and did not pay attention to the npcs then, so I can't really relate it to exactly one thing... except perhaps getting the beserker quest, because I accepted it around the same time of my settlement lvling up , and since I have seen many people pointing at that particular quest, that may indeed be the culprit here...

    Do you remember if you accepted the quest in your new playthrough? As to avoid me starting over and the theories are proven wrong and screwing up my game again? 😁

  • Schakoww
    5 posts


    It is possibly be related to Berserker`s quest, I bought it with U tokens and I just read the letter in my room, after I did the upgrade.
    I'm doing only the Daily Contracts to get Opals, coz I won't put my time into it and realize this its an insoluble problem (this post is from 17nov2020)
    Devs are more the 1 month to solve it.

    Suggestion: add 1 NPC to rebuild the settlement or unbuild, rebuild, kick out, and invite NPCs.

  • rudge03
    2 posts
    This post is deleted!
  • Esyke
    2 posts

    Hi guys! I had the same problem, but finishing the Valka quest fixed it for me. Which was also broken lol, she stopped midway through. So I used a horse to herd her to her tent and now its fine.

  • rudge03
    2 posts

    My NPC problem is fixed, might not help everyone as from what iv read it occurs at different stages, I had a valka mission bug where she stopped at the top of the hill and couldn't communicate with NPC s, I went into the great hall and there was a woman there who had been robbed and offered a mission guthrum the baker when i finished that the valka mission worked and then after that my npc were back, as i say might not help everyone its seems that the guthrum side mission was stopping everything for me.

  • The_First_Robbo
    1 posts

    Some information regarding a patch/update would be fantastic! Cant interact with multiple npc's in ravensthorpe makes playing the game and trying to achieve 100% pretty pointless.

  • OliTay11
    3 posts

    I have the same issues could never talk to shipyard person and cant talk to trader anymore

  • smithy10GB
    Original poster 70 posts

    @lethalrabbid I get it but there is a line between customer satisfaction and straight up stealing.

    It's no different than if I sold ubisoft a TV with half the screen not working, it's shocking how we can't get a refund at this point.

    In adherence to the consumer rights act the product is faulty and does not serve the purpose it was intended for, pretty sure this also counts as false advertising since we cannot access the content advertised.
    It just seems like the only way to get a company like this to listen is a court case.

    At this point it would make me happy to see them sued, there is a global pandemic, everyone is struggling and ubisoft thinks its alright to just take money for, what is at this point, basically nothing.

    Let me make this clear, what I Purchased, not donated to, was a complete game, not an early access/game preview game.
    As such I would like a complete product, it has been almost 6 weeks and ubisoft still can't fix the issue.

    Sorry I said can't but let's be honest they really don't give a damn otherwise they would have focused the bugs and not the event.

  • LethalRabbid
    8 posts

    @smithy10gb yeah, I completely agree with that statement. And it's just sad how customer satisfaction is being handled, again I totally agree with you.

  • niccover
    3 posts

    After completing the Ledecestrescire quest I can't speak with no one in the settlement and I can't do nothing in Yule Festival (so it is a total useless event, thank you Ubisoft)..

    I've killed some soldiers that appeared (I thing is the danish attack mission, but is not shown in the missions menu) but nothing happened after...

  • XxdariusXDRO
    3 posts

    @esyke how do i get her on the horse help me i have 2 hours left before Reda changes the items and i lose the hammer

  • ychagnon
    1 posts

    I started Valka quest to carry her stuff to her new house.

    She talked to the blacksmith and then totally get stuck near the Long House because Randvi is not there to talk to her.

    And now i noticed i could not interact with anything at all in the village. Everything is stuck and when i reload it always takes me back to that Valka quest i cant complete.

    Game is totally pointless if i cant do anything in the settlement. I cant turn in any quest or trade anything.

    I call that a gamebreaking bug and a total showstopper. ( I play on PC by the way ).

    Very disappointed.

  • D3neS_1997
    1 posts

    @ychagnon Its doin the same for me... I have stuck with the missons, I cant do anything, im so fckin dissappointed....

  • rafa.afp
    2 posts

    Same here, any solution already ?

Suggested Topics

Community Details