Welcome to discussions

Quick Suggestions

  • The_First_Robbo
    1 posts

    Some information regarding a patch/update would be fantastic! Cant interact with multiple npc's in ravensthorpe makes playing the game and trying to achieve 100% pretty pointless.

  • OliTay11
    3 posts

    I have the same issues could never talk to shipyard person and cant talk to trader anymore

  • smithy10GB
    Original poster 70 posts

    @lethalrabbid I get it but there is a line between customer satisfaction and straight up stealing.

    It's no different than if I sold ubisoft a TV with half the screen not working, it's shocking how we can't get a refund at this point.

    In adherence to the consumer rights act the product is faulty and does not serve the purpose it was intended for, pretty sure this also counts as false advertising since we cannot access the content advertised.
    It just seems like the only way to get a company like this to listen is a court case.

    At this point it would make me happy to see them sued, there is a global pandemic, everyone is struggling and ubisoft thinks its alright to just take money for, what is at this point, basically nothing.

    Let me make this clear, what I Purchased, not donated to, was a complete game, not an early access/game preview game.
    As such I would like a complete product, it has been almost 6 weeks and ubisoft still can't fix the issue.

    Sorry I said can't but let's be honest they really don't give a damn otherwise they would have focused the bugs and not the event.

  • LethalRabbid
    8 posts

    @smithy10gb yeah, I completely agree with that statement. And it's just sad how customer satisfaction is being handled, again I totally agree with you.

  • niccover
    3 posts

    After completing the Ledecestrescire quest I can't speak with no one in the settlement and I can't do nothing in Yule Festival (so it is a total useless event, thank you Ubisoft)..

    I've killed some soldiers that appeared (I thing is the danish attack mission, but is not shown in the missions menu) but nothing happened after...

  • XxdariusXDRO
    3 posts

    @esyke how do i get her on the horse help me i have 2 hours left before Reda changes the items and i lose the hammer

  • ychagnon
    1 posts

    I started Valka quest to carry her stuff to her new house.

    She talked to the blacksmith and then totally get stuck near the Long House because Randvi is not there to talk to her.

    And now i noticed i could not interact with anything at all in the village. Everything is stuck and when i reload it always takes me back to that Valka quest i cant complete.

    Game is totally pointless if i cant do anything in the settlement. I cant turn in any quest or trade anything.

    I call that a gamebreaking bug and a total showstopper. ( I play on PC by the way ).

    Very disappointed.

  • D3neS_1997
    1 posts

    @ychagnon Its doin the same for me... I have stuck with the missons, I cant do anything, im so fckin dissappointed....

  • rafa.afp
    2 posts

    Same here, any solution already ?

  • rafa.afp
    2 posts

    @xxdariusxdro Did you manage? i cant belive it really worked. you get on your horse, and by going with the horse above her, she will move little by little

  • Schakoww
    5 posts

    Well I opened a ticket and they replayed.

    Sort version: " will be fix with next update".

    So let's wait! I Feel sorry for you @smithy10GB, I'm waiting 2 days and I'm in despair, imagine you waiting more than 1 month. You should receive bonus contents plus 30.000 Helix.

  • Gruffley
    1 posts

    Hello everyone!

    I'm having this exact issue, and it's especially annoying to me because I need to talk to Randvi in order to continue the story.

    Is there any news about when this patch will be released?

    Thank you.

  • RastafComa
    5 posts

    Hello folks, 

    I also had the problem that I could no longer talk to the NPCs in the camp. In addition, I had the quest with Valka active, so where you have to drag her stuff to her accommodation. She then just stops in the middle of the mountain without going further, and every time I started this quest. 
    The solution to both problems was to build the seer's hut in the camp. After that you can accompany valka with her stuff to the hut and after completing this quest also talk to the other NPCs again even with Reda. 
    I hope that solves the problem for you. 

  • XxdariusXDRO
    3 posts


  • XxdariusXDRO
    3 posts

    @rafa-afp know what i am unninstalling add me on discord XxDariusXD#3876 and tell me when the bug is out
    hate new games

  • QueenFriday
    2 posts

    I had the same issue. No ability to do Yule quests or progress in quests. Valka moved in and climbed the hill then stopped. Building the seer's house did nothing to change that. Complete impasse and very frustrated. I'd finished one alliance arc (Grantsbridge) and spoken to Randi. My settlement was a level 3. I've seen several postings blaming the Berserker quest. I didn't preorder so likely don't have it, at the very least, I hadn't accepted it. So that's not the culprit. For me, seemed to be related to village levelling or the Yule festival.
    I started again and am avoiding leveling Ravensthorpe and going there during the Yule festival. Am running through the world as a new Eivor waiting patiently for an update/fix or for the end of the Yule event mid-January. Consider me wandering and homeless for now.
    Anyone stuck with a low level village?

  • LethalRabbid
    8 posts

    @rastafcoma tried that, did not work 😞
    Glad it did work for you though...!

  • jonthegeerf
    1 posts

    the title pretty much sums it up. I was researching this, and I found a solution that didn’t work. I hope you can fix this in the next patch. Thank you.

  • LukeeeSkywalker
    7 posts

    Same issue for me on Series X. Powerlevel 400 +13 after finished the main story and clearing Lincolnescir everyone in the camp stopped talking to me. After 125 Hours the game ended itself for me. It seems thar it is possible to unbug it for two interactions switching to main menue and reload last safegame. Tattoo and witch lady (on a horse) are permanently broken. Village Level is almost 6.
    Read the howl post and I'm heartbroken that this issue is pending since the start of November!
    If Xbox users can contribute please keep me updated. Looking forward to finish this beautiful bugged game 😉

  • Vexilatio.
    3 posts

    Cant progress quest. bring valka plants shes stuck on a horse and unable to talk.

    Cant bring roman artifacts since he cant be talked to either.

    Xbox one S

    102hours into the game

Suggested Topics