Welcome to discussions

Quick Suggestions

  • FilipeBranco06
    1 posts

    So yesterday i just finished the quest where you help sigurd and two brothers dethrone the king of Mercia. I got back to my settlement and upgraded it to lvl 3, after that i couldnt talk to anyone in my settlement besides Petra in the hunting lodge. This is very frustrating because I payed full price for the game and i cannot advance in the story because i cannot talk to Randvi so i can progress in the game. Is there anything i can do to fix this? And when i start the quest with valka getting her stuff to her new home she gets stuck halfway through and doesnt move, so i cant finish that mission as well. And yes I have finished the quest of setteling in

  • Ubi-Borealis
    Ubisoft Support Staff 2894 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • CostlyTurtle336
    8 posts

    Since I began the “A Wise Friend” quest, in which Valka stopped walking halfway to her destination, I have been unable to interact with ANYONE in my settlement that isn’t Yule-quest related. I’m talking no blacksmith, barracks, Hytham, shipyard, I can’t interact with Randvi to see the alliance map and therefore cannot start the story quest where I need to go meet Sigurd to get my second alliance. When the issue started I was at around 30 hours of gameplay and now am at 40. This is SO frustrating, these glitches and bugs are debilitating to the point where I can’t even play the game without fear that I’ll have to lose all the progress to solve this glitch regardless. Even worse is that I see online this issue has been ongoing for 50+ days and I have little to no hope of a resolution given that every single page on this Ubisoft website glitches out too. True quality, and I’m so frustrated because AC is the only franchise I even like to play, for the love of god this is what, game 17? In the series? Should have it together by now, and release a fix for this game-ending issue ASAP.

  • Amarie1979
    2 posts

    Is there still no fix for not being able to speak to Wallace the tanner at the settlement? Looks like this has been happening a while. Yes. I have finished the Valka mission.

  • CostlyTurtle336
    8 posts
    This post is deleted!
  • KyraDrachenlady
    5 posts

    @kyanep THe tip was good, but i used a slight different wa. i shoved the Seer to her hut, did the Asgard quest and now i can finally talk with all the ppl of the Village!

  • kyanep
    4 posts

    @CostlyTurtle336

    Did you tried the workaround I suggested in this post ?

    @Ubi-Woofer

    You seems to follow this issue so I ping you because I think I might have a workaround that work for a several people (not all people thought).
    Check this post, if you want I can provide a more detailed description of the issue, you can contact me through my support ticket N°13648454 (French support).
    You know better than me what your work is, but I guess you can add this workaround in several location :

    • pinned to this forum thread
    • in the know issues list
    • maybe in the FAQ area of the support website, for people trying to open a case


    I don't know if development team started to investigate (because it is a real bug that break the entire game experience, even if the workaround works), but I guess you can tell them that, for some people, the bug is because the conflict between "A wise friend" quest and a Randvi quest (inside longhouse), both quests required Randvi on different location. Might help to find the bug and to fix, I don't know.

  • lewisstorer89
    19 posts

    my NPC bug is nothing to do with Valka. The fact that alot have this bug because of her, but others like me have it too without it being due to her - shows how big this issue really is.

    Shocking there is no fix yet. Disgusting actually.

    I can speak to her and go to and from Asgard no problem. She always hangs around in and outside her hut and getting her there with her luggage was no problem for me.

  • Y2john84
    48 posts

    @lewisstorer89 absolutely!

  • niccover
    3 posts

    I tried for the second time to speak (starting with and old saving) with Randvi but after that (and after my settlement update to level 4) the problem was the same (no active NPCs, Yule Festival impossible to use); so I left the game and reloaded the latest game save that I had (I saved just before speaking with Randvi, but I'm not sure if the reloading was my saving or the automatic one) and this resolved the problem, the game started with the feast and the following Danish attack...now I can speak again with every one.

    I never had problems with Valka's quest.

    Hope this can help someone, while Ubisoft is doing nothing..

  • kymbeee
    3 posts

    @lewisstorer89 same here, I never had any problems with Valka or going to Asgard. I can interact with some settlement NPCs but not all, most importantly I can’t interact with the quartermaster (barracks) or the shipyard. So far the the blacksmith is still okay. I last played just after the Yule festival started and that’s where things were at with my settlement NPCs, but starting up drunk each time and having the damn Mari Lywd cloak and horse skull stuck on my face (from bug in Glowecesterscire arc) was the last blow, particularly since my next stop was supposed to be Vinland, where it’s my understanding there’s a lovely quiver bug for me to catch.

    Get your [censored] together please Ubisoft, I’d like to play this game of yours that I paid a LOT of money for.

  • Mr_Croftman
    1 posts

    I am also having the same issues on PC, problem connecting to servers, and I can not interact with any of the nps's at the settlement. Probably
    going to stop playing until there is a patch!

  • BlackDog1247
    2 posts

    Sent a support ticket, but I am also unable to interact with anybody after completing all the tasks with the Ragnarsons. Have been unable to complete the Valka mission for some time now, she just stops and stands at the longhouse and looks at it.

    I'm on PC.

  • tantron57
    1 posts

    I cannot talk to Wallace to have my beasts mounted. I was romancing Petra and tried breaking up with her to fix this but it didn’t work any ideas?

  • swampmaster
    1 posts

    @kyanep Thanks for this! I also had the stuck Valka bug, but initially it didn't affect any other NPCs and online forums suggested it would fix itself eventullay if I kept on upgrading the settlement, so I kept playing. However after I built the Bakery and did the Baker's quests, and then Petra's finding Wallace quest, I stopped being able to interact with most NPCs, including Randvi. That's when I got worried, went looking for additional info online and found this thread.

    The back and forth to Norway and pushing Randvi down the path solution worked to fix the Valka quest, and now all NPCs seem to be available again. Yeh for me! I do want to say though that I fully agree with most of the posters on this thread who have been waiting months for a fix that a bug of that magnitude is just inacceptable and should at the very least entitle people who cannot get a fix for it to a full refund. This was my fist time playing a Ubisoft game in a while because I'd gotten fed up with the bugginess of past titles, and I came back because I'd heard only good comments about Valhalla. Apparently I should have dug deeper...

    For the time being I'll keep playing and hope this was my only close brush with buggy death, but I'm not going to make the mistake of buying another big title from Ubisoft any time soon.

  • KaatdJ
    1 posts

    I'm on PS4, my settlement level is 5, but the problem occurred earlier. When I just built the shipyard and the barracks I was able to interact with them. However after the recruitment of the beserker i noticed that this was no longer the case.
    So I cannot interact with barracks, shipyard, fisher, cartographer, stables
    Some of these were built before and some after.

  • guest-cK3p0xCp
    1 posts

    I cannot speak to Blacksmith, Shop, or Assassin’s Bureau. Help!

  • Y2john84
    48 posts

    The valka bug was nothing to do with my npc problem, I've completed all valka missions (the dream world missions). I've not been able to speak to x5 npc's ever since completing the berserker add on mission near release day 1 of the game. The Yuletide missions worked at first, then the fighters spawned and killed plenty of my settlement dwellers, now when I go to a yuletide fight, the first fighter spawns dead and freezes the game. This is outrageous ubisoft, I've been playing £30 worth of a £70 game for months now, there is no defence now! I'm NEVER buying ubisoft again, and I've been with assassins creed from the very beginning, I'm gutted!

  • lewisstorer89
    19 posts

    @y2john84 exact same situation to me bro 😞

    I adored Origins.
    Liked Odyssey to begin with then got bored
    first few hours of Valhalla felt like a return to form.....but this issue is so bad, and its annoyed me so much, Im likely in the same boat (not buying a Ubi game again)
    We have wanted refunds for months and we simply wont get them.
    Disgusting.

  • Y2john84
    48 posts
    This post is deleted!
  • Y2john84
    48 posts

    @lewisstorer89 yep, it's game over mate

Suggested Topics

Community Details

123
Online
142.4k
Users
25.2k
Topics
130.4k
Posts