Welcome to discussions

Quick Suggestions

  • QueenFriday
    2 posts
    This post is deleted!
  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello all!

    I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein settlement NPCs couldn't be interacted with is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.

    If you are still encountering issues when interacting with settlement NPCs following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:
    - You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    - The issue still occuring in-game.

    Thanks! 😊

    Official Response
  • PINO7610
    1 posts

    Same here, npc fishboy barracks and shipyard not responding. Next to that I’m always drunk when I start the game 😄

  • kyanep
    4 posts

    I tried @rudge03 solution with no success. Valka is still bugging and can't talk to any NPC

  • kyanep
    4 posts

    Ok I manage to fixed the bug, for me it was because of the valka quest being stuck. I just made what you can see on this video :

    It allow me to fix Valka quest, and I now can talk to NPCs. To sum up :

    1) Build the house for Valka in settlement (level 3 required)
    2) Travel to Norway (using Atlas)
    3) Go back to settlement, you can see Radvi outside to the longhouse
    4) Using your horse, push Radvi in the path of Valka (check the video)
    5) Go get Valka and follow the quest.

    After this quest, I was able to talk to NPC again.

  • Y2john84
    48 posts

    Now I can't speak to ANY npc! And I try to fight in the yuletide event, and my first fighter spawns dead and my game freezes! This is absurd! 100hrs wasted! What's worse is you say you have the fix! So why isn't it downloading to my ps4? This should be a hotfix, not scheduled for a bulk download with other fixes, it's been months now!!!!!

  • GrunnyG2008
    3 posts


    Same issue on xbox, I was in the middle of the quest where you take the seer's box to her house and she just stops. I can't speak to anyone anywhere. Here's what I have completed:
    Hunter's house
    I also can't talk to the lady in the longhouse to advance the alliance quest either.

  • GrunnyG2008
    3 posts

    So these problems have been going on for over a month and you haven't fixed them yet. Great.
    I'm playing on an xbox one s
    My settlement is level 2.
    I have been doing a mix of side quests and the main story.
    I was working on the "a wise friend" quest. Valka stops at the top of the hill, will not move and even when you drop the crate at her house, nothing happens. It was after this that the NPC's stopped interacting with me.

  • jecolson
    1 posts

    Playing on PC. After the "A Wise Friend" quest option, Valka gets stuck at the top of the hill, since starting that quest I have been unable to speak to any NPCs, including those in the Longhouse.

  • Taeghen11
    1 posts

    @kyanep Thanks for posting the video. I had the same problem, quest bugged and not able to talk to any NPCs. Did what the video said and now everything is working right again.

  • LethalRabbid
    8 posts

    @kyanep woaah, magnificent!!!
    This worked for me! Thank you!

  • Nyugathat
    1 posts


    Cool....exactly that was it. I followed your instructions and ...I was able to complete the Valka quest and after that all the dialog options in the settlement were available again.

    Thanks for that 🙂

  • Y2john84
    48 posts

    @kyanep I've completed valka quests and no npc works in my settlement

  • FilipeBranco06
    1 posts

    So yesterday i just finished the quest where you help sigurd and two brothers dethrone the king of Mercia. I got back to my settlement and upgraded it to lvl 3, after that i couldnt talk to anyone in my settlement besides Petra in the hunting lodge. This is very frustrating because I payed full price for the game and i cannot advance in the story because i cannot talk to Randvi so i can progress in the game. Is there anything i can do to fix this? And when i start the quest with valka getting her stuff to her new home she gets stuck halfway through and doesnt move, so i cant finish that mission as well. And yes I have finished the quest of setteling in

  • CostlyTurtle336
    8 posts

    Since I began the “A Wise Friend” quest, in which Valka stopped walking halfway to her destination, I have been unable to interact with ANYONE in my settlement that isn’t Yule-quest related. I’m talking no blacksmith, barracks, Hytham, shipyard, I can’t interact with Randvi to see the alliance map and therefore cannot start the story quest where I need to go meet Sigurd to get my second alliance. When the issue started I was at around 30 hours of gameplay and now am at 40. This is SO frustrating, these glitches and bugs are debilitating to the point where I can’t even play the game without fear that I’ll have to lose all the progress to solve this glitch regardless. Even worse is that I see online this issue has been ongoing for 50+ days and I have little to no hope of a resolution given that every single page on this Ubisoft website glitches out too. True quality, and I’m so frustrated because AC is the only franchise I even like to play, for the love of god this is what, game 17? In the series? Should have it together by now, and release a fix for this game-ending issue ASAP.

  • Amarie1979
    2 posts

    Is there still no fix for not being able to speak to Wallace the tanner at the settlement? Looks like this has been happening a while. Yes. I have finished the Valka mission.

  • CostlyTurtle336
    8 posts
    This post is deleted!
  • KyraDrachenlady
    5 posts

    @kyanep THe tip was good, but i used a slight different wa. i shoved the Seer to her hut, did the Asgard quest and now i can finally talk with all the ppl of the Village!

  • kyanep
    4 posts


    Did you tried the workaround I suggested in this post ?


    You seems to follow this issue so I ping you because I think I might have a workaround that work for a several people (not all people thought).
    Check this post, if you want I can provide a more detailed description of the issue, you can contact me through my support ticket N°13648454 (French support).
    You know better than me what your work is, but I guess you can add this workaround in several location :

    • pinned to this forum thread
    • in the know issues list
    • maybe in the FAQ area of the support website, for people trying to open a case

    I don't know if development team started to investigate (because it is a real bug that break the entire game experience, even if the workaround works), but I guess you can tell them that, for some people, the bug is because the conflict between "A wise friend" quest and a Randvi quest (inside longhouse), both quests required Randvi on different location. Might help to find the bug and to fix, I don't know.

  • lewisstorer89
    19 posts

    my NPC bug is nothing to do with Valka. The fact that alot have this bug because of her, but others like me have it too without it being due to her - shows how big this issue really is.

    Shocking there is no fix yet. Disgusting actually.

    I can speak to her and go to and from Asgard no problem. She always hangs around in and outside her hut and getting her there with her luggage was no problem for me.

  • Y2john84
    48 posts

    @lewisstorer89 absolutely!

Suggested Topics

Community Details